aboutsummaryrefslogtreecommitdiff
path: root/comms/gammu-devel
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-26 19:41:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-26 19:41:29 +0000
commitc6be53fee5a989780c8d0e8b14e163328bee8470 (patch)
tree068d842cc5a0dbb7a76ca1c574759ac59f12438c /comms/gammu-devel
parent7156d6958cf9ebeb74ddc63607936905f11374d4 (diff)
downloadports-c6be53fee5a989780c8d0e8b14e163328bee8470.tar.gz
ports-c6be53fee5a989780c8d0e8b14e163328bee8470.zip
Notes
Diffstat (limited to 'comms/gammu-devel')
-rw-r--r--comms/gammu-devel/Makefile6
-rw-r--r--comms/gammu-devel/distinfo4
-rw-r--r--comms/gammu-devel/files/patch-bluetooth27
-rw-r--r--comms/gammu-devel/files/patch-cfg-Makefile.glo19
-rw-r--r--comms/gammu-devel/files/patch-configure.in25
-rw-r--r--comms/gammu-devel/pkg-plist7
6 files changed, 47 insertions, 41 deletions
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 35c989e7c6ab..29d000387979 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= gammu
-PORTVERSION= 1.00.0
-PORTREVISION= 1
+PORTVERSION= 1.01.0
CATEGORIES= comms
-MASTER_SITES= http://www.kirill.spb.ru/gammu/
+MASTER_SITES= http://www.mwiacek.com/zips/gsm/gammu/stable/1_0x/
MAINTAINER= kirill@solaris.ru
COMMENT= GNU All Mobile Management Utilities
@@ -19,6 +18,7 @@ USE_GMAKE= yes
USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
WANT_AUTOCONF_VER=259
+INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-bluerfsearch
CONFIGURE_ENV= CFLAGS="${CFLAGS} -fPIC"
diff --git a/comms/gammu-devel/distinfo b/comms/gammu-devel/distinfo
index 0a0dea446848..51c6f4098330 100644
--- a/comms/gammu-devel/distinfo
+++ b/comms/gammu-devel/distinfo
@@ -1,2 +1,2 @@
-MD5 (gammu-1.00.0.tar.gz) = 9d921f9c5b6f3b8b76a69720e2d9f173
-SIZE (gammu-1.00.0.tar.gz) = 850872
+MD5 (gammu-1.01.0.tar.gz) = 1ae9d7d51158c9f0cb5d3b25e7e7e1e1
+SIZE (gammu-1.01.0.tar.gz) = 860546
diff --git a/comms/gammu-devel/files/patch-bluetooth b/comms/gammu-devel/files/patch-bluetooth
index 0e1f685e3c80..1e698a060071 100644
--- a/comms/gammu-devel/files/patch-bluetooth
+++ b/comms/gammu-devel/files/patch-bluetooth
@@ -1,20 +1,7 @@
-diff -ur orig/bluetoth.c patched/bluetoth.c
---- common/device/bluetoth/bluetoth.c Thu Nov 25 12:36:26 2004
-+++ common/device/bluetoth/bluetoth.c Thu Nov 25 12:46:22 2004
-@@ -30,9 +30,6 @@
- {
- GSM_Error error;
-
--#ifdef BLUETOOTH_RF_SEARCHING
-- if (!mystrncasecmp(s->CurrentConfig->Connection, "bluerf", 6)) return bluetooth_findchannel(s);
--#endif
-
- switch (s->ConnectionType) {
- case GCT_BLUEAT:
-diff -ur common/device/bluetoth/bluez.c common/device/bluetoth/bluez.c
---- common/device/bluetoth/bluez.c Thu Nov 25 12:36:26 2004
-+++ common/device/bluetoth/bluez.c Thu Nov 25 12:46:56 2004
-@@ -14,6 +14,8 @@
+diff -ru ../gammu-1.01.0.orig/common/device/bluetoth/bluez.c common/device/bluetoth/bluez.c
+--- ../gammu-1.01.0.orig/common/device/bluetoth/bluez.c Thu Mar 10 10:35:58 2005
++++ common/device/bluetoth/bluez.c Sat Jul 9 12:46:07 2005
+@@ -23,6 +23,8 @@
#ifdef GSM_ENABLE_BLUETOOTHDEVICE
#ifdef GSM_ENABLE_BLUEZ
@@ -23,7 +10,7 @@ diff -ur common/device/bluetoth/bluez.c common/device/bluetoth/bluez.c
#include <stdlib.h>
#include <stdio.h>
#include <fcntl.h>
-@@ -22,10 +24,7 @@
+@@ -31,10 +33,7 @@
#include <sys/socket.h>
#include <sys/time.h>
#include <unistd.h>
@@ -35,7 +22,7 @@ diff -ur common/device/bluetoth/bluez.c common/device/bluetoth/bluez.c
#include "../../gsmcomon.h"
#include "../devfunc.h"
-@@ -34,21 +33,21 @@
+@@ -43,21 +42,21 @@
GSM_Error bluetooth_connect(GSM_StateMachine *s, int port, char *device)
{
GSM_Device_BlueToothData *d = &s->Device.Data.BlueTooth;
@@ -62,7 +49,7 @@ diff -ur common/device/bluetoth/bluez.c common/device/bluetoth/bluez.c
if (bind(fd, (struct sockaddr *)&laddr, sizeof(laddr)) < 0) {
dbgprintf("Can't bind socket\n");
-@@ -57,9 +56,9 @@
+@@ -66,9 +65,9 @@
}
str2ba(device, &bdaddr);
diff --git a/comms/gammu-devel/files/patch-cfg-Makefile.glo b/comms/gammu-devel/files/patch-cfg-Makefile.glo
index 0d5709a1957e..80567a309457 100644
--- a/comms/gammu-devel/files/patch-cfg-Makefile.glo
+++ b/comms/gammu-devel/files/patch-cfg-Makefile.glo
@@ -1,5 +1,5 @@
---- cfg/Makefile.glo.orig Sat Jan 15 17:01:28 2005
-+++ cfg/Makefile.glo Thu Mar 24 13:13:31 2005
+--- ../gammu-1.01.0.orig/cfg/Makefile.glo Tue Apr 12 15:26:08 2005
++++ cfg/Makefile.glo Sat Jul 9 22:24:39 2005
@@ -122,7 +122,7 @@
@echo Making $<
@$(CC) -c $(CFLAGS) -I$(TOPDIR)/common/ $(CPPFLAGS) $*.c -o $*.o
@@ -9,7 +9,16 @@
$(TOPDIR)/gammu/gammu: $(COMMON) $(GAMMU)
@echo Linking gammu
-@@ -227,7 +227,7 @@
+@@ -136,7 +136,7 @@
+
+ $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR): $(COMMON)
+ @echo Linking libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR)
+- @$(CC) $(LDLIBS) -shared -Wl,-soname -Wl,libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) -o $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) $(COMMON)
++ @$(CC) $(LDLIBS) -shared -Wl,-soname -Wl,libGammu.so.$(SONAME_MAJOR) -o $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) $(COMMON)
+ @$(LN) -s libGammu.so.$(SONAME_MAJOR).$(SONAME_MINOR) $(TOPDIR)/common/libGammu.so.$(SONAME_MAJOR)
+ @$(LN) -s libGammu.so.$(SONAME_MAJOR) $(TOPDIR)/common/libGammu.so
+
+@@ -230,7 +230,7 @@
@$(INSTALL) -m 0644 $(TOPDIR)/docs/docs/english/gammu.1 $(DESTDIR)$(INSTALL_MAN_DIR)
@$(RM) $(DESTDIR)$(INSTALL_DOC_DIR)/docs/english/gammu.1
@@ -18,7 +27,7 @@
installonly: all
@echo Installing binaries to $(DESTDIR)$(INSTALL_BIN_DIR)
-@@ -244,8 +244,7 @@
+@@ -247,8 +247,7 @@
@echo Installing shared library to $(DESTDIR)$(INSTALL_LIB_DIR)
@$(INSTALL) -m 0755 -d $(DESTDIR)$(INSTALL_LIB_DIR)
@@ -28,7 +37,7 @@
@$(LN) -s libGammu.so.$(SONAME_MAJOR) $(DESTDIR)$(INSTALL_LIB_DIR)/libGammu.so
@echo Installing static library to $(DESTDIR)$(INSTALL_LIB_DIR)
-@@ -264,8 +263,8 @@
+@@ -267,8 +266,8 @@
@$(INSTALL) -m 0644 cfg/config.h $(DESTDIR)$(INSTALL_H_DIR)/config.h
@echo Installing pkgconfig file
diff --git a/comms/gammu-devel/files/patch-configure.in b/comms/gammu-devel/files/patch-configure.in
index 03bdd0a17fb2..14989aac2ef2 100644
--- a/comms/gammu-devel/files/patch-configure.in
+++ b/comms/gammu-devel/files/patch-configure.in
@@ -1,11 +1,11 @@
---- cfg/autoconf/configure.in.orig Sat Jan 15 13:45:26 2005
-+++ cfg/autoconf/configure.in Thu Apr 14 08:27:47 2005
+--- ../gammu-1.01.0.orig/cfg/autoconf/configure.in Tue Mar 8 19:16:22 2005
++++ cfg/autoconf/configure.in Sat Jul 9 12:51:12 2005
@@ -185,17 +185,17 @@
fi
if test "$gsm_blue_stack" = unknown ; then
AC_CHECK_HEADERS(bluetooth/bluetooth.h,
- [gsm_blue_stack=Bluez
-+ [gsm_blue_stack=FreeBSD
++ [gsm_blue_stack=FreeBSD
LDLIBS="$LDLIBS -lbluetooth"
AC_CHECK_LIB(sdp, sdp_list_append, LDLIBS="$LDLIBS -lsdp")
AC_DEFINE(GSM_ENABLE_BLUEZ)
@@ -21,7 +21,7 @@
[ if test x$withval = xyes; then
AC_MSG_WARN(Usage is: --with-bluedir=DIR)
else
-@@ -287,7 +287,7 @@
+@@ -292,7 +292,7 @@
[ --disable-bluefbus Disable Nokia FBUS2 over Bluetooth stack
(Nokia 6210)],
[gsm_enable_bluefbus2="no"],
@@ -30,7 +30,7 @@
AC_DEFINE(GSM_ENABLE_BLUEFBUS2)
gsm_enable_bluefbus2="yes"
else
-@@ -297,7 +297,7 @@
+@@ -302,7 +302,7 @@
[ --disable-bluephonet Disable Nokia PHONET FBUS over Bluetooth
stack (all new Nokias)],
[gsm_enable_bluephonet="no"],
@@ -39,7 +39,7 @@
AC_DEFINE(GSM_ENABLE_BLUEPHONET)
gsm_enable_bluephonet="yes"
else
-@@ -306,7 +306,7 @@
+@@ -311,7 +311,7 @@
AC_ARG_ENABLE(blueat,
[ --disable-blueat Disable AT commands over Bluetooth stack],
[gsm_enable_blueat="no"],
@@ -48,7 +48,7 @@
AC_DEFINE(GSM_ENABLE_BLUEAT)
gsm_enable_blueat="yes"
else
-@@ -315,7 +315,7 @@
+@@ -320,7 +320,7 @@
AC_ARG_ENABLE(blueobex,
[ --disable-blueobex Disable OBEX over Bluetooth stack],
[gsm_enable_blueobex="no"],
@@ -57,7 +57,16 @@
AC_DEFINE(GSM_ENABLE_BLUEOBEX)
gsm_enable_blueobex="yes"
else
-@@ -438,7 +438,7 @@
+@@ -355,7 +355,7 @@
+ AC_ARG_ENABLE(bluerfsearch,
+ [ --disable-bluerfsearch Disable searching for RF channels with Bluetooth stack],
+ [gsm_enable_bluerfsearch="no"],
+- [if test $gsm_blue_stack = Bluez; then
++ [if test $gsm_blue_stack = FreeBSD; then
+ AC_DEFINE(BLUETOOTH_RF_SEARCHING)
+ gsm_enable_bluerfsearch="yes"
+ fi])
+@@ -443,7 +443,7 @@
Binaries - $bindir
RPM making directory - $RPM_DIR
Temporary directory - $TEMP_DIR
diff --git a/comms/gammu-devel/pkg-plist b/comms/gammu-devel/pkg-plist
index 5550ee8e0484..7a1c85bffd02 100644
--- a/comms/gammu-devel/pkg-plist
+++ b/comms/gammu-devel/pkg-plist
@@ -64,9 +64,9 @@ include/gammu/phone/nokia/dct3/n9210.h
include/gammu/phone/nokia/dct4/dct4func.h
include/gammu/phone/nokia/dct4/n3320.h
include/gammu/phone/nokia/dct4/n3650.h
-include/gammu/phone/nokia/dct4/n6510.h
-include/gammu/phone/nokia/dct4/6510cal.h
-include/gammu/phone/nokia/dct4/6510file.h
+include/gammu/phone/nokia/dct4/6510/6510cal.h
+include/gammu/phone/nokia/dct4/6510/6510file.h
+include/gammu/phone/nokia/dct4/6510/n6510.h
include/gammu/phone/obex/obexgen.h
include/gammu/phone/symbian/mroutgen.h
include/gammu/protocol/protocol.h
@@ -109,6 +109,7 @@ include/gammu/service/sms/gsmsms.h
@dirrm include/gammu/phone/symbian
@dirrm include/gammu/phone/obex
@dirrm include/gammu/phone/nokia/dct3
+@dirrm include/gammu/phone/nokia/dct4/6510
@dirrm include/gammu/phone/nokia/dct4
@dirrm include/gammu/phone/nokia
@dirrm include/gammu/phone/at