aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii/files
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-10-26 01:35:09 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-10-26 01:35:09 +0000
commit4b84fd722479d289609f39851dc42e102767d027 (patch)
tree1a17987de16f09776ded8a004ca1ac019608ff0a /comms/gnokii/files
parent016f8749099b6e7b769d90c85d207cb0525fef58 (diff)
downloadports-4b84fd722479d289609f39851dc42e102767d027.tar.gz
ports-4b84fd722479d289609f39851dc42e102767d027.zip
Notes
Diffstat (limited to 'comms/gnokii/files')
-rw-r--r--comms/gnokii/files/patch-smsd-Makefile12
-rw-r--r--comms/gnokii/files/smsd-Makefile-WITH_GLIB.diff21
2 files changed, 27 insertions, 6 deletions
diff --git a/comms/gnokii/files/patch-smsd-Makefile b/comms/gnokii/files/patch-smsd-Makefile
index 4d4e7a5c73a9..8922796d7353 100644
--- a/comms/gnokii/files/patch-smsd-Makefile
+++ b/comms/gnokii/files/patch-smsd-Makefile
@@ -1,5 +1,5 @@
---- smsd/Makefile.orig Fri Feb 13 18:58:38 2004
-+++ smsd/Makefile Fri Feb 13 19:02:30 2004
+--- smsd/Makefile.orig Wed Oct 20 17:24:58 2004
++++ smsd/Makefile Wed Oct 20 17:25:10 2004
@@ -26,9 +26,9 @@
LDLIBS += $(PTHREAD_LIBS) \
$(shell $(GLIBLDLIBS))
@@ -7,8 +7,8 @@
-LDLIBS += -rdynamic $(TOPDIR)/common/libgnokii.la -ldl
+# LDLIBS += -rdynamic $(TOPDIR)/common/libgnokii.la -ldl
# Some systems, eg. FreeBSD don't have libdl. Use this:
--# LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii
-+LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii
+-# LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii -pthread -L../getopt -lgetopt
++LDLIBS += -s -rdynamic -L$(TOPDIR)/common -lgnokii -pthread
- ifdef XPM_LIBS
- LDLIBS +=$(XPM_LIBS)
+ OBJS = smsd.lo \
+ lowlevel.lo
diff --git a/comms/gnokii/files/smsd-Makefile-WITH_GLIB.diff b/comms/gnokii/files/smsd-Makefile-WITH_GLIB.diff
new file mode 100644
index 000000000000..6a5b8fcd921a
--- /dev/null
+++ b/comms/gnokii/files/smsd-Makefile-WITH_GLIB.diff
@@ -0,0 +1,21 @@
+--- smsd/Makefile.orig Wed Oct 20 17:26:17 2004
++++ smsd/Makefile Wed Oct 20 17:26:25 2004
+@@ -6,14 +6,14 @@
+ # $Id: Makefile,v 1.31 2004/08/03 09:29:09 ja Exp $
+ #
+
+-GLIBCFLAGS = glib-config --cflags
+-GLIBLDLIBS = glib-config --libs
++#GLIBCFLAGS = glib-config --cflags
++#GLIBLDLIBS = glib-config --libs
+
+ # Comment out above lines and uncomment below lines if you want compile smsd
+ # with glib2 instead of glib1.
+ #
+-#GLIBCFLAGS = pkg-config --cflags glib-2.0
+-#GLIBLDLIBS = pkg-config --libs glib-2.0
++GLIBCFLAGS = pkg-config --cflags glib-2.0
++GLIBLDLIBS = pkg-config --libs glib-2.0
+
+ TOPDIR=..
+ include $(TOPDIR)/Makefile.global