aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2011-01-26 13:47:04 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2011-01-26 13:47:04 +0000
commit184100d6d93f7af3c9bdb2e9a7e05df331c5b90d (patch)
treeff99a32171cc41de12a427ab44a67f2ceca5e177 /comms/gnokii
parent72aea3aa1cc14de63798b48f8d1338fcfaac9a7e (diff)
downloadports-184100d6d93f7af3c9bdb2e9a7e05df331c5b90d.tar.gz
ports-184100d6d93f7af3c9bdb2e9a7e05df331c5b90d.zip
- Update to 0.6.30
- Add LICENSE information - Add SQLite support option - Remove MD5 checksum PR: ports/154303 Submitted by: Guido Falsi <mad AT madpilot.net> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=268264
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile15
-rw-r--r--comms/gnokii/distinfo5
-rw-r--r--comms/gnokii/files/patch-common-phones-pcsc.c12
-rw-r--r--comms/gnokii/pkg-plist5
4 files changed, 18 insertions, 19 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 44e3f50aaea1..b13380459c02 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnokii
-PORTVERSION= 0.6.29
-PORTREVISION= 1
+PORTVERSION= 0.6.30
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -17,6 +16,9 @@ MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
MAINTAINER= mad@madpilot.net
COMMENT= Tools to talk to GSM cellular phones
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
USE_BZIP2= yes
@@ -50,6 +52,7 @@ OPTIONS= ICAL "Build with IETF iCal support" off \
SMSD "Enable smsd daemon" off \
MYSQL "Enable MySQL support for smsd" off \
PGSQL "Enable PostgreSQL support for smsd" off \
+ SQLITE "Enable SQLite support in smsd" off \
X11 "Build graphical version (xgnokii)" on
.include <bsd.port.pre.mk>
@@ -69,7 +72,7 @@ LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
.endif
.if !defined(WITH_SMSD)
-PLIST_SUB+= SMSD='@comment ' MSM='@comment ' PGM='@comment '
+PLIST_SUB+= SMSD='@comment ' MSM='@comment ' PGM='@comment ' SQLT='@comment '
CONFIGURE_ARGS+= --disable-smsd
.else
PLIST_SUB+= SMSD=''
@@ -87,6 +90,12 @@ PLIST_SUB+= PGM=''
.else
PLIST_SUB+= PGM='@comment '
.endif
+.if exists(${LOCALBASE}/lib/libsqlite3.so) && !defined(WITHOUT_SQLITE)
+LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+PLIST_SUB+= SQLT=''
+.else
+PLIST_SUB+= SQLT='@comment '
+.endif
.endif
.if defined(WITHOUT_X11)
diff --git a/comms/gnokii/distinfo b/comms/gnokii/distinfo
index 74a656fb21a7..787761da6400 100644
--- a/comms/gnokii/distinfo
+++ b/comms/gnokii/distinfo
@@ -1,3 +1,2 @@
-MD5 (gnokii-0.6.29.tar.bz2) = 6111e0158a1129062bda6420db67c313
-SHA256 (gnokii-0.6.29.tar.bz2) = d1633e934b6b43c681ea96c5830d44683a85f05e64ea03c3ecf0d5096aee8470
-SIZE (gnokii-0.6.29.tar.bz2) = 1302020
+SHA256 (gnokii-0.6.30.tar.bz2) = 337c75369901cc6665219e3b92e29949fc83823e8d63608979230d72fe2e1dd4
+SIZE (gnokii-0.6.30.tar.bz2) = 1320209
diff --git a/comms/gnokii/files/patch-common-phones-pcsc.c b/comms/gnokii/files/patch-common-phones-pcsc.c
deleted file mode 100644
index 8da34877ae2e..000000000000
--- a/comms/gnokii/files/patch-common-phones-pcsc.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- common/phones/pcsc.c.orig 2010-06-04 15:08:13.000466080 +0200
-+++ common/phones/pcsc.c 2010-06-04 15:15:44.926057193 +0200
-@@ -199,7 +199,9 @@
- case SCARD_W_UNPOWERED_CARD:
- case SCARD_W_RESET_CARD:
- case SCARD_W_REMOVED_CARD:
-+/* removed from pcsc-lite
- case SCARD_W_INSERTED_CARD:
-+*/
- return GN_ERR_SIMPROBLEM;
- case SCARD_E_NO_MEMORY:
- return GN_ERR_MEMORYFULL;
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
index c58cb8829f0c..0fc564fff5bb 100644
--- a/comms/gnokii/pkg-plist
+++ b/comms/gnokii/pkg-plist
@@ -21,7 +21,7 @@ include/gnokii/wappush.h
lib/libgnokii.a
lib/libgnokii.la
lib/libgnokii.so
-lib/libgnokii.so.6
+lib/libgnokii.so.7
libdata/pkgconfig/gnokii.pc
libdata/pkgconfig/xgnokii.pc
sbin/gnokiid
@@ -53,6 +53,9 @@ share/locale/zh_CN/LC_MESSAGES/gnokii.mo
%%PGM%%lib/smsd/libsmsd_pq.la
%%PGM%%lib/smsd/libsmsd_pq.so
%%PGM%%share/smsd/sms.tables.pq.sql
+%%SQLT%%lib/smsd/libsmsd_sqlite.a
+%%SQLT%%lib/smsd/libsmsd_sqlite.la
+%%SQLT%%lib/smsd/libsmsd_sqlite.so
%%SMSD%%@dirrm lib/smsd
%%SMSD%%@dirrm share/smsd
%%X11%%share/applications/xgnokii.desktop