aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-06-15 14:36:21 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-06-15 14:36:21 +0000
commit8274f12d4f98fd20087c2c18b8d85ce8e462b43d (patch)
tree90c4122127bc8defa63fd639d39fa3ef43bb259f /comms/gnokii
parent13e3329d2c246b294d5ea1d96220d6d557626720 (diff)
downloadports-8274f12d4f98fd20087c2c18b8d85ce8e462b43d.tar.gz
ports-8274f12d4f98fd20087c2c18b8d85ce8e462b43d.zip
- Fix configure when both X11 and SMSD options are off [1]
(this port always requires glib20) - While here regenerate patches to silence portlint warnings Reporterd by: Marc van Houtum <marc at dutchsecurity.net> (by email) [1]
Notes
Notes: svn path=/head/; revision=389710
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile3
-rw-r--r--comms/gnokii/files/patch-Docs-man-Makefile.in8
-rw-r--r--comms/gnokii/files/patch-Makefile.in6
-rw-r--r--comms/gnokii/files/patch-common-cfgreader.c8
-rw-r--r--comms/gnokii/files/patch-common-devices-unixbluetooth.c4
-rw-r--r--comms/gnokii/files/patch-gnokii-Makefile.in8
-rw-r--r--comms/gnokii/files/patch-gnokiid-Makefile.in8
-rw-r--r--comms/gnokii/files/patch-smsd-Makefile.in14
-rw-r--r--comms/gnokii/files/patch-xgnokii-Makefile.in6
9 files changed, 32 insertions, 33 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 63d29b4b1190..95a232cb6d25 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -22,7 +22,7 @@ GROUPS= ${PORTNAME}
USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
USE_LDCONFIG= yes
USE_CSTD= gnu89
-USE_GNOME= intltool
+USE_GNOME= glib20 intltool
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-security
CPPFLAGS+= -I${LOCALBASE}/include
@@ -58,7 +58,6 @@ PLIST_SUB+= SMSD='@comment ' MSM='@comment ' PGM='@comment ' SQLT='@comment '
CONFIGURE_ARGS+= --disable-smsd
.else
PLIST_SUB+= SMSD=''
-USE_GNOME+= glib20
. if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
PLIST_SUB+= MSM=''
diff --git a/comms/gnokii/files/patch-Docs-man-Makefile.in b/comms/gnokii/files/patch-Docs-man-Makefile.in
index 38413ce17882..49c52738150d 100644
--- a/comms/gnokii/files/patch-Docs-man-Makefile.in
+++ b/comms/gnokii/files/patch-Docs-man-Makefile.in
@@ -1,7 +1,7 @@
---- Docs/man/Makefile.in.orig 2008-02-23 17:36:56.000000000 +0100
-+++ Docs/man/Makefile.in 2008-02-23 17:52:50.000000000 +0100
-@@ -252,7 +252,7 @@
- target_vendor = @target_vendor@
+--- Docs/man/Makefile.in.orig 2015-06-15 14:14:28 UTC
++++ Docs/man/Makefile.in
+@@ -282,7 +282,7 @@ target_vendor = @target_vendor@
+ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-man_MANS = gnokii.1 sendsms.1 gnokiid.8 mgnokiidev.8 xgnokii.1x
diff --git a/comms/gnokii/files/patch-Makefile.in b/comms/gnokii/files/patch-Makefile.in
index 89bd064c4b18..67a797d48017 100644
--- a/comms/gnokii/files/patch-Makefile.in
+++ b/comms/gnokii/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2010-04-21 15:49:31.000000000 +0200
-+++ Makefile.in 2010-04-24 20:09:03.347837666 +0200
-@@ -301,9 +301,9 @@
+--- Makefile.in.orig 2015-06-15 14:14:28 UTC
++++ Makefile.in
+@@ -313,9 +313,9 @@ target_vendor = @target_vendor@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
diff --git a/comms/gnokii/files/patch-common-cfgreader.c b/comms/gnokii/files/patch-common-cfgreader.c
index 592353029aff..297269f10ef0 100644
--- a/comms/gnokii/files/patch-common-cfgreader.c
+++ b/comms/gnokii/files/patch-common-cfgreader.c
@@ -1,6 +1,6 @@
---- common/cfgreader.c.orig 2011-12-02 15:53:04.000000000 +0100
-+++ common/cfgreader.c 2013-08-13 13:25:46.836652059 +0200
-@@ -991,7 +991,7 @@
+--- common/cfgreader.c.orig 2011-12-02 14:53:04 UTC
++++ common/cfgreader.c
+@@ -991,7 +991,7 @@ static bool cfg_get_log_target(gn_log_ta
#define CHECK_SIZE() if (*retval >= size) { \
void *aux; \
size *= 2; \
@@ -9,7 +9,7 @@
if (aux) \
config_file_locations = aux; \
else {\
-@@ -1107,7 +1107,7 @@
+@@ -1107,7 +1107,7 @@ static char **get_locations(int *retval)
if (i >= xcd_size) {
void *aux;
xcd_size *= 2;
diff --git a/comms/gnokii/files/patch-common-devices-unixbluetooth.c b/comms/gnokii/files/patch-common-devices-unixbluetooth.c
index 8cd7f1eac865..4f8d6e9931ca 100644
--- a/comms/gnokii/files/patch-common-devices-unixbluetooth.c
+++ b/comms/gnokii/files/patch-common-devices-unixbluetooth.c
@@ -1,5 +1,5 @@
---- common/devices/unixbluetooth.c.orig 2009-06-23 20:24:56.000000000 +0200
-+++ common/devices/unixbluetooth.c 2009-09-08 22:21:31.450731259 +0200
+--- common/devices/unixbluetooth.c.orig 2011-12-02 14:53:04 UTC
++++ common/devices/unixbluetooth.c
@@ -51,7 +51,7 @@
#ifdef HAVE_BLUETOOTH_NETGRAPH /* FreeBSD / netgraph */
diff --git a/comms/gnokii/files/patch-gnokii-Makefile.in b/comms/gnokii/files/patch-gnokii-Makefile.in
index f8cb8100cf82..e7069c8d5e88 100644
--- a/comms/gnokii/files/patch-gnokii-Makefile.in
+++ b/comms/gnokii/files/patch-gnokii-Makefile.in
@@ -1,6 +1,6 @@
---- gnokii/Makefile.in.orig 2009-09-08 23:05:42.870592830 +0200
-+++ gnokii/Makefile.in 2009-09-08 23:10:05.004848245 +0200
-@@ -61,12 +61,12 @@
+--- gnokii/Makefile.in.orig 2015-06-15 14:14:28 UTC
++++ gnokii/Makefile.in
+@@ -63,12 +63,12 @@ am_gnokii_OBJECTS = gnokii-gnokii.$(OBJE
gnokii-gnokii-security.$(OBJEXT) \
gnokii-gnokii-settings.$(OBJEXT) gnokii-gnokii-sms.$(OBJEXT) \
gnokii-gnokii-todo.$(OBJEXT) gnokii-gnokii-utils.$(OBJEXT) \
@@ -15,7 +15,7 @@
gnokii_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
--mode=link $(CCLD) $(gnokii_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
$(LDFLAGS) -o $@
-@@ -289,7 +289,7 @@
+@@ -305,7 +305,7 @@ gnokii_SOURCES = gnokii.c gnokii-calenda
# Compile getopt1.c and getopt.c unconditionally on all platforms, it
# has its own magic for the platforms that already have it.
gnokii_LDADD = $(top_builddir)/common/libgnokii.la $(INTLLIBS) \
diff --git a/comms/gnokii/files/patch-gnokiid-Makefile.in b/comms/gnokii/files/patch-gnokiid-Makefile.in
index 55c838d3da35..31f404751aaa 100644
--- a/comms/gnokii/files/patch-gnokiid-Makefile.in
+++ b/comms/gnokii/files/patch-gnokiid-Makefile.in
@@ -1,6 +1,6 @@
---- gnokiid/Makefile.in.orig 2010-04-21 15:49:27.000000000 +0200
-+++ gnokiid/Makefile.in 2010-04-25 18:04:37.105945495 +0200
-@@ -53,7 +53,7 @@
+--- gnokiid/Makefile.in.orig 2015-06-15 14:14:28 UTC
++++ gnokiid/Makefile.in
+@@ -53,7 +53,7 @@ CONFIG_CLEAN_VPATH_FILES =
am__installdirs = "$(DESTDIR)$(bindir)"
PROGRAMS = $(bin_PROGRAMS)
am_gnokiid_OBJECTS = gnokiid-gnokiid.$(OBJEXT)
@@ -9,7 +9,7 @@
am__DEPENDENCIES_1 =
gnokiid_DEPENDENCIES = $(top_builddir)/common/libgnokii.la \
$(top_builddir)/common/data/libDATA.la $(am__DEPENDENCIES_1)
-@@ -328,8 +328,8 @@
+@@ -340,8 +340,8 @@ install-binPROGRAMS: $(bin_PROGRAMS)
while read type dir files; do \
if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
test -z "$$files" || { \
diff --git a/comms/gnokii/files/patch-smsd-Makefile.in b/comms/gnokii/files/patch-smsd-Makefile.in
index 265652b4ff1b..700c41915ff6 100644
--- a/comms/gnokii/files/patch-smsd-Makefile.in
+++ b/comms/gnokii/files/patch-smsd-Makefile.in
@@ -1,15 +1,15 @@
---- smsd/Makefile.in.orig 2010-04-21 15:49:29.000000000 +0200
-+++ smsd/Makefile.in 2010-04-25 18:09:09.881650463 +0200
-@@ -105,7 +105,7 @@
- @HAVE_POSTGRES_TRUE@am_libsmsd_pq_la_rpath = -rpath $(plugindir)
+--- smsd/Makefile.in.orig 2015-06-15 14:14:28 UTC
++++ smsd/Makefile.in
+@@ -115,7 +115,7 @@ libsmsd_sqlite_la_LINK = $(LIBTOOL) --ta
+ @HAVE_SQLITE_TRUE@am_libsmsd_sqlite_la_rpath = -rpath $(plugindir)
PROGRAMS = $(bin_PROGRAMS)
am_smsd_OBJECTS = smsd.$(OBJEXT) lowlevel.$(OBJEXT)
-smsd_OBJECTS = $(am_smsd_OBJECTS)
+smsd_OBJECTS = $(am_smsd_OBJECTS) /usr/lib/libsdp.so
smsd_DEPENDENCIES = $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
- $(am__DEPENDENCIES_1) $(top_builddir)/common/libgnokii.la
- DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/include
-@@ -442,8 +442,8 @@
+ $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+ $(top_builddir)/common/libgnokii.la
+@@ -474,8 +474,8 @@ install-binPROGRAMS: $(bin_PROGRAMS)
while read type dir files; do \
if test "$$dir" = .; then dir=; else dir=/$$dir; fi; \
test -z "$$files" || { \
diff --git a/comms/gnokii/files/patch-xgnokii-Makefile.in b/comms/gnokii/files/patch-xgnokii-Makefile.in
index 1a8f09465c06..2a057e744bdd 100644
--- a/comms/gnokii/files/patch-xgnokii-Makefile.in
+++ b/comms/gnokii/files/patch-xgnokii-Makefile.in
@@ -1,6 +1,6 @@
---- xgnokii/Makefile.in.orig 2008-10-06 08:57:20.000000000 +0200
-+++ xgnokii/Makefile.in 2009-02-26 17:33:22.000000000 +0100
-@@ -62,7 +62,7 @@
+--- xgnokii/Makefile.in.orig 2015-06-15 14:14:28 UTC
++++ xgnokii/Makefile.in
+@@ -67,7 +67,7 @@ am_xgnokii_OBJECTS = xgnokii-xgnokii.$(O
xgnokii-xgnokii_xring.$(OBJEXT) \
xgnokii-xgnokii_lowlevel.$(OBJEXT) \
xgnokii-xgnokii_data.$(OBJEXT)