aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-09-29 10:46:21 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-09-29 10:46:21 +0000
commit89640873560e3abb480d59bad5043dce37c75c80 (patch)
tree5817ff86badfb5c3cda3ee2278bb79c817eff702 /comms/gnokii
parent5a27db0d8c22a5d1d6327614710bca05c1ddfeb7 (diff)
downloadports-89640873560e3abb480d59bad5043dce37c75c80.tar.gz
ports-89640873560e3abb480d59bad5043dce37c75c80.zip
- Support staging
- Convert to new LIB_DEPENDS format - Use options helpers
Notes
Notes: svn path=/head/; revision=328668
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile50
-rw-r--r--comms/gnokii/pkg-plist6
2 files changed, 22 insertions, 34 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index eb82b644e8a3..24864451ba1c 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -36,8 +36,6 @@ LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES+= pkg-message
PORTDOCS= *
-MAN1= gnokii.1 sendsms.1 xgnokii.1
-MAN8= gnokiid.8 mgnokiidev.8
CONFLICTS= smstools-[0-9]* sendsms-[0-9]*
@@ -53,24 +51,13 @@ SMSD_DESC= Enable smsd daemon (includes "file" backend)
SMSDDB_DESC= Enable database support in smsd (select one or more)
X11_DESC= Build graphical version (xgnokii)
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+ICAL_CONFIGURE_ENABLE= libical
+ICAL_LIB_DEPENDS= libical.so:${PORTSDIR}/devel/libical
+USB_CONFIGURE_ENABLE= libusb
+PCSC_CONFIGURE_ENABLE= libpcsclite
+PCSC_LIB_DEPENDS= libpcsclite.so:${PORTSDIR}/devel/pcsc-lite
-.if ${PORT_OPTIONS:MICAL}
-LIB_DEPENDS+= ical:${PORTSDIR}/devel/libical
-.else
-CONFIGURE_ARGS+= --disable-libical
-.endif
-
-. if ! ${PORT_OPTIONS:MUSB}
-CONFIGURE_ARGS+= --disable-libusb
-.endif
-
-.if ${PORT_OPTIONS:MPCSC}
-LIB_DEPENDS+= pcsclite:${PORTSDIR}/devel/pcsc-lite
-.else
-CONFIGURE_ARGS+= --disable-libpcsclite
-.endif
+.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MSMSD)
PLIST_SUB+= SMSD='@comment ' MSM='@comment ' PGM='@comment ' SQLT='@comment '
@@ -78,7 +65,6 @@ CONFIGURE_ARGS+= --disable-smsd
.else
PLIST_SUB+= SMSD=''
USE_GNOME+= glib20
-MAN8+= smsd.8
. if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
PLIST_SUB+= MSM=''
@@ -132,29 +118,25 @@ post-patch:
@${MV} ${WRKSRC}/Docs/man/xgnokii.1x ${WRKSRC}/Docs/man/xgnokii.1
post-install:
- ${INSTALL_DATA} ${WRKSRC}/xgnokii/xgnokii.pc ${PREFIX}/libdata/pkgconfig
- @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ${INSTALL_DATA} ${WRKSRC}/xgnokii/xgnokii.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
.if ${PORT_OPTIONS:MDOCS}
- ${GMAKE} install -C ${WRKSRC}/Docs
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install -C ${WRKSRC}/Docs
.else
- ${GMAKE} install -C ${WRKSRC}/Docs/man
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} install -C ${WRKSRC}/Docs/man
.endif
${INSTALL_DATA} ${WRKSRC}/Docs/sample/gnokiirc \
- ${PREFIX}/etc/gnokiirc.sample
+ ${STAGEDIR}${PREFIX}/etc/gnokiirc.sample
.if ${PORT_OPTIONS:MSMSD}
- @cd ${WRKSRC}/smsd && ${GMAKE} install
- ${MKDIR} ${PREFIX}/share/smsd
- ${INSTALL_SCRIPT} ${WRKSRC}/smsd/action ${PREFIX}/share/smsd
- ${INSTALL_DATA} ${WRKSRC}/smsd/README ${PREFIX}/share/smsd
+ @cd ${WRKSRC}/smsd && ${SETENV} ${MAKE_ENV} ${GMAKE} install
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/smsd
+ ${INSTALL_SCRIPT} ${WRKSRC}/smsd/action ${STAGEDIR}${PREFIX}/share/smsd
+ ${INSTALL_DATA} ${WRKSRC}/smsd/README ${STAGEDIR}${PREFIX}/share/smsd
. if ${PORT_OPTIONS:MMYSQL}
- ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.mysql.sql ${PREFIX}/share/smsd
+ ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.mysql.sql ${STAGEDIR}${PREFIX}/share/smsd
. endif
. if ${PORT_OPTIONS:MPGSQL}
- ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.pq.sql ${PREFIX}/share/smsd
+ ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.pq.sql ${STAGEDIR}${PREFIX}/share/smsd
. endif
.endif
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
index a12398fcbea3..b430171e2e1b 100644
--- a/comms/gnokii/pkg-plist
+++ b/comms/gnokii/pkg-plist
@@ -24,6 +24,12 @@ lib/libgnokii.so
lib/libgnokii.so.7
libdata/pkgconfig/gnokii.pc
libdata/pkgconfig/xgnokii.pc
+man/man1/gnokii.1.gz
+man/man1/sendsms.1.gz
+man/man1/xgnokii.1.gz
+man/man8/gnokiid.8.gz
+man/man8/mgnokiidev.8.gz
+%%SMSD%%man/man8/smsd.8.gz
sbin/gnokiid
sbin/mgnokiidev
%%SMSD%%sbin/smsd