aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-12-10 16:46:22 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-12-10 16:46:22 +0000
commitaa07758c852128a41e59315d84da341040675072 (patch)
treeae9c68f5887c1e43e2d8959330a921151e028ccd /comms/gnokii
parent8a6bc85144cf2e06f777ec18ae59a0ef7a3064e6 (diff)
downloadports-aa07758c852128a41e59315d84da341040675072.tar.gz
ports-aa07758c852128a41e59315d84da341040675072.zip
- Update to 0.6.31
PR: ports/163158 Submitted by: Guido Falsi <mad@madpilot.net> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=287151
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile8
-rw-r--r--comms/gnokii/distinfo4
-rw-r--r--comms/gnokii/files/patch-configure71
-rw-r--r--comms/gnokii/pkg-plist6
4 files changed, 55 insertions, 34 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 3209b57de209..359b9c95236f 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnokii
-PORTVERSION= 0.6.30
+PORTVERSION= 0.6.31
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -32,8 +32,7 @@ WANT_GNOME= yes
USE_GNOME= intltool
GNU_CONFIGURE= yes
CPPFLAGS+= ${CFLAGS} -I${LOCALBASE}/include -fPIC
-CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE} --enable-security \
- --with-xgnokiidir=${PREFIX}/share
+CONFIGURE_ARGS+= --enable-security
CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
XGETTEXT="${LOCALBASE}/bin/xgettext" \
LIBS="-L${WRKSRC}/common -L${LOCALBASE}/lib" \
@@ -103,13 +102,14 @@ PLIST_SUB+= SQLT='@comment '
CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11='@comment '
.else
+CONFIGURE_ARGS+= --with-x
USE_XORG= xpm
USE_GNOME+= gtk20
PLIST_SUB+= X11=''
.endif
FIXPREFIX= Docs/man/gnokiid.8 Docs/DataCalls-QuickStart Docs/README \
- common/cfgreader.c po/et.po po/sl.po
+ common/cfgreader.c
post-patch:
.for f in ${FIXPREFIX}
@${REINPLACE_CMD} -e "s:/etc/gnokiirc:${PREFIX}/etc/gnokiirc:g" \
diff --git a/comms/gnokii/distinfo b/comms/gnokii/distinfo
index 787761da6400..e701e9162049 100644
--- a/comms/gnokii/distinfo
+++ b/comms/gnokii/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnokii-0.6.30.tar.bz2) = 337c75369901cc6665219e3b92e29949fc83823e8d63608979230d72fe2e1dd4
-SIZE (gnokii-0.6.30.tar.bz2) = 1320209
+SHA256 (gnokii-0.6.31.tar.bz2) = 8f5a083b05c1a66a3402ca5cd80084e14c2c0632c991bb53b03c78e9adb02501
+SIZE (gnokii-0.6.31.tar.bz2) = 1237865
diff --git a/comms/gnokii/files/patch-configure b/comms/gnokii/files/patch-configure
index 7360cca528ba..01e03e6ef9c6 100644
--- a/comms/gnokii/files/patch-configure
+++ b/comms/gnokii/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2010-04-21 15:49:32.000000000 +0200
-+++ configure 2010-04-25 18:02:53.185508083 +0200
-@@ -1060,7 +1060,7 @@
+--- configure.orig 2011-12-02 15:54:03.000000000 +0100
++++ configure 2011-12-09 16:57:35.591360321 +0100
+@@ -955,7 +955,7 @@
psdir='${docdir}'
libdir='${exec_prefix}/lib'
localedir='${datarootdir}/locale'
@@ -9,11 +9,10 @@
ac_prev=
ac_dashdash=
-@@ -7909,20 +7909,6 @@
-
+@@ -7939,19 +7939,6 @@
fi
--
+
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if building on FreeBSD" >&5
-$as_echo_n "checking if building on FreeBSD... " >&6; }
-
@@ -30,7 +29,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking if building on NetBSD" >&5
$as_echo_n "checking if building on NetBSD... " >&6; }
-@@ -14858,7 +14844,7 @@
+@@ -15803,7 +15790,7 @@
$as_echo_n "checking if more special flags are required for pthreads... " >&6; }
flag=no
case "${host_cpu}-${host_os}" in
@@ -39,34 +38,43 @@
*solaris* | *-osf* | *-hpux*) flag="-D_REENTRANT";;
esac
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: ${flag}" >&5
-@@ -15461,7 +15447,7 @@
+@@ -16399,7 +16386,7 @@
+
if test "$enable_libical" = "yes"; then
+- ICAL_LIBS="$ICAL_LIBS -lpthread -lical"
++ ICAL_LIBS="$ICAL_LIBS -pthread -lical"
OLD_CFLAGS="$CFLAGS"
-- LIBS="$LIBS $ICAL_LIBS -lpthread -lical"
-+ LIBS="$LIBS $ICAL_LIBS -pthread -lical"
- CFLAGS="$CFLAGS $ICAL_CFLAGS"
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether libical is installed" >&5
- $as_echo_n "checking whether libical is installed... " >&6; }
-@@ -15883,7 +15869,7 @@
+ OLD_LIBS="$LIBS"
+ LIBS="$LIBS $ICAL_LIBS"
+@@ -16716,7 +16703,7 @@
+ $as_echo "#define HAVE_BLUETOOTH_BLUEZ /**/" >>confdefs.h
+
+ USE_BLUETOOTH="yes"
+- BLUETOOTH_LIBS="-lbluetooth"
++ BLUETOOTH_LIBS="-lsdp -lbluetooth"
+
+ fi
+ fi
+@@ -16849,7 +16836,7 @@
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-lbluetooth $LIBS"
-+LIBS="-lsdp -lbluetooth $LIBS"
++LIBS="-sdp -lbluetooth $LIBS"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -15914,7 +15900,7 @@
+@@ -16880,7 +16867,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_bluetooth_bt_aton" >&5
$as_echo "$ac_cv_lib_bluetooth_bt_aton" >&6; }
- if test "x$ac_cv_lib_bluetooth_bt_aton" = x""yes; then :
+ if test "x$ac_cv_lib_bluetooth_bt_aton" = xyes; then :
- BLUETOOTH_LIBS="-lbluetooth" ac_cv_have_bt_lib=yes
+ BLUETOOTH_LIBS="-lsdp -lbluetooth" ac_cv_have_bt_lib=yes
else
ac_cv_have_bt_lib=no
fi
-@@ -16011,7 +15997,7 @@
+@@ -16977,7 +16964,7 @@
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -75,21 +83,40 @@
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -16042,7 +16028,7 @@
+@@ -17008,7 +16995,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_bluetooth_bt_aton" >&5
$as_echo "$ac_cv_lib_bluetooth_bt_aton" >&6; }
- if test "x$ac_cv_lib_bluetooth_bt_aton" = x""yes; then :
+ if test "x$ac_cv_lib_bluetooth_bt_aton" = xyes; then :
- BLUETOOTH_LIBS="-lbluetooth" ac_cv_have_bt_lib=yes
+ BLUETOOTH_LIBS="-lsdp -lbluetooth" ac_cv_have_bt_lib=yes
else
ac_cv_have_bt_lib=no
fi
-@@ -16612,7 +16598,7 @@
+@@ -17488,8 +17475,7 @@
+ $as_echo_n "(cached) " >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lXpm $XLIBS -lX11
+- $LIBS"
++LIBS="-lXpm $XLIBS -lX11 $LIBS"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+
+@@ -17521,7 +17507,7 @@
$as_echo "$ac_cv_lib_Xpm_XpmWriteFileFromXpmImage" >&6; }
- if test "x$ac_cv_lib_Xpm_XpmWriteFileFromXpmImage" = x""yes; then :
+ if test "x$ac_cv_lib_Xpm_XpmWriteFileFromXpmImage" = xyes; then :
XPM_CFLAGS="$XINCL"
- XPM_LIBS="$XLIBS -lXpm -lX11"
+ XPM_LIBS="$XLIBS -lXpm -lX11 -lroken -lcrypt"
$as_echo "#define XPM 1" >>confdefs.h
+@@ -17556,7 +17542,7 @@
+ fi
+ fi
+
+- if test "x$_support" = "xyes"; then
++ if test "x$x_support" = "xyes"; then
+ XGNOKII_TRUE=
+ XGNOKII_FALSE='#'
+ else
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
index 0fc564fff5bb..a12398fcbea3 100644
--- a/comms/gnokii/pkg-plist
+++ b/comms/gnokii/pkg-plist
@@ -27,19 +27,13 @@ libdata/pkgconfig/xgnokii.pc
sbin/gnokiid
sbin/mgnokiidev
%%SMSD%%sbin/smsd
-share/locale/cs/LC_MESSAGES/gnokii.mo
share/locale/de/LC_MESSAGES/gnokii.mo
-share/locale/et/LC_MESSAGES/gnokii.mo
share/locale/fi/LC_MESSAGES/gnokii.mo
share/locale/fr/LC_MESSAGES/gnokii.mo
share/locale/it/LC_MESSAGES/gnokii.mo
-share/locale/nl/LC_MESSAGES/gnokii.mo
share/locale/pl/LC_MESSAGES/gnokii.mo
share/locale/pt/LC_MESSAGES/gnokii.mo
-share/locale/sk/LC_MESSAGES/gnokii.mo
-share/locale/sl/LC_MESSAGES/gnokii.mo
share/locale/sv/LC_MESSAGES/gnokii.mo
-share/locale/zh_CN/LC_MESSAGES/gnokii.mo
%%SMSD%%share/smsd/README
%%SMSD%%share/smsd/action
%%SMSD%%lib/smsd/libsmsd_file.a