aboutsummaryrefslogtreecommitdiff
path: root/comms/gnokii
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-08-14 13:00:15 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-08-14 13:00:15 +0000
commitccddbf64e6babf6e32db68242ca0fac8ff1c8b06 (patch)
tree3836608a3e5cc2693fb9db3059c917ff9dda1099 /comms/gnokii
parent4b268d3780ac7b557bca950fe787e4e49cbae278 (diff)
downloadports-ccddbf64e6babf6e32db68242ca0fac8ff1c8b06.tar.gz
ports-ccddbf64e6babf6e32db68242ca0fac8ff1c8b06.zip
- Add patch to avoid a bus error while starting the software.
Many thanks to the Mike Bernard for reporting and helping me debug this problem. While here remove obsolete MAKE_JOBS_SFE flag Reported by: Mike Barnard Kwatampora <mike.barnardq@gmail.com>
Notes
Notes: svn path=/head/; revision=324715
Diffstat (limited to 'comms/gnokii')
-rw-r--r--comms/gnokii/Makefile3
-rw-r--r--comms/gnokii/files/patch-common-cfgreader.c20
2 files changed, 21 insertions, 2 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index ea4a56fd911d..cbbe92c96686 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnokii
PORTVERSION= 0.6.31
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -23,7 +23,6 @@ USE_BZIP2= yes
USES= gettext gmake
USE_LDCONFIG= yes
USE_CSTD= gnu89
-MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
USE_GNOME= intltool
GNU_CONFIGURE= yes
diff --git a/comms/gnokii/files/patch-common-cfgreader.c b/comms/gnokii/files/patch-common-cfgreader.c
new file mode 100644
index 000000000000..592353029aff
--- /dev/null
+++ b/comms/gnokii/files/patch-common-cfgreader.c
@@ -0,0 +1,20 @@
+--- common/cfgreader.c.orig 2011-12-02 15:53:04.000000000 +0100
++++ common/cfgreader.c 2013-08-13 13:25:46.836652059 +0200
+@@ -991,7 +991,7 @@
+ #define CHECK_SIZE() if (*retval >= size) { \
+ void *aux; \
+ size *= 2; \
+- aux = realloc(config_file_locations, size); \
++ aux = realloc(config_file_locations, size * sizeof(char *)); \
+ if (aux) \
+ config_file_locations = aux; \
+ else {\
+@@ -1107,7 +1107,7 @@
+ if (i >= xcd_size) {
+ void *aux;
+ xcd_size *= 2;
+- aux = realloc(xdg_config_dir, xcd_size);
++ aux = realloc(xdg_config_dir, xcd_size * sizeof(char *));
+ if (aux)
+ xdg_config_dir = aux;
+ else {