aboutsummaryrefslogtreecommitdiff
path: root/comms/gnuradio/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-04-29 13:57:24 +0000
committerDiane Bruce <db@FreeBSD.org>2013-04-29 13:57:24 +0000
commit6773ec919101764641e8a18a2cf931236f6ff7e0 (patch)
tree8e6c9538a67bfa0cf95d88e3d96c2941d3975d86 /comms/gnuradio/Makefile
parentdddd7142fbeafaa8aeeb115ab3ae6d44074fedb1 (diff)
downloadports-6773ec919101764641e8a18a2cf931236f6ff7e0.tar.gz
ports-6773ec919101764641e8a18a2cf931236f6ff7e0.zip
Notes
Diffstat (limited to 'comms/gnuradio/Makefile')
-rw-r--r--comms/gnuradio/Makefile61
1 files changed, 45 insertions, 16 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 5fb2caa837c9..a49694bcbdd3 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -1,10 +1,11 @@
# $FreeBSD$
PORTNAME= gnuradio
-PORTVERSION= 3.6.2
-PORTREVISION= 2
+PORTVERSION= 3.6.3
CATEGORIES= comms astro hamradio
-MASTER_SITES= http://gnuradio.org/releases/gnuradio/
+MASTER_SITES= http://gnuradio.org/releases/gnuradio/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio Software defined radio
@@ -32,30 +33,26 @@ RUN_DEPENDS= ${PYNUMPY} \
USES= cmake:outsource
DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
-#CMAKE_ARGS= --debug-output --trace
-CMAKE_ARGS=+ --debug-output
USE_PYTHON= 2.7+
USE_WX= 2.6+
USE_QT4= gui xml qmake moc rcc uic
WX_COMPS= wx wx:build wx:run python:build python:run
USE_PERL5= yes
USE_LDCONFIG= yes
+PLIST_SUB+= MAJOR_VERSION="3"
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= USRP TESTING
+OPTIONS_DEFAULT= USRP
+USRP_DESC= Include USRP support (UHD) from Ettus
+TESTING_DESC= Include testing support
+.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
.endif
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-OPTIONS_DEFINE= USRP TESTING
-OPTIONS_DEFAULT= USRP
-USRP_DESC= Include USRP support (UHD) from Ettus
-TESTING_DESC= Include testing support
-
-.include <bsd.port.options.mk>
-
.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
${LOCALBASE}/bin/sphinx-apidoc:${PORTSDIR}/textproc/py-sphinx \
@@ -64,9 +61,11 @@ BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
${LOCALBASE}/lib/X11/fonts/freefont-ttf/fonts.scale:${PORTSDIR}/x11-fonts/freefont-ttf \
latex:${PORTSDIR}/print/teTeX
CMAKE_ARGS+= -DENABLE_DOXYGEN:STRING="ON"
+CMAKE_ARGS+= -DENABLE_DOCS:STRING="ON"
HAVE_PORTDOCS= YES
.else
CMAKE_ARGS+= -DENABLE_DOXYGEN:STRING="OFF"
+CMAKE_ARGS+= -DENABLE_DOCS:STRING="OFF"
.endif
.if ${PORT_OPTIONS:MUSRP}
@@ -85,14 +84,44 @@ BUILD_DEPENDS+= cppunit-config:${PORTSDIR}/devel/cppunit
CMAKE_ARGS+= -DENABLE_TESTING:STRING="OFF"
.endif
+.include <bsd.port.options.mk>
post-patch:
+ ${FIND} ${WRKSRC}/.. -name CMakeLists.txt | \
+ ${XARGS} ${REINPLACE_CMD} -e \
+ "s|{GR_LIBRARY_DIR}/pkgconfig|{GR_PKGCONFIG_DIR}/pkgconfig|g"
+
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
${WRKSRC}/docs/doxygen/Doxyfile.in
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/cmake/Modules/FindPortaudio.cmake
+
+PLISTMAIN= pkg-plist.main
+PLISTDIRS= pkg-plist.dirs
+PLIST= ${WRKDIR}/.pkg-plist
pre-install:
- ${MKDIR} ${PREFIX}/include/gruel
- ${INSTALL_DATA} ${WRKSRC}/gruel/src/include/gruel/*.h \
- ${PREFIX}/include/gruel
+ @${RM} -f ${PLIST}
+ @${CAT} ${PLISTMAIN} > ${PLIST}
+ @cd ${WRKDIR}/.build/docs/doxygen && ${FIND} html -type f | \
+ ${SED} -e 's|html|%%PORTDOCS%%%%DOCSDIR%%/html|' \
+ | ${SORT} >> ${PLIST}
+ @cd ${WRKDIR}/.build/gr-trellis && ${FIND} doc -name \*.html -type f | \
+ ${SED} -e 's|doc|%%PORTDOCS%%%%DOCSDIR%%/html|' \
+ | ${SORT} >> ${PLIST}
+ @cd ${WRKDIR}/.build/docs/doxygen && ${FIND} xml -type f | \
+ ${SED} -e 's|xml|%%PORTDOCS%%%%DOCSDIR%%/xml|' \
+ | ${SORT} >> ${PLIST}
+ @cd ${WRKDIR}/.build/gr-trellis && ${FIND} doc -name \*.xml -type f | \
+ ${SED} -e 's|doc|%%PORTDOCS%%%%DOCSDIR%%/xml|' \
+ | ${SORT} >> ${PLIST}
+ @${CAT} ${PLISTDIRS} >> ${PLIST}
+ @cd ${WRKDIR}/.build/docs/doxygen && ${FIND} html -type d | ${SORT} -r | \
+ ${SED} -e 's|html|%%PORTDOCS%%@dirrm %%DOCSDIR%%/html|' \
+ >> ${PLIST}
+ @cd ${WRKDIR}/.build/docs/doxygen && ${FIND} xml -type d | ${SORT} -r | \
+ ${SED} -e 's|xml|%%PORTDOCS%%@dirrm %%DOCSDIR%%/xml|' \
+ >> ${PLIST}
+ @${ECHO_CMD} "%%PORTDOCS%%@dirrm %%DOCSDIR%%" >> ${PLIST}
post-install:
.if defined(HAVE_PORTDOCS)