aboutsummaryrefslogtreecommitdiff
path: root/comms/gnuradio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /comms/gnuradio
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'comms/gnuradio')
-rw-r--r--comms/gnuradio/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 60e6fa2de11a..83feccfc73ba 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -51,7 +51,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# volk/lib/volk_cpu.c: In function 'i_can_has_3dnow':
# volk/lib/volk_cpu.c:62: error: can't find a register in class 'BREG' while reloading 'asm'
# volk/lib/volk_cpu.c:62: error: 'asm' operand has impossible constraints
-USES= cmake:outsource compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 qt:4 shebangfix
+USES= cmake compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 qt:4 shebangfix
SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in \
gnuradio-runtime/python/gnuradio/ctrlport/gr-ctrlport-monitor \
gnuradio-runtime/python/gnuradio/ctrlport/gr-perf-monitorx