aboutsummaryrefslogtreecommitdiff
path: root/comms/gnuradio
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2019-08-12 12:38:41 +0000
committerDiane Bruce <db@FreeBSD.org>2019-08-12 12:38:41 +0000
commit91e665eb10073c4232843fad52724099414c2330 (patch)
tree208a57c2d5fbe6e45fa7f59d2f55ce6c68c428c9 /comms/gnuradio
parent100bf33e8da01c636178b1542fc09df2eeb3258f (diff)
downloadports-91e665eb10073c4232843fad52724099414c2330.tar.gz
ports-91e665eb10073c4232843fad52724099414c2330.zip
Changelog:
## [3.8.0.0] - 2019-08-09 Witness me! Tonight, we release GNU Radio 3.8.0.0. It's the first minor release version since more than six years, not without pride this community stands to face the brightest future SDR on general purpose hardware ever had. Since we've not been documenting changes in the shape of a Changelog for the whole of the development that happened since GNU Radio 3.7.0, I'm afraid that these release notes will be more of a GLTL;DR (git log too long; didn't read) than a detailed account of what has changed. What has _not** changed is the fact that GNU Radio is centered around a very simple truth: > Let the developers hack on DSP. Software interfaces are for humans, not the > other way around. And so, compared to the later 3.7 releases, nothing has fundamentally modified the way one develops signal processing systems with GNU Radio: You write blocks, and you combine blocks to be part of a larger signal processing flow graph. With that as a success story, we of course have faced quite a bit of change in the systems we use to develop and in the people that develop GNU Radio. This has lead to several changes that weren't compatible with 3.7. **This is an excerpt only:** ### Fixed #### Project Scope - Roughly 36 dBBug, (ETOOMANYBUGS) - Fixed .so versioning ### Changed #### Project Scope - C++11 - merged the wholeness of the `next` branch - Dependency version bumps: CMake, GCC, MSVC, Swig, Boost - New dependencies: MPIR/GMP, Qt5, gsm, codec2 - Removed dependencies: libusb, Qt4, CppUnit - Python: Python 2 & Python 3 compatible. 3.8 will be the last Py2k-compatible release series - gengen was replaced by templates (if you don't know gengen, don't do any research; save yourself that sorrow) - Modern CMake (as far as feasible at this point) - VOLK version updated to v2.0.0 - .clang-format file now dictates coding style - clang-format'ed the whole tree. - installed CMake files now tell about configuration #### gnuradio-runtime - reworked fractional tag time handling, especially in the context of resamplers #### GRC - C++ generation as option - YAML instead of XML - removed `blks2` - much better canvas tooling - consistent gobject usage - ROUNDED ARROWS #### gr-qtgui - moving from Qt4 to Qt5 #### gr-utils - `gr_modtool` now vastly improved #### gr-vocoder - improved versatility - removed in-tree libgsm, libcodec2, use system-wide libs ### Removed #### Project Scope - Modules `gr-comedi`, `gr-fcd` and `gr-wxgui` are gone #### gr-comedi - nobody could remember who used this, or for what. It has seen 0 active code contributions in the 3.7 lifecycle #### gr-digital - python-based `packet_encoder` and related tools: Bugs that were sporadic and never fixed, so after long deprecation, we're removing it #### gr-fcd - since it's currently untestable by the CI, it's being removed, as there was no code contributions. Generally, we strive to include all batteries with GNU Radio. Re-integration within a more general SDR interface would be desirable. #### gr-utils - removed PyQwt (dead) based tools #### gr-wxgui - Unmaintained, breaks on increasingly many systems, always was slower than Qtgui. We've been starting to tell people to migrate to Qt since at least 2015. Now, we're finally removing it. ==== Mike English notes: Note that the 3.8.0.0 tarball is again available from https://www.gnuradio.org/releases/gnuradio/ and the volk dependency (a submodule in the git repo) is included so we can do away with USES_GITHUB and go back to building from the official release tarball. I've run this through portlint and poudriere already, so it should apply cleanly. ==== PR: ports/239793 Submitted by: mike.english@gmail.com
Notes
Notes: svn path=/head/; revision=508731
Diffstat (limited to 'comms/gnuradio')
-rw-r--r--comms/gnuradio/Makefile8
-rw-r--r--comms/gnuradio/distinfo8
-rw-r--r--comms/gnuradio/files/patch-cmake_Modules_GrPython.cmake4
-rw-r--r--comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in4
-rw-r--r--comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__decode__ps__impl.h4
-rw-r--r--comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__encode__sp__impl.h4
-rw-r--r--comms/gnuradio/pkg-plist39
7 files changed, 33 insertions, 38 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index c3ea46032c40..e7db8a94d62d 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= gnuradio
-#MASTER_SITES= http://gnuradio.org/releases/gnuradio/
-PORTVERSION= 3.8.0.0.r2
+PORTVERSION= 3.8.0.0
CATEGORIES= comms astro hamradio
-DISTNAME= v3.8.0.0-rc2
+MASTER_SITES= http://gnuradio.org/releases/gnuradio/
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Amateur Radio Software defined radio
@@ -56,9 +55,6 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# volk/lib/volk_cpu.c:62: error: 'asm' operand has impossible constraints
USES= cmake compiler:c11 desktop-file-utils fortran gnome iconv \
perl5 pkgconfig pyqt:5 python:2.7 qt:5 shared-mime-info shebangfix
-USE_GITHUB= yes
-GH_TUPLE= gnuradio:gnuradio:${DISTNAME} \
- gnuradio:volk:d250816:volk/volk
SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in \
gnuradio-runtime/python/gnuradio/ctrlport/gr-ctrlport-monitor \
diff --git a/comms/gnuradio/distinfo b/comms/gnuradio/distinfo
index def6c489a0ff..35beaf2af245 100644
--- a/comms/gnuradio/distinfo
+++ b/comms/gnuradio/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1565477657
-SHA256 (gnuradio-gnuradio-3.8.0.0.r2-v3.8.0.0-rc2_GH0.tar.gz) = 0dc466017101f39aa903780fa510c3cdf3a29ce75d12148fc449b12fe6324304
-SIZE (gnuradio-gnuradio-3.8.0.0.r2-v3.8.0.0-rc2_GH0.tar.gz) = 3400475
-SHA256 (gnuradio-volk-d250816_GH0.tar.gz) = 334da8910cfadc2e1487ef2a651f8eaa472262a4bfd3fa7c38d913c8fc32cbd8
-SIZE (gnuradio-volk-d250816_GH0.tar.gz) = 252477
+TIMESTAMP = 1565539118
+SHA256 (gnuradio-3.8.0.0.tar.gz) = 3a9c90111f22f2f6f30450731dc671ad28ce824fc1a7bc8ea0783da9b95a7092
+SIZE (gnuradio-3.8.0.0.tar.gz) = 3557884
diff --git a/comms/gnuradio/files/patch-cmake_Modules_GrPython.cmake b/comms/gnuradio/files/patch-cmake_Modules_GrPython.cmake
index 8ad804608fcf..7e7554ea678b 100644
--- a/comms/gnuradio/files/patch-cmake_Modules_GrPython.cmake
+++ b/comms/gnuradio/files/patch-cmake_Modules_GrPython.cmake
@@ -1,6 +1,6 @@
---- cmake/Modules/GrPython.cmake.orig 2019-03-09 13:28:14 UTC
+--- cmake/Modules/GrPython.cmake.orig 2019-08-09 21:40:34 UTC
+++ cmake/Modules/GrPython.cmake
-@@ -101,11 +101,15 @@ if(NOT DEFINED GR_PYTHON_DIR)
+@@ -111,11 +111,15 @@ if(NOT DEFINED GR_PYTHON_DIR)
execute_process(COMMAND ${PYTHON_EXECUTABLE} -c "
import os
import sys
diff --git a/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in b/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in
index 8cc97c16529b..b8e9761d703e 100644
--- a/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in
+++ b/comms/gnuradio/files/patch-docs_doxygen_Doxyfile.in
@@ -1,6 +1,6 @@
---- docs/doxygen/Doxyfile.in.orig 2019-03-09 13:28:14 UTC
+--- docs/doxygen/Doxyfile.in.orig 2019-08-09 21:40:34 UTC
+++ docs/doxygen/Doxyfile.in
-@@ -1852,7 +1852,7 @@ DOT_FONTSIZE = 10
+@@ -1848,7 +1848,7 @@ DOT_FONTSIZE = 10
# If you specify a different font using DOT_FONTNAME you can use DOT_FONTPATH to
# set the path where dot can find it.
diff --git a/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__decode__ps__impl.h b/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__decode__ps__impl.h
index 526dd4a51cd7..ed0dc385e100 100644
--- a/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__decode__ps__impl.h
+++ b/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__decode__ps__impl.h
@@ -1,9 +1,9 @@
---- gr-vocoder/lib/gsm_fr_decode_ps_impl.h.orig 2019-05-29 03:34:08 UTC
+--- gr-vocoder/lib/gsm_fr_decode_ps_impl.h.orig 2019-08-09 21:40:34 UTC
+++ gr-vocoder/lib/gsm_fr_decode_ps_impl.h
@@ -26,7 +26,11 @@
#include <gnuradio/vocoder/gsm_fr_decode_ps.h>
- extern "C"{
+ extern "C" {
+#ifdef __FreeBSD__
+#include <gsm.h>
+#else
diff --git a/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__encode__sp__impl.h b/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__encode__sp__impl.h
index 2d1096501144..8b32b26bc512 100644
--- a/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__encode__sp__impl.h
+++ b/comms/gnuradio/files/patch-gr-vocoder_lib_gsm__fr__encode__sp__impl.h
@@ -1,9 +1,9 @@
---- gr-vocoder/lib/gsm_fr_encode_sp_impl.h.orig 2019-05-29 03:34:08 UTC
+--- gr-vocoder/lib/gsm_fr_encode_sp_impl.h.orig 2019-08-11 18:52:58 UTC
+++ gr-vocoder/lib/gsm_fr_encode_sp_impl.h
@@ -26,7 +26,11 @@
#include <gnuradio/vocoder/gsm_fr_encode_sp.h>
- extern "C"{
+ extern "C" {
+#ifdef __FreeBSD__
+#include <gsm.h>
+#else
diff --git a/comms/gnuradio/pkg-plist b/comms/gnuradio/pkg-plist
index ed4ccd532478..3a497edce6bf 100644
--- a/comms/gnuradio/pkg-plist
+++ b/comms/gnuradio/pkg-plist
@@ -757,6 +757,7 @@ include/pmt/pmt.h
include/pmt/pmt_pool.h
include/pmt/pmt_serial_tags.h
include/pmt/pmt_sugar.h
+include/volk/constants.h
include/volk/saturation_arithmetic.h
include/volk/volk.h
include/volk/volk_16i_32fc_dot_prod_32fc.h
@@ -998,60 +999,60 @@ lib/cmake/volk/VolkTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/volk/VolkTargets.cmake
lib/libgnuradio-analog.so
lib/libgnuradio-analog.so.3.8.0
-lib/libgnuradio-analog.so.3.8.0.0-rc2
+lib/libgnuradio-analog.so.3.8.0.0
lib/libgnuradio-audio.so
lib/libgnuradio-audio.so.3.8.0
-lib/libgnuradio-audio.so.3.8.0.0-rc2
+lib/libgnuradio-audio.so.3.8.0.0
lib/libgnuradio-blocks.so
lib/libgnuradio-blocks.so.3.8.0
-lib/libgnuradio-blocks.so.3.8.0.0-rc2
+lib/libgnuradio-blocks.so.3.8.0.0
lib/libgnuradio-channels.so
lib/libgnuradio-channels.so.3.8.0
-lib/libgnuradio-channels.so.3.8.0.0-rc2
+lib/libgnuradio-channels.so.3.8.0.0
lib/libgnuradio-digital.so
lib/libgnuradio-digital.so.3.8.0
-lib/libgnuradio-digital.so.3.8.0.0-rc2
+lib/libgnuradio-digital.so.3.8.0.0
lib/libgnuradio-dtv.so
lib/libgnuradio-dtv.so.3.8.0
-lib/libgnuradio-dtv.so.3.8.0.0-rc2
+lib/libgnuradio-dtv.so.3.8.0.0
lib/libgnuradio-fec.so
lib/libgnuradio-fec.so.3.8.0
-lib/libgnuradio-fec.so.3.8.0.0-rc2
+lib/libgnuradio-fec.so.3.8.0.0
lib/libgnuradio-fft.so
lib/libgnuradio-fft.so.3.8.0
-lib/libgnuradio-fft.so.3.8.0.0-rc2
+lib/libgnuradio-fft.so.3.8.0.0
lib/libgnuradio-filter.so
lib/libgnuradio-filter.so.3.8.0
-lib/libgnuradio-filter.so.3.8.0.0-rc2
+lib/libgnuradio-filter.so.3.8.0.0
lib/libgnuradio-pmt.so
lib/libgnuradio-pmt.so.3.8.0
-lib/libgnuradio-pmt.so.3.8.0.0-rc2
+lib/libgnuradio-pmt.so.3.8.0.0
lib/libgnuradio-qtgui.so
lib/libgnuradio-qtgui.so.3.8.0
-lib/libgnuradio-qtgui.so.3.8.0.0-rc2
+lib/libgnuradio-qtgui.so.3.8.0.0
lib/libgnuradio-runtime.so
lib/libgnuradio-runtime.so.3.8.0
-lib/libgnuradio-runtime.so.3.8.0.0-rc2
+lib/libgnuradio-runtime.so.3.8.0.0
lib/libgnuradio-trellis.so
lib/libgnuradio-trellis.so.3.8.0
-lib/libgnuradio-trellis.so.3.8.0.0-rc2
+lib/libgnuradio-trellis.so.3.8.0.0
%%UHD%%lib/libgnuradio-uhd.so
%%UHD%%lib/libgnuradio-uhd.so.3.8.0
-%%UHD%%lib/libgnuradio-uhd.so.3.8.0.0-rc2
+%%UHD%%lib/libgnuradio-uhd.so.3.8.0.0
lib/libgnuradio-video-sdl.so
lib/libgnuradio-video-sdl.so.3.8.0
-lib/libgnuradio-video-sdl.so.3.8.0.0-rc2
+lib/libgnuradio-video-sdl.so.3.8.0.0
lib/libgnuradio-vocoder.so
lib/libgnuradio-vocoder.so.3.8.0
-lib/libgnuradio-vocoder.so.3.8.0.0-rc2
+lib/libgnuradio-vocoder.so.3.8.0.0
lib/libgnuradio-wavelet.so
lib/libgnuradio-wavelet.so.3.8.0
-lib/libgnuradio-wavelet.so.3.8.0.0-rc2
+lib/libgnuradio-wavelet.so.3.8.0.0
lib/libgnuradio-zeromq.so
lib/libgnuradio-zeromq.so.3.8.0
-lib/libgnuradio-zeromq.so.3.8.0.0-rc2
+lib/libgnuradio-zeromq.so.3.8.0.0
lib/libvolk.so
-lib/libvolk.so.1.4.1git
+lib/libvolk.so.2.0
%%PYTHON_SITELIBDIR%%/gnuradio/__init__.py
%%PYTHON_SITELIBDIR%%/gnuradio/__init__.pyc
%%PYTHON_SITELIBDIR%%/gnuradio/__init__.pyo