aboutsummaryrefslogtreecommitdiff
path: root/comms/hackrf/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-08-30 20:20:31 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-08-30 20:20:31 +0000
commit15b54b6841815380279856bf6220f9e6ed969980 (patch)
treed8e2226b28d12fcf1b5038819c07e675ed0ee127 /comms/hackrf/Makefile
parent3a7475f899f65f1be159d2ecfa7496aeb1b81dbc (diff)
downloadports-15b54b6841815380279856bf6220f9e6ed969980.tar.gz
ports-15b54b6841815380279856bf6220f9e6ed969980.zip
Notes
Diffstat (limited to 'comms/hackrf/Makefile')
-rw-r--r--comms/hackrf/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/comms/hackrf/Makefile b/comms/hackrf/Makefile
new file mode 100644
index 000000000000..b8dd7d232103
--- /dev/null
+++ b/comms/hackrf/Makefile
@@ -0,0 +1,23 @@
+# Created by: Tomasz "CeDeROM" CEDRO (http://www.tomek.cedro.info)
+# $FreeBSD$
+
+PORTNAME= hackrf
+PORTVERSION= 2015.07.2
+CATEGORIES= comms devel hamradio science security
+
+MAINTAINER= cederom@tlen.pl
+COMMENT= Low cost open source hardware software radio platform
+
+LICENSE= GPLv2
+
+USE_GITHUB= YES
+GH_ACCOUNT= mossmann
+GH_TAGNAME= 69c4997
+
+USES= cmake:outsource
+CMAKE_SOURCE_PATH= ${WRKSRC}/host
+CMAKE_ARGS= -DLIBUSB_LIBRARIES=/usr/lib/libusb.so
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>