aboutsummaryrefslogtreecommitdiff
path: root/comms/hamlib
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /comms/hamlib
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'comms/hamlib')
-rw-r--r--comms/hamlib/Makefile7
-rw-r--r--comms/hamlib/pkg-plist7
2 files changed, 5 insertions, 9 deletions
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 12f143a8bab3..14dc5c9e0734 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hamlib
PORTVERSION= 1.2.15.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms hamradio
MASTER_SITES= SF
@@ -16,6 +16,7 @@ BUILD_DEPENDS= swig:${PORTSDIR}/devel/swig13
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
USES= perl5 libtool:keepla pkgconfig pathfix python tcl
+USE_PERL5= build run
USE_GNOME= libxml2
USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
@@ -49,8 +50,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/${d} ${STAGEDIR}${DOCSDIR}
.endfor
-post-stage:
- ${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
- @${RM} -f ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod*
-
.include <bsd.port.mk>
diff --git a/comms/hamlib/pkg-plist b/comms/hamlib/pkg-plist
index 1aa00f13e14d..929453b099ce 100644
--- a/comms/hamlib/pkg-plist
+++ b/comms/hamlib/pkg-plist
@@ -148,10 +148,9 @@ libdata/pkgconfig/hamlib.pc
sbin/rpc.rigd
sbin/rpc.rotd
share/aclocal/hamlib.m4
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hamlib/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Hamlib/Hamlib.so
-%%SITE_PERL%%/%%PERL_ARCH%%/Hamlib.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/perltest.pl
+%%SITE_ARCH%%/auto/Hamlib/Hamlib.so
+%%SITE_ARCH%%/Hamlib.pm
+%%SITE_ARCH%%/perltest.pl
%%PYTHON_SITELIBDIR%%/_Hamlib.so
%%PYTHON_SITELIBDIR%%/_Hamlib.la
%%PYTHON_SITELIBDIR%%/_Hamlib.a