aboutsummaryrefslogtreecommitdiff
path: root/comms/hcidump
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-09-06 09:28:23 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-09-06 09:28:23 +0000
commit1277935b6f514e1c52d59f323a69cf9d8d902fd1 (patch)
tree387176267c304377837746a81f3580b16a41ac1e /comms/hcidump
parent52744541bcecd8dc6d0db1d2a7c21616a54a7a50 (diff)
downloadports-1277935b6f514e1c52d59f323a69cf9d8d902fd1.tar.gz
ports-1277935b6f514e1c52d59f323a69cf9d8d902fd1.zip
Resurrect this port. It is actually very useful to debug Bluetooth problems
and also is referenced in the FreeBSD Handbook. Add license (GPLv2) while I am here. Requested by: emax
Notes
Notes: svn path=/head/; revision=281280
Diffstat (limited to 'comms/hcidump')
-rw-r--r--comms/hcidump/Makefile24
-rw-r--r--comms/hcidump/distinfo2
-rw-r--r--comms/hcidump/files/patch-hcidump-Makefile19
-rw-r--r--comms/hcidump/files/patch-parser-Makefile12
-rw-r--r--comms/hcidump/files/patch-parser.c11
-rw-r--r--comms/hcidump/pkg-descr5
6 files changed, 73 insertions, 0 deletions
diff --git a/comms/hcidump/Makefile b/comms/hcidump/Makefile
new file mode 100644
index 000000000000..b24e78131c52
--- /dev/null
+++ b/comms/hcidump/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hcidump
+# Date created: 10 Dec 2004
+# Whom: Pav Lucistnik <pav@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hcidump
+PORTVERSION= 1.5.1
+CATEGORIES= comms sysutils
+MASTER_SITES= http://bsd-geek.de/FreeBSD/distfiles/
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= Bluetooth traffic dumper, similar to tcpdump
+
+LICENSE= GPLv2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= hcidump.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/hcidump
+
+.include <bsd.port.mk>
diff --git a/comms/hcidump/distinfo b/comms/hcidump/distinfo
new file mode 100644
index 000000000000..db5382aa86f5
--- /dev/null
+++ b/comms/hcidump/distinfo
@@ -0,0 +1,2 @@
+SHA256 (hcidump-1.5.1.tar.gz) = fffd83539c9e1c565a381bc4e178597be0c64a1eb3364e6ce31db1f30827ab4e
+SIZE (hcidump-1.5.1.tar.gz) = 32480
diff --git a/comms/hcidump/files/patch-hcidump-Makefile b/comms/hcidump/files/patch-hcidump-Makefile
new file mode 100644
index 000000000000..cc47e508a4b5
--- /dev/null
+++ b/comms/hcidump/files/patch-hcidump-Makefile
@@ -0,0 +1,19 @@
+--- hcidump/Makefile.orig Fri Mar 12 23:16:58 2004
++++ hcidump/Makefile Fri Dec 10 21:06:23 2004
+@@ -2,13 +2,12 @@
+ # $FreeBSD$
+
+ PROG= hcidump
+-BINDIR= /usr/local/bin
+-MANDIR= /usr/local/man/man
++BINDIR= ${PREFIX}/bin
++MANDIR= ${PREFIX}/man/man
+ MAN1= hcidump.1
+ SRCS= hcidump.c
+ WARNS?= 2
+-DEBUG_FLAGS= -g
+-CFLAGS= -O2 -I../parser
++CFLAGS+= -I../parser
+
+ DPADD+= ../parser/libparser.a
+ LDADD+= -L../parser -lparser
diff --git a/comms/hcidump/files/patch-parser-Makefile b/comms/hcidump/files/patch-parser-Makefile
new file mode 100644
index 000000000000..ecb5464b60d3
--- /dev/null
+++ b/comms/hcidump/files/patch-parser-Makefile
@@ -0,0 +1,12 @@
+--- parser/Makefile.orig Fri Mar 12 23:16:59 2004
++++ parser/Makefile Fri Dec 10 21:07:28 2004
+@@ -7,8 +7,7 @@
+ MAN=
+ SRCS= bnep.c cmtp.c hidp.c l2cap.c rfcomm.c hci.c parser.c sdp.c
+ WARNS?= 2
+-DEBUG_FLAGS= -g
+-CFLAGS= -O2
++CFLAGS?= -O2
+
+ NOPROFILE= 1
+
diff --git a/comms/hcidump/files/patch-parser.c b/comms/hcidump/files/patch-parser.c
new file mode 100644
index 000000000000..8ed8a87e7ed4
--- /dev/null
+++ b/comms/hcidump/files/patch-parser.c
@@ -0,0 +1,11 @@
+--- parser/parser.c.ORIG Fri Sep 22 23:33:36 2006
++++ parser/parser.c Fri Sep 22 23:34:45 2006
+@@ -65,7 +65,7 @@
+
+ if (!parser.state) {
+ if (parser.flags & DUMP_TSTAMP)
+- printf("%8lu.%06lu ", f->ts.tv_sec, f->ts.tv_usec);
++ printf("%8lu.%06lu ", (unsigned long)f->ts.tv_sec, f->ts.tv_usec);
+ printf("%c ", (f->in ? '>' : '<'));
+ parser.state = 1;
+ } else
diff --git a/comms/hcidump/pkg-descr b/comms/hcidump/pkg-descr
new file mode 100644
index 000000000000..97b8df0b982c
--- /dev/null
+++ b/comms/hcidump/pkg-descr
@@ -0,0 +1,5 @@
+HCIdump reads raw HCI data coming from and going to a Bluetooth device and
+prints commands, events and, data in a human-readable form.
+
+Optionally, the dump can be written to a file rather than parsed, so that
+dump file can be parsed later.