aboutsummaryrefslogtreecommitdiff
path: root/comms/hso-kmod/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-18 15:44:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-18 15:44:54 +0000
commit57d6225b2bb8c7b181426fd9f887b195c0824730 (patch)
tree0dbd188d670cde0e353401bb6716e1e205104574 /comms/hso-kmod/files
parentef850abeba460cfad13b62ebe470b24342165c07 (diff)
downloadports-57d6225b2bb8c7b181426fd9f887b195c0824730.tar.gz
ports-57d6225b2bb8c7b181426fd9f887b195c0824730.zip
Notes
Diffstat (limited to 'comms/hso-kmod/files')
-rw-r--r--comms/hso-kmod/files/HSO-DEBUG-patch-Makefile11
-rw-r--r--comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile9
-rw-r--r--comms/hso-kmod/files/option-icon.conf.sample7
-rw-r--r--comms/hso-kmod/files/patch-if_hso.c20
-rw-r--r--comms/hso-kmod/files/pkg-message.in20
5 files changed, 67 insertions, 0 deletions
diff --git a/comms/hso-kmod/files/HSO-DEBUG-patch-Makefile b/comms/hso-kmod/files/HSO-DEBUG-patch-Makefile
new file mode 100644
index 000000000000..9cf82162c477
--- /dev/null
+++ b/comms/hso-kmod/files/HSO-DEBUG-patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2008-05-14 14:18:19.880920578 +0200
++++ Makefile 2008-05-14 14:18:29.051785451 +0200
+@@ -2,7 +2,7 @@
+ S= ${.CURDIR}/../..
+ .PATH: $S/dev/usb
+
+-CFLAGS+= -DUSB_DEBUG=1 -DHSO_DEBUG=-1 -g
++#CFLAGS+= -DUSB_DEBUG=1 -DHSO_DEBUG=-1 -g
+ KMOD= hso
+ SRCS= if_hso.c opt_usb.h device_if.h bus_if.h usbdevs.h
+
diff --git a/comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile b/comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile
new file mode 100644
index 000000000000..c1a8b8fab908
--- /dev/null
+++ b/comms/hso-kmod/files/HSOCTL-DEBUG-patch-Makefile
@@ -0,0 +1,9 @@
+--- Makefile.orig 2008-05-14 14:18:53.751411172 +0200
++++ Makefile 2008-05-14 14:19:01.497294028 +0200
+@@ -1,5 +1,5 @@
+ SRCS= hsoctl.c
+ PROG= hsoctl
+-CFLAGS+= -g
++#CFLAGS+= -g
+
+ .include <bsd.prog.mk>
diff --git a/comms/hso-kmod/files/option-icon.conf.sample b/comms/hso-kmod/files/option-icon.conf.sample
new file mode 100644
index 000000000000..a133356969bf
--- /dev/null
+++ b/comms/hso-kmod/files/option-icon.conf.sample
@@ -0,0 +1,7 @@
+attach 100 {
+match "device-name" "umass[0-9]+";
+match "vendor" "0x0af0";
+match "product" "0x6911|0x6971|0x7251|0x7401";
+match "devclass" "0x00";
+action "sleep 1; /sbin/camcontrol cmd `/sbin/camcontrol devlist | /usr/bin/grep ZCOPTION | /usr/bin/awk '{match($11, /pass[0-9]+/); print substr($11, RSTART, RLENGTH) }'` -c '01 00 00 00 00 00' -i 1 i1 > /dev/null";
+};
diff --git a/comms/hso-kmod/files/patch-if_hso.c b/comms/hso-kmod/files/patch-if_hso.c
new file mode 100644
index 000000000000..253d3085c40d
--- /dev/null
+++ b/comms/hso-kmod/files/patch-if_hso.c
@@ -0,0 +1,20 @@
+--- if_hso.c.orig 2008-05-18 15:16:15.402471749 +0200
++++ if_hso.c 2008-05-18 15:16:54.689656014 +0200
+@@ -831,7 +831,7 @@
+
+ ht = tp->t_sc;
+ if (cnt > ht->ht_obufsz) {
+- DPRINTF(1, "too many bytes %d, reducing to %d\n",
++ DPRINTF(1, "too many bytes %d, reducing to %zd\n",
+ cnt, ht->ht_obufsz);
+ cnt = ht->ht_obufsz;
+ }
+@@ -1005,7 +1005,7 @@
+ len = m->m_pkthdr.len - ETHER_HDR_LEN;
+ m_copydata(m, ETHER_HDR_LEN, len, ib->ib_buf);
+
+- DPRINTF(5, "hso_if_start: mlen=%d, len=%d\n",
++ DPRINTF(5, "hso_if_start: mlen=%d, len=%zd\n",
+ m->m_pkthdr.len, len);
+
+ m_freem(m);
diff --git a/comms/hso-kmod/files/pkg-message.in b/comms/hso-kmod/files/pkg-message.in
new file mode 100644
index 000000000000..40fcc68195de
--- /dev/null
+++ b/comms/hso-kmod/files/pkg-message.in
@@ -0,0 +1,20 @@
+
+===============================================================================
+
+This port has installed the hso kernel module.
+
+1) To load the kernel module at boot time,
+add the following line to /boot/loader.conf:
+
+hso_load="YES"
+
+2) If you have installed devd files, restart devd :
+/etc/rc.d/devd restart
+
+3) If you have built the hsoctl utility, use it to connect :
+e.g. : hsoctl -a bredband.tre.se -p 1234 hso0
+
+4) Enjoy !
+
+===============================================================================
+