aboutsummaryrefslogtreecommitdiff
path: root/comms/hylafax
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-15 16:46:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-15 16:46:55 +0000
commit1e9daf32c553888fe783c5b776e791d122fe6f98 (patch)
treeee83e00c46a135b87f463c725327d5f6e64c1d29 /comms/hylafax
parent6e64e601329d42246f92c9f25064315946589550 (diff)
downloadports-1e9daf32c553888fe783c5b776e791d122fe6f98.tar.gz
ports-1e9daf32c553888fe783c5b776e791d122fe6f98.zip
- use OPTIONS_DEFINE
Notes
Notes: svn path=/head/; revision=299364
Diffstat (limited to 'comms/hylafax')
-rw-r--r--comms/hylafax/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index fb34ea88ffa7..d702b518c3f7 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -57,9 +57,10 @@ MAN8= choptest.8c cqtest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
-OPTIONS= PAM "Include pam support" ON \
- NLS "Native Language Support" ON \
- GAWK "Use gawk for scripts" OFF \
+OPTIONS_DEFINE= PAM NLS GAWK
+OPTIONS_DEFAULT=PAM NLS
+NO_OPTIONS_SORT=yes
+GAWK_DESC= Use gawk for scripts
.include <bsd.port.pre.mk>
@@ -69,7 +70,7 @@ CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
.endif
# Want PAM?
-.if defined(WITHOUT_PAM)
+.if empty(PORT_OPTIONS:MPAM)
CONFIGURE_ARGS+=--disable-pam
.endif
@@ -92,12 +93,12 @@ PLIST_SUB+= HYLAFAX_SPOOL=${HYLAFAX_SPOOL}
CONFIGURE_ARGS+=--nointeractive
.endif
-.if defined(WITH_GAWK)
+.if ${PORT_OPTIONS:MGAWK}
BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
CONFIGURE_ARGS+=--with-AWK="${LOCALBASE}/bin/gawk"
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= WITH_NLS=""
.else