aboutsummaryrefslogtreecommitdiff
path: root/comms/kb
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2008-07-18 00:23:52 +0000
committerDiane Bruce <db@FreeBSD.org>2008-07-18 00:23:52 +0000
commite38f60b9177d75d0c556afb87aec664506550081 (patch)
tree5535afa754ad2ed75fd8d231ed6ee690aeb4ba47 /comms/kb
parent53021b6530debcc3445c5a9aca83e9e98f1277b9 (diff)
downloadports-e38f60b9177d75d0c556afb87aec664506550081.tar.gz
ports-e38f60b9177d75d0c556afb87aec664506550081.zip
- Add patch to allow slightly off screen resolutions to work.
Notes
Notes: svn path=/head/; revision=217001
Diffstat (limited to 'comms/kb')
-rw-r--r--comms/kb/Makefile2
-rw-r--r--comms/kb/files/patch-init.c33
2 files changed, 31 insertions, 4 deletions
diff --git a/comms/kb/Makefile b/comms/kb/Makefile
index 382415824c1d..45d9cc753832 100644
--- a/comms/kb/Makefile
+++ b/comms/kb/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kb
PORTVERSION= 8.04
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= http://www.db.net/downloads/ \
${MASTER_SITE_LOCAL}
diff --git a/comms/kb/files/patch-init.c b/comms/kb/files/patch-init.c
index 2227c09a0e66..e39c0aab5075 100644
--- a/comms/kb/files/patch-init.c
+++ b/comms/kb/files/patch-init.c
@@ -1,5 +1,5 @@
---- init.c.orig 2008-05-27 11:46:25.000000000 -0400
-+++ init.c 2008-05-27 11:47:49.000000000 -0400
+--- init.c.orig 2008-03-30 09:33:37.000000000 -0400
++++ init.c 2008-07-17 15:33:42.000000000 -0400
@@ -525,6 +525,8 @@
pfd = pango_font_description_from_string ("misc fixed 16");
pfm = pango_context_get_metrics (pc, pfd, pl);
@@ -9,7 +9,7 @@
if(ipfmgadw/PANGO_SCALE==wcol)
{
cursor_offset = 4;
-@@ -533,6 +535,7 @@
+@@ -533,10 +535,11 @@
pango_font_description_free (pfd);
}
else
@@ -17,3 +17,30 @@
{
for(nff=0; nff<2; nff++)
{
+- for(font_size=10; font_size<=24; font_size++)
++ for(font_size=10; font_size<=32; font_size++)
+ {
+ pango_font_metrics_unref (pfm);
+ pango_font_description_free (pfd);
+@@ -545,7 +548,7 @@
+ pfd = pango_font_description_from_string (font_desc);
+ pfm = pango_context_get_metrics (pc, pfd, pl);
+ ipfmgadw = pango_font_metrics_get_approximate_digit_width (pfm);
+- if(ipfmgadw/PANGO_SCALE==wcol)
++ if(ipfmgadw/PANGO_SCALE>=wcol)
+ {
+ nfound = TRUE;
+ ipfmgd = pango_font_metrics_get_descent (pfm);
+@@ -562,7 +565,11 @@
+ pango_font_metrics_unref (pfm);
+ pango_font_description_free (pfd);
+ if(nfound)
+- printf("Found a good font [%s]\n", font_desc);
++ {
++ if(ipfmgadw/PANGO_SCALE>wcol)
++ printf("Font may appear squashed due to your screen resolution\n");
++ printf("Found a good font [%s] font_size %d\n", font_desc, font_size);
++ }
+ else
+ {
+ printf("Cannot find a suitable font for your system!\n");