aboutsummaryrefslogtreecommitdiff
path: root/comms/klog
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2018-04-06 23:08:50 +0000
committerDiane Bruce <db@FreeBSD.org>2018-04-06 23:08:50 +0000
commit278005c4874d71998c1d6e4d36af8c82985477a6 (patch)
tree5105f34adca8ba6edd4ce6b8292b1abcb9ff3a88 /comms/klog
parent170df6304a8be0d7761db5565a623778c838f186 (diff)
downloadports-278005c4874d71998c1d6e4d36af8c82985477a6.tar.gz
ports-278005c4874d71998c1d6e4d36af8c82985477a6.zip
Update klog
April - 0.9.3 - Double clicking on DXCC Widget name of the Entity will show the QSO is providing that status on the Search widget. - Added DXCC support for Kosovo. - Bugfix: Default band & mode are now defined as the most used band and mode. - Bugfix: TX frequency was not saved. - Bugfix: In the dxcc status widget, some countries were showing the UN flag unappropriately. - Bugfix: When updating the CTY file, query errors were shown on world.readCTYCSV function. - Bugfix: When editing the QRZ, the cursor position was not properly maintained. - Bugfix: Fixed the flags of several DXCC entities that were not correctly shown. - Bugfix: DXCC Status widget was not listing all the DX entities. - Bugfix: Modes & Bands where not always properly updated from the Setup. - Bugfix: Adding new QSO that implies a DXCC or WAZ status already worked failed. - Bugfix: Updating the WAZ status was not always possible due to a incorrect DB query. - Updated translations: Danish (TNX Joe), Spanish (EA4TV).
Notes
Notes: svn path=/head/; revision=466692
Diffstat (limited to 'comms/klog')
-rw-r--r--comms/klog/Makefile17
-rw-r--r--comms/klog/distinfo5
-rw-r--r--comms/klog/files/patch-setuppagelogsnew.cpp10
3 files changed, 14 insertions, 18 deletions
diff --git a/comms/klog/Makefile b/comms/klog/Makefile
index 63f8e4a5f588..9d95f51bf0ba 100644
--- a/comms/klog/Makefile
+++ b/comms/klog/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= klog
-PORTVERSION= 0.9.2.3
+PORTVERSION= 0.9.3
CATEGORIES= comms hamradio
MASTER_SITES= SAVANNAH
@@ -12,7 +12,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
USES= qmake
-USE_QT5= buildtools_build core gui linguisttools_build network \
+USE_QT5= buildtools_build core gui linguisttools_build multimedia network \
printsupport sql sql-sqlite3_run widgets
DESKTOP_ENTRIES= "KLog" "Simple Amateur Radio Logging Program" \
"" "klog" "Network;HamRadio;" \
@@ -22,6 +22,11 @@ PLIST_FILES= bin/klog \
${DATADIR}/translations/klog_ca.qm \
${DATADIR}/translations/klog_es.qm \
${DATADIR}/translations/klog_ja.qm \
+ ${DATADIR}/translations/klog_da.qm \
+ ${DATADIR}/translations/klog_fi.qm \
+ ${DATADIR}/translations/klog_hr.qm \
+ ${DATADIR}/translations/klog_it.qm \
+ ${DATADIR}/translations/klog_pl.qm \
man/man1/klog.1.gz
post-patch:
@@ -30,13 +35,13 @@ post-patch:
s|);|, "${DATADIR}/translations/");|' \
${WRKSRC}/main.cpp
-post-build:
- ${LRELEASE} ${WRKSRC}/${PORTNAME}.pro
+#post-build:
+# ${LRELEASE} ${WRKSRC}/${PORTNAME}.pro
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/klog ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/target/klog ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DATADIR}/translations
- ${INSTALL_DATA} ${WRKSRC}/translations/klog_*.qm \
+ ${INSTALL_DATA} ${WRKSRC}/build/target/translations/klog_*.qm \
${STAGEDIR}${DATADIR}/translations
${INSTALL_MAN} ${WRKSRC}/klog.1 ${STAGEDIR}${MANPREFIX}/man/man1
diff --git a/comms/klog/distinfo b/comms/klog/distinfo
index 79ac14414f0a..8ade663de000 100644
--- a/comms/klog/distinfo
+++ b/comms/klog/distinfo
@@ -1,2 +1,3 @@
-SHA256 (klog-0.9.2.3.tar.gz) = 992973b15270782e92d5aa4e42d966ed240ff3f44dba49bb3274ae6d4ae67cb6
-SIZE (klog-0.9.2.3.tar.gz) = 1159783
+TIMESTAMP = 1522971958
+SHA256 (klog-0.9.3.tar.gz) = 46df382328ff4681036fd1d719069f4aaab94a8defc3cb50e5706448f5a34c6c
+SIZE (klog-0.9.3.tar.gz) = 1891616
diff --git a/comms/klog/files/patch-setuppagelogsnew.cpp b/comms/klog/files/patch-setuppagelogsnew.cpp
deleted file mode 100644
index 31a868f8e8e6..000000000000
--- a/comms/klog/files/patch-setuppagelogsnew.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- setuppagelogsnew.cpp.orig 2015-09-15 18:40:58 UTC
-+++ setuppagelogsnew.cpp
-@@ -735,6 +735,7 @@ bool SetupPageLogsNew::isThereAnyNotMana
- //qDebug() << "SetupPageLogsNew::isThereAnyNotManagedLog tras el while" << endl;
- }
- //qDebug() << "SetupPageLogsNew::isThereAnyNotManagedLog END" << endl;
-+ return true;
- }
-
- void SetupPageLogsNew::setStationCallSign(const QString _st)