aboutsummaryrefslogtreecommitdiff
path: root/comms/libfec
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-08 21:30:18 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-08 21:30:18 +0000
commit19054810ba299f96d321510eae657c858a9e30e2 (patch)
treee590862da722f3294858f040629444910d7fa4d2 /comms/libfec
parent130a71d2606cdc5b6378c026442764e42377baa4 (diff)
downloadports-19054810ba299f96d321510eae657c858a9e30e2.tar.gz
ports-19054810ba299f96d321510eae657c858a9e30e2.zip
This library package provides several forward error correction (FEC) decoders
and accelerated primitives useful in digital signal processing (DSP). Except for the Reed-Solomon codecs, these functions take full advantage of the MMX, SSE and SSE2 SIMD instruction sets on Intel/AMD IA-32 processors and the Altivec/VMX/Velocity Engine SIMD instruction set on the G4 and G5 PowerPC. The library includes Viterbi decoders for the following convolutional codes: rate 1/2 k=7 rate 1/2 k=9 rate 1/6 k=15 ("Cassini") plus two Reed-Solomon encoder-decoders: one optimized for the (255,223) CCSDS standard code a general purpose encoder/decoder for arbitrary RS codes and three low-level 16-bit DSP support routines: signed dot product peak detection sum-of-squares (energy) computation This library is licensed under the "lesser" GNU General Public License. WWW: http://www.ka9q.net/code/fec/ - Diane Bruce, VA3DB db@db.net PR: ports/99895 Submitted by: db
Notes
Notes: svn path=/head/; revision=167213
Diffstat (limited to 'comms/libfec')
-rw-r--r--comms/libfec/Makefile34
-rw-r--r--comms/libfec/distinfo3
-rw-r--r--comms/libfec/pkg-descr23
-rw-r--r--comms/libfec/pkg-plist3
4 files changed, 63 insertions, 0 deletions
diff --git a/comms/libfec/Makefile b/comms/libfec/Makefile
new file mode 100644
index 000000000000..9d7a74b35f55
--- /dev/null
+++ b/comms/libfec/Makefile
@@ -0,0 +1,34 @@
+# ports collection makefile for: fec
+# Date created: 7 July 2006
+# Whom: db
+#
+# $FreeBSD$
+
+PORTNAME= libfec
+PORTVERSION= 2.1.1
+CATEGORIES= comms astro hamradio
+MASTER_SITES= http://www.ka9q.net/code/fec/
+DISTNAME= fec-${PORTVERSION}
+
+MAINTAINER= db@db.net
+COMMENT= Several forward error correction (FEC) decoders
+
+MAKEFILE= makefile
+MAN3= simd-viterbi.3 rs.3 dsp.3
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+ONLY_FOR_ARCHS= i386
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|gcc|${CC}|g' ${WRKSRC}/makefile.in
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/libfec/distinfo b/comms/libfec/distinfo
new file mode 100644
index 000000000000..6709a581ad3b
--- /dev/null
+++ b/comms/libfec/distinfo
@@ -0,0 +1,3 @@
+MD5 (fec-2.1.1.tar.bz2) = 3dca8111b8ce46809a7ea51b9d9df746
+SHA256 (fec-2.1.1.tar.bz2) = 4984ff33ed7609189c50f216e0a20eef1c72b72b031cdc0afbed80066073e99e
+SIZE (fec-2.1.1.tar.bz2) = 85871
diff --git a/comms/libfec/pkg-descr b/comms/libfec/pkg-descr
new file mode 100644
index 000000000000..fac19b389e10
--- /dev/null
+++ b/comms/libfec/pkg-descr
@@ -0,0 +1,23 @@
+This library package provides several forward error correction (FEC) decoders
+and accelerated primitives useful in digital signal processing (DSP).
+Except for the Reed-Solomon codecs, these functions take full advantage of
+the MMX, SSE and SSE2 SIMD instruction sets on Intel/AMD IA-32 processors
+and the Altivec/VMX/Velocity Engine SIMD instruction set on the
+G4 and G5 PowerPC.
+The library includes Viterbi decoders for the following convolutional codes:
+rate 1/2 k=7
+rate 1/2 k=9
+rate 1/6 k=15 ("Cassini")
+plus two Reed-Solomon encoder-decoders:
+one optimized for the (255,223) CCSDS standard code
+a general purpose encoder/decoder for arbitrary RS codes
+and three low-level 16-bit DSP support routines:
+signed dot product
+peak detection
+sum-of-squares (energy) computation
+This library is licensed under the "lesser" GNU General Public License.
+
+WWW: http://www.ka9q.net/code/fec/
+
+- Diane Bruce, VA3DB
+db@db.net
diff --git a/comms/libfec/pkg-plist b/comms/libfec/pkg-plist
new file mode 100644
index 000000000000..37dde711229a
--- /dev/null
+++ b/comms/libfec/pkg-plist
@@ -0,0 +1,3 @@
+include/fec.h
+lib/libfec.so
+lib/libfec.a