aboutsummaryrefslogtreecommitdiff
path: root/comms/libfec
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-10 22:07:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-10 22:07:16 +0000
commit6b4524a77d991fd79df3fe018fec4615107192a6 (patch)
tree88a5261487538e84e1c0268f2d5b62ef27f2ef27 /comms/libfec
parent56ece1a5cc413cbe16163c5e731c4ed0aee1967b (diff)
downloadports-6b4524a77d991fd79df3fe018fec4615107192a6.tar.gz
ports-6b4524a77d991fd79df3fe018fec4615107192a6.zip
- Update to 3.0
PR: ports/106542 Submitted by: Thomas Sandford <freebsduser@paradisegreen.co.uk> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=179418
Diffstat (limited to 'comms/libfec')
-rw-r--r--comms/libfec/Makefile6
-rw-r--r--comms/libfec/distinfo6
-rw-r--r--comms/libfec/files/patch-fec.c44
3 files changed, 50 insertions, 6 deletions
diff --git a/comms/libfec/Makefile b/comms/libfec/Makefile
index 9d7a74b35f55..dc6da1c9584f 100644
--- a/comms/libfec/Makefile
+++ b/comms/libfec/Makefile
@@ -5,8 +5,8 @@
# $FreeBSD$
PORTNAME= libfec
-PORTVERSION= 2.1.1
-CATEGORIES= comms astro hamradio
+PORTVERSION= 3.0
+CATEGORIES= comms astro hamradio math
MASTER_SITES= http://www.ka9q.net/code/fec/
DISTNAME= fec-${PORTVERSION}
@@ -19,7 +19,7 @@ MAN3= simd-viterbi.3 rs.3 dsp.3
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386
post-patch:
diff --git a/comms/libfec/distinfo b/comms/libfec/distinfo
index 6709a581ad3b..d5e253289ce8 100644
--- a/comms/libfec/distinfo
+++ b/comms/libfec/distinfo
@@ -1,3 +1,3 @@
-MD5 (fec-2.1.1.tar.bz2) = 3dca8111b8ce46809a7ea51b9d9df746
-SHA256 (fec-2.1.1.tar.bz2) = 4984ff33ed7609189c50f216e0a20eef1c72b72b031cdc0afbed80066073e99e
-SIZE (fec-2.1.1.tar.bz2) = 85871
+MD5 (fec-3.0.tar.bz2) = cdc0ee233dda7678a3627543180b24a6
+SHA256 (fec-3.0.tar.bz2) = 5b9ee31465798f109f2100acd7a6ed83eaa1431a6833f155fa30952eb42d2cdd
+SIZE (fec-3.0.tar.bz2) = 99980
diff --git a/comms/libfec/files/patch-fec.c b/comms/libfec/files/patch-fec.c
new file mode 100644
index 000000000000..47fd34954eb9
--- /dev/null
+++ b/comms/libfec/files/patch-fec.c
@@ -0,0 +1,44 @@
+--- fec.c.orig Sat Dec 9 22:04:49 2006
++++ fec.c Sat Dec 9 22:01:43 2006
+@@ -3,6 +3,10 @@
+ */
+
+ #include <stdio.h>
++#include <errno.h>
++#include <stdlib.h>
++#include <sys/param.h>
++
+ #include "fec.h"
+
+ unsigned char Partab[256];
+@@ -64,3 +68,30 @@
+ 5, 6, 6, 7, 6, 7, 7, 8,
+ };
+
++#if __FreeBSD_version <700000
++
++int
++posix_memalign(void **memptr, size_t alignment, size_t size)
++{
++ int err;
++ void *result;
++
++ /* Make sure that alignment is a large enough power of 2. */
++ if (((alignment - 1) & alignment) != 0 || alignment < sizeof(void *))
++ return (EINVAL);
++
++ /*
++ * (size | alignment) is enough to assure the requested alignment, since
++ * the allocator always allocates power-of-two blocks.
++ */
++ err = errno; /* Protect errno against changes in pubrealloc(). */
++ result = malloc(size | alignment);
++ errno = err;
++
++ if (result == NULL)
++ return (ENOMEM);
++
++ *memptr = result;
++ return (0);
++}
++#endif