aboutsummaryrefslogtreecommitdiff
path: root/comms/libfec
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-02-14 10:57:11 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-02-14 10:57:11 +0000
commit705ca33af2d723ab847c8628719c29fdb29df72f (patch)
tree291a58a620882ca42931655ce366bc16f4befacd /comms/libfec
parent432f9eb3b3d4e40246988706b0d860e5d240d229 (diff)
downloadports-705ca33af2d723ab847c8628719c29fdb29df72f.tar.gz
ports-705ca33af2d723ab847c8628719c29fdb29df72f.zip
Use -fPIC for all architectures because the makefile tries to create a
shared library libfec.so from object files compiled without -fPIC.
Notes
Notes: svn path=/head/; revision=434076
Diffstat (limited to 'comms/libfec')
-rw-r--r--comms/libfec/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/comms/libfec/Makefile b/comms/libfec/Makefile
index 6e5e198afc07..9e0e79cc43a8 100644
--- a/comms/libfec/Makefile
+++ b/comms/libfec/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libfec
PORTVERSION= 3.0.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms astro hamradio math
MASTER_SITES= http://www.ka9q.net/code/fec/ \
LOCAL/db
@@ -26,8 +26,8 @@ PLIST_FILES= include/fec.h \
man/man3/rs.3.gz \
man/man3/simd-viterbi.3.gz
-CFLAGS_aarch64= -fPIC
-CFLAGS_amd64= -fPIC
+# makefile tries to create libfec.so from object files compiled without -fPIC.
+CFLAGS+= -fPIC
post-patch:
@${CP} ${FILESDIR}/cpu_mode.c ${WRKSRC}