aboutsummaryrefslogtreecommitdiff
path: root/comms/libimobiledevice
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 14:00:13 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-05 14:23:45 +0000
commit148f9e0f2cd9090ac22b2a426ee382c312ece6a6 (patch)
treeaf7607baf166e72d5e0720322307a198385a73f4 /comms/libimobiledevice
parent6298a7853eb2b88142eddde49a1a1d7e2a3f44fe (diff)
downloadports-148f9e0f2cd9090ac22b2a426ee382c312ece6a6.tar.gz
ports-148f9e0f2cd9090ac22b2a426ee382c312ece6a6.zip
comms/{py-}libimobiledevice: Fix build on llvm15
- While I am here utilize USES=localbase:ldflags Approved by: portmgr (blanket)
Diffstat (limited to 'comms/libimobiledevice')
-rw-r--r--comms/libimobiledevice/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index bb58a406dc91..e19006b9dadc 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -13,12 +13,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
SLAVE_PORT?= no
-USES+= cpe libtool localbase pathfix pkgconfig ssl tar:bzip2
+USES+= cpe libtool localbase:ldflags pathfix pkgconfig ssl tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=openssl_CFLAGS="-I${OPENSSLINC}" \
openssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
.if ${SLAVE_PORT} == no
@@ -46,4 +44,10 @@ post-install:
.endif # ${SLAVE_PORT} == no
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
+.include <bsd.port.post.mk>