aboutsummaryrefslogtreecommitdiff
path: root/comms/libimobiledevice
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-10 19:50:23 +0000
commit3b7bd0a1490f574288fc9a02617a19cf238254e0 (patch)
treec05d182f965de6bace293ed87ece71bd45e7c422 /comms/libimobiledevice
parent913e08e52dca0eafb130dc0942c6275a178095ea (diff)
downloadports-3b7bd0a1490f574288fc9a02617a19cf238254e0.tar.gz
ports-3b7bd0a1490f574288fc9a02617a19cf238254e0.zip
Fix problems with missing libs when the linker enforces explicit linking
(a* to d* categories) PR: 192062
Notes
Notes: svn path=/head/; revision=364564
Diffstat (limited to 'comms/libimobiledevice')
-rw-r--r--comms/libimobiledevice/Makefile12
-rw-r--r--comms/libimobiledevice/files/patch-configure10
2 files changed, 6 insertions, 16 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 4b399ec74af7..0c30addf90f3 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -13,11 +13,13 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES= pkgconfig tar:bzip2
+USES= pathfix pkgconfig tar:bzip2
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= openssl_LIBS=-lssl
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= openssl_CFLAGS="-I${OPENSSLINC}" \
+ openssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
.if ${SLAVE_PORT} == "no"
@@ -36,8 +38,6 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's, *@ssl_requires@,,' \
${WRKSRC}/${PORTNAME}*.pc.in
- @${REINPLACE_CMD} -e 's,$$(libdir)/pkgconfig,${PREFIX}/libdata/pkgconfig,g' \
- ${WRKSRC}/Makefile.in
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/comms/libimobiledevice/files/patch-configure b/comms/libimobiledevice/files/patch-configure
deleted file mode 100644
index c286b6f000ac..000000000000
--- a/comms/libimobiledevice/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./configure.orig 2013-03-18 10:28:26.000000000 +0100
-+++ ./configure 2013-04-30 14:56:00.356777062 +0200
-@@ -17262,6 +17262,7 @@
- $as_echo "yes" >&6; }
- have_openssl=yes
- fi
-+have_openssl=yes
- if test "x$have_openssl" = "xyes"; then
- if test "x$use_openssl" != "xyes"; then
- enable_openssl=no