aboutsummaryrefslogtreecommitdiff
path: root/comms/libimobiledevice
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2014-09-28 22:58:51 +0000
committerAlberto Villa <avilla@FreeBSD.org>2014-09-28 22:58:51 +0000
commitc6c79da969e63a1b59f318e5e20c9a2475290bf2 (patch)
tree3519e27224702b200392e2556264193fb94f359e /comms/libimobiledevice
parent0393573f88dd44a26be995caa3ce8ef85916f214 (diff)
downloadports-c6c79da969e63a1b59f318e5e20c9a2475290bf2.tar.gz
ports-c6c79da969e63a1b59f318e5e20c9a2475290bf2.zip
- Update libplist to 1.11.
- Split libusbmuxd.so into comms/libusbmuxd and update to 1.0.9. - Update libimobiledevice to 1.1.6. - Update usbmuxd to Git snapshot (~1.0.9). - Document usbmuxd upgrade process. This marks an important refactoring effort for proper iOS 7 support. It's packed with new features, tools, speed improvements, code refactoring, crash fixes, memory leak fixes and much more.
Notes
Notes: svn path=/head/; revision=369503
Diffstat (limited to 'comms/libimobiledevice')
-rw-r--r--comms/libimobiledevice/Makefile14
-rw-r--r--comms/libimobiledevice/distinfo4
-rw-r--r--comms/libimobiledevice/files/patch-configure19
-rw-r--r--comms/libimobiledevice/files/patch-git_62ab50f11
-rw-r--r--comms/libimobiledevice/pkg-plist7
5 files changed, 34 insertions, 21 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 4efaa5b31fbd..bd13e14cc8cf 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= libimobiledevice
-PORTVERSION= 1.1.5
-PORTREVISION?= 1
+PORTVERSION= 1.1.6
+PORTREVISION?= 0
CATEGORIES?= comms
MASTER_SITES= http://www.${PORTNAME}.org/downloads/
@@ -13,19 +13,19 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES= libtool pathfix pkgconfig tar:bzip2
+USES+= libtool pathfix pkgconfig tar:bzip2
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= openssl_CFLAGS="-I${OPENSSLINC}" \
+CONFIGURE_ARGS+=openssl_CFLAGS="-I${OPENSSLINC}" \
openssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-.if ${SLAVE_PORT} == "no"
+.if ${SLAVE_PORT} == no
LIB_DEPENDS= libplist.so:${PORTSDIR}/devel/libplist \
- libusbmuxd.so:${PORTSDIR}/comms/usbmuxd
+ libusbmuxd.so:${PORTSDIR}/comms/libusbmuxd
USE_GNOME= glib20
CONFIGURE_ARGS+=--without-cython
@@ -44,6 +44,6 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif # ${SLAVE_PORT} == "no"
+.endif # ${SLAVE_PORT} == no
.include <bsd.port.mk>
diff --git a/comms/libimobiledevice/distinfo b/comms/libimobiledevice/distinfo
index c332c2b2d692..42d239d35424 100644
--- a/comms/libimobiledevice/distinfo
+++ b/comms/libimobiledevice/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libimobiledevice-1.1.5.tar.bz2) = d52ecd069dfc0abe8a81ed0718540df2def2f84b44e88ea783d44312b6f5f33e
-SIZE (libimobiledevice-1.1.5.tar.bz2) = 577138
+SHA256 (libimobiledevice-1.1.6.tar.bz2) = 1fcd56489a27181617507b1d8aaf122f66d9860c0fe5af4c78f9e0ed129e33e0
+SIZE (libimobiledevice-1.1.6.tar.bz2) = 619429
diff --git a/comms/libimobiledevice/files/patch-configure b/comms/libimobiledevice/files/patch-configure
new file mode 100644
index 000000000000..eb7e68ef9304
--- /dev/null
+++ b/comms/libimobiledevice/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig 2014-09-24 12:07:10 UTC
++++ configure
+@@ -17090,7 +17090,7 @@
+ py_version=$PYTHON_VERSION
+ else
+ py_version=`$PYTHON -c "import sys; \
+- print(sys.version[:3]")`
++ print(sys.version[:3])"`
+ fi
+ fi
+
+@@ -17336,6 +17336,7 @@
+ $as_echo "yes" >&6; }
+ have_openssl=yes
+ fi
++have_openssl=yes
+ if test "x$have_openssl" = "xyes"; then
+ if test "x$use_openssl" != "xyes"; then
+ enable_openssl=no
diff --git a/comms/libimobiledevice/files/patch-git_62ab50f b/comms/libimobiledevice/files/patch-git_62ab50f
deleted file mode 100644
index 66e07a6a512f..000000000000
--- a/comms/libimobiledevice/files/patch-git_62ab50f
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./cython/lockdown.pxi.orig 2013-03-07 23:05:33.000000000 +0100
-+++ ./cython/lockdown.pxi 2013-10-14 02:44:26.489878883 +0200
-@@ -221,7 +221,7 @@
- char* c_session_id = NULL
- bint ssl_enabled
- bytes session_id
-- err = lockdownd_start_session(self._c_client, host_id, &c_session_id, &ssl_enabled)
-+ err = lockdownd_start_session(self._c_client, host_id, &c_session_id, <int *>&ssl_enabled)
- try:
- self.handle_error(err)
-
diff --git a/comms/libimobiledevice/pkg-plist b/comms/libimobiledevice/pkg-plist
index c92304e86cac..5967195ba8e3 100644
--- a/comms/libimobiledevice/pkg-plist
+++ b/comms/libimobiledevice/pkg-plist
@@ -1,12 +1,14 @@
bin/idevice_id
bin/idevicebackup
bin/idevicebackup2
+bin/idevicecrashreport
bin/idevicedate
bin/idevicedebugserverproxy
bin/idevicediagnostics
bin/ideviceenterrecovery
bin/ideviceimagemounter
bin/ideviceinfo
+bin/idevicename
bin/idevicepair
bin/ideviceprovision
bin/idevicescreenshot
@@ -28,6 +30,8 @@ include/libimobiledevice/notification_proxy.h
include/libimobiledevice/restore.h
include/libimobiledevice/sbservices.h
include/libimobiledevice/screenshotr.h
+include/libimobiledevice/service.h
+include/libimobiledevice/syslog_relay.h
include/libimobiledevice/webinspector.h
lib/libimobiledevice.a
lib/libimobiledevice.so
@@ -37,14 +41,15 @@ libdata/pkgconfig/libimobiledevice-1.0.pc
man/man1/idevice_id.1.gz
man/man1/idevicebackup.1.gz
man/man1/idevicebackup2.1.gz
+man/man1/idevicecrashreport.1.gz
man/man1/idevicedate.1.gz
man/man1/idevicedebugserverproxy.1.gz
man/man1/idevicediagnostics.1.gz
man/man1/ideviceenterrecovery.1.gz
man/man1/ideviceimagemounter.1.gz
man/man1/ideviceinfo.1.gz
+man/man1/idevicename.1.gz
man/man1/idevicepair.1.gz
man/man1/ideviceprovision.1.gz
man/man1/idevicescreenshot.1.gz
man/man1/idevicesyslog.1.gz
-@dirrm include/libimobiledevice