aboutsummaryrefslogtreecommitdiff
path: root/comms/libirman
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:21:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 05:21:28 +0000
commitc4a25f6b2ae5d1cdad338b32fe86dbc85384ec22 (patch)
tree51ccd9bb51089538bfe1b4e0d5952b3a54e88837 /comms/libirman
parentb24867305db18906864c48ffc46654a1d0717296 (diff)
downloadports-c4a25f6b2ae5d1cdad338b32fe86dbc85384ec22.tar.gz
ports-c4a25f6b2ae5d1cdad338b32fe86dbc85384ec22.zip
New port for libirman 0.4.2
This is a new port for the libirman library for use with Evation's Irman infrared reciever. PR: ports/50443 Submitted by: Douglas K. Rand <rand@meridian-enviro.com>
Notes
Notes: svn path=/head/; revision=90742
Diffstat (limited to 'comms/libirman')
-rw-r--r--comms/libirman/Makefile20
-rw-r--r--comms/libirman/distinfo1
-rw-r--r--comms/libirman/files/patch-Makefile.in19
-rw-r--r--comms/libirman/files/patch-irman.conf-location11
-rw-r--r--comms/libirman/files/patch-no-flock-of-serial-ports17
-rw-r--r--comms/libirman/pkg-descr9
-rw-r--r--comms/libirman/pkg-plist4
7 files changed, 81 insertions, 0 deletions
diff --git a/comms/libirman/Makefile b/comms/libirman/Makefile
new file mode 100644
index 000000000000..a23e3ac0f29c
--- /dev/null
+++ b/comms/libirman/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: libirman
+# Date created: 2003-03-29
+# Whom: Douglas K. Rand <rand@meridian-enviro.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libirman
+PORTVERSION= 0.4.2
+CATEGORIES= comms
+MASTER_SITES= http://mars.wiwi.uni-halle.de/lirc/software/snapshots/
+
+MAINTAINER= rand@meridian-enviro.com
+COMMENT= Library for Evation's Irman infrared reciever
+
+HAS_CONFIGURE= YES
+USE_GMAKE= YES
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/comms/libirman/distinfo b/comms/libirman/distinfo
new file mode 100644
index 000000000000..5873eea161e8
--- /dev/null
+++ b/comms/libirman/distinfo
@@ -0,0 +1 @@
+MD5 (libirman-0.4.2.tar.gz) = b99017d049685cb84a95098190a89de8
diff --git a/comms/libirman/files/patch-Makefile.in b/comms/libirman/files/patch-Makefile.in
new file mode 100644
index 000000000000..5c2b675e24ec
--- /dev/null
+++ b/comms/libirman/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+--- Makefile.in-orig Sat Mar 29 20:56:03 2003
++++ Makefile.in Sat Mar 29 21:38:07 2003
+@@ -103,7 +103,6 @@
+
+
+ install: @NORMAL@ install-dirs install-normal @INSTALL_SWTEST@
+- @echo notice: the test programs are only installed in the current directory \(`pwd`\)
+
+ install-dirs:
+ $(top_srcdir)/mkinstalldirs $(libdir)
+@@ -114,7 +113,7 @@
+ install-normal:
+ $(INSTALL) -m 755 workmanir $(bindir)/workmanir
+ $(INSTALL) -m 755 libirman.a $(libdir)/libirman.a
+- $(INSTALL) -m 644 irman.conf $(sysconfdir)/irman.conf
++ $(INSTALL) -m 644 irman.conf $(sysconfdir)/irman.conf.sample
+ $(INSTALL) -m 644 irman.h $(includedir)/irman.h
+
+ install-swtest:
diff --git a/comms/libirman/files/patch-irman.conf-location b/comms/libirman/files/patch-irman.conf-location
new file mode 100644
index 000000000000..76aebde5409c
--- /dev/null
+++ b/comms/libirman/files/patch-irman.conf-location
@@ -0,0 +1,11 @@
+--- irman.h-orig Sat Mar 29 20:42:50 2003
++++ irman.h Sat Mar 29 20:43:00 2003
+@@ -48,7 +48,7 @@
+
+ /* filename for system irmanrc */
+ #ifndef IR_SYSCONF_DIR
+-# define IR_SYSCONF_DIR "/etc"
++# define IR_SYSCONF_DIR "/usr/local/etc"
+ #endif
+ #define IR_SYSTEM_IRMANRC IR_SYSCONF_DIR "/irman.conf"
+ /* filename for users irmanrc */
diff --git a/comms/libirman/files/patch-no-flock-of-serial-ports b/comms/libirman/files/patch-no-flock-of-serial-ports
new file mode 100644
index 000000000000..5dbb3fd78b13
--- /dev/null
+++ b/comms/libirman/files/patch-no-flock-of-serial-ports
@@ -0,0 +1,17 @@
+--- irio.c-orig Sat Mar 29 20:26:57 2003
++++ irio.c Sat Mar 29 20:27:12 2003
+@@ -91,14 +91,6 @@
+ return -1;
+ }
+
+- /* lock the file for ourselves */
+- if (flock(portfd, LOCK_EX | LOCK_NB) < 0) {
+- /* unable to get lock */
+- close(portfd);
+- portfd = 0;
+- return -1;
+- }
+-
+ /* get port attributes, store in oldterm */
+ if (tcgetattr(portfd, &oldterm) < 0) {
+ close(portfd);
diff --git a/comms/libirman/pkg-descr b/comms/libirman/pkg-descr
new file mode 100644
index 000000000000..7a5b5501c631
--- /dev/null
+++ b/comms/libirman/pkg-descr
@@ -0,0 +1,9 @@
+libirman is a library for accessing the IRMAN hardware from Linux
+and other Unix systems.
+
+Currently the package is mainly for advanced users and developers; this
+does not mean that less experienced users will not be able to use it, but
+that there are not a lot of applications for libirman at the moment, and
+that if you run into problems you may have difficulty fixing things.
+
+WWW: http://www.evation.com/libirman/
diff --git a/comms/libirman/pkg-plist b/comms/libirman/pkg-plist
new file mode 100644
index 000000000000..4b994117c889
--- /dev/null
+++ b/comms/libirman/pkg-plist
@@ -0,0 +1,4 @@
+bin/workmanir
+etc/irman.conf.sample
+include/irman.h
+lib/libirman.a