aboutsummaryrefslogtreecommitdiff
path: root/comms/linrad
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2007-07-10 16:41:16 +0000
committerDiane Bruce <db@FreeBSD.org>2007-07-10 16:41:16 +0000
commita23d0bf818fb5fc6567195d1f2f7b19e7440fd7a (patch)
treead603475151ccdf82655159e8d948928cfa53c7d /comms/linrad
parent9acc845f5d8a16d1578ae2a5c5befc0140254d92 (diff)
downloadports-a23d0bf818fb5fc6567195d1f2f7b19e7440fd7a.tar.gz
ports-a23d0bf818fb5fc6567195d1f2f7b19e7440fd7a.zip
- update to 2.34
Approved: ehaupt (mentor)
Notes
Notes: svn path=/head/; revision=195372
Diffstat (limited to 'comms/linrad')
-rw-r--r--comms/linrad/Makefile7
-rw-r--r--comms/linrad/distinfo6
-rw-r--r--comms/linrad/files/patch-Makefile.in20
-rw-r--r--comms/linrad/files/patch-help.c8
4 files changed, 18 insertions, 23 deletions
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index 5c365f676fa1..b4156de10b09 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= linrad
-PORTVERSION= 2.28
-PORTREVISION= 1
+PORTVERSION= 2.34
CATEGORIES= comms
MASTER_SITES= http://www.nitehawk.com/sm5bsz/linuxdsp/archive/\
http://g7rau.demon.co.uk/sm5bsz/linuxdsp/archive/\
http://www.sm5bsz.com/linuxdsp/archive/
-DISTNAME= lir02-28
+DISTNAME= lir02-34
EXTRACT_SUFX= .tbz
DIST_SUBDIR= ${PORTNAME}
@@ -29,7 +28,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --sysconfdir=${PREFIX} --mandir=${PREFIX}/man
USE_GMAKE= yes
USE_BZIP2= yes
ALL_TARGET= xlinrad
-USE_X_PREFIX= yes
+USE_XORG= x11
ONLY_FOR_ARCHS= i386
X11_PATCHFILES= Makefile.in help.c xmain.c
LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
diff --git a/comms/linrad/distinfo b/comms/linrad/distinfo
index c6e0c4349303..e63af2b7491d 100644
--- a/comms/linrad/distinfo
+++ b/comms/linrad/distinfo
@@ -1,3 +1,3 @@
-MD5 (linrad/lir02-28.tbz) = 671c3e9072f70a1b6ca942de55259bde
-SHA256 (linrad/lir02-28.tbz) = 904928349136586c4dad22e5242be104e57b1e8c98b21aac0faf3e9ab1823498
-SIZE (linrad/lir02-28.tbz) = 471279
+MD5 (linrad/lir02-34.tbz) = ebaeddd5455daa1dc23ef41ad33866b1
+SHA256 (linrad/lir02-34.tbz) = def769123a6d41c472127eedf59146411ec83ea594ce8c73f0223814b425b7c8
+SIZE (linrad/lir02-34.tbz) = 472578
diff --git a/comms/linrad/files/patch-Makefile.in b/comms/linrad/files/patch-Makefile.in
index 2966bcf7c6e2..cfeeb4ee2058 100644
--- a/comms/linrad/files/patch-Makefile.in
+++ b/comms/linrad/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Tue Apr 10 14:08:58 2007
-+++ Makefile.in Sat Apr 21 23:23:50 2007
+--- Makefile.in.orig Wed May 9 15:23:18 2007
++++ Makefile.in Fri Jun 29 17:53:19 2007
@@ -4,7 +4,7 @@
# Name the output files *.ol instead of *.o
# so we definitely know it is for Linux.
@@ -9,7 +9,7 @@
WCC = /usr/bin/i586-mingw32msvc-gcc
WINWCC = C:\mingw\bin\mingw32-gcc
NASM = nasm
-@@ -14,13 +14,10 @@
+@@ -14,10 +14,7 @@
# so we definitely know it is for Windows.
# (*.o files can be present by mistake)
# Always use the same flags.
@@ -20,17 +20,13 @@
+CFL = ${CFLAGS} -DOSNUM=1 -I${X11BASE}/include -c -o
CFW = -g -O -DOSNUM=2 -W -Wimplicit -Wreturn-type -Wformat \
-Wunused -Wcomment -Wchar-subscripts -Wshadow -Wuninitialized \
---Wparentheses -Wstrict-prototypes -Werror -ffast-math \
-+-Wparentheses -Wstrict-prototypes -ffast-math \
- -fomit-frame-pointer -c -o
- # Define dependencies for routines used both in Linux and Windows
-
+ -Wparentheses -Wstrict-prototypes -Werror -ffast-math \
@@ -624,7 +621,7 @@
meter_graph.ol fonts.ol screensub.ol lxsys.ol
-- gcc -olinrad -lvgagl -lvga -lpthread -lm \
-+ $(CC) -olinrad -lvgagl -lvga -pthread -lm \
+- gcc @MEM@ -olinrad -lvgagl -lvga -lpthread -lm \
++ ${CC} @MEM@ -olinrad -lvgagl -lvga -pthread -lm \
-Wl,-Map,linrad.lmap,-warn-common \
lmain.ol lvar.ol ui.ol lsetad.ol fft1.ol buf.ol \
mouse.ol wide_graph.ol getiq.ol fft0.ol adtest.ol hires_graph.ol \
@@ -38,8 +34,8 @@
-- gcc -oxlinrad -L/usr/X11R6/lib -lX11 -lpthread -lm \
-+ $(CC) -oxlinrad -L/usr/X11R6/lib -lX11 -pthread -lm \
+- gcc @MEM@ -oxlinrad -L/usr/X11R6/lib -lX11 -lpthread -lm \
++ gcc @MEM@ -oxlinrad -L/usr/local/lib -lX11 -pthread -lm \
-Wl,-Map,linrad.xmap,-warn-common \
xmain.ol xvar.ol ui.ol lsetad.ol fft1.ol buf.ol lvar.ol \
mouse.ol wide_graph.ol getiq.ol fft0.ol adtest.ol hires_graph.ol \
diff --git a/comms/linrad/files/patch-help.c b/comms/linrad/files/patch-help.c
index 5a1b66159307..e6020c4e25aa 100644
--- a/comms/linrad/files/patch-help.c
+++ b/comms/linrad/files/patch-help.c
@@ -1,6 +1,6 @@
---- help.c.orig Wed Feb 14 04:37:46 2007
-+++ help.c Thu Feb 22 18:44:17 2007
-@@ -352,7 +352,7 @@
+--- help.c.orig Wed May 9 15:23:18 2007
++++ help.c Fri Jun 29 17:59:12 2007
+@@ -370,7 +370,7 @@
printf("\n%s",s);
DEB"\n%s",s);
}
@@ -9,7 +9,7 @@
line=3;
if(screen_mode)
{
-@@ -367,7 +367,7 @@
+@@ -385,7 +385,7 @@
{
int line;
if(msg_no < 0)return;