aboutsummaryrefslogtreecommitdiff
path: root/comms/minicom
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-04-15 11:37:46 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-04-15 11:37:46 +0000
commit09e3a2ce74bf48f0a5dc4873487da8e2ec649394 (patch)
treecd222d64873014e3c1ee0b9ab2ffaaf3df2f409d /comms/minicom
parent806cbf019448f665d092e2a6cb7c2133f13f37d3 (diff)
downloadports-09e3a2ce74bf48f0a5dc4873487da8e2ec649394.tar.gz
ports-09e3a2ce74bf48f0a5dc4873487da8e2ec649394.zip
comms/minicom: Clean up
- Use USES=localbase instead of setting LIBS and CPPFLAGS - Set LICENSE_FILE and do not install the license to the documentation directory. - Replace unnecessary "+=" used for CONFIGURE_ARGS with "=". - Remove no-op REINPLACE_CMD. - Use MKDIR instead of INSTALL. - Format the makefile with portfmt.
Notes
Notes: svn path=/head/; revision=531761
Diffstat (limited to 'comms/minicom')
-rw-r--r--comms/minicom/Makefile31
-rw-r--r--comms/minicom/pkg-plist1
2 files changed, 14 insertions, 18 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index e575c7e66fb4..7c27512b3a40 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= minicom
PORTVERSION= 2.7.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms
MASTER_SITES= https://fossies.org/linux/misc/
@@ -11,37 +11,34 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= MS-DOS Telix serial communication program "workalike"
LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= lrz:comms/lrzsz
-USES= iconv ncurses
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib ${ICONV_LIB} -lncurses
+USES= iconv localbase ncurses
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-dfl-baud=57600 \
- --sysconfdir=${PREFIX}/etc/minicom \
- --enable-lock-dir=/var/spool/lock \
- --enable-dfl-port=/dev/cuau0
-
-OPTIONS_DEFINE= DOCS NLS
-OPTIONS_SUB= yes
-NLS_USES= gettext
+CONFIGURE_ARGS= --enable-dfl-baud=57600 \
+ --enable-dfl-port=/dev/cuau0 \
+ --enable-lock-dir=/var/spool/lock \
+ --sysconfdir=${PREFIX}/etc/minicom
+LIBS+= ${ICONV_LIB} -lncurses
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
post-patch:
${REINPLACE_CMD} -e "s@/usr/local/bin/@${LOCALBASE}/bin/@; \
s@/sz@/lsz@;s@/sb@/lsb@;s@/sx@/lsx@;s@/rz@/lrz@; \
s@/rb@/lrb@;s@/rx@/lrx@" ${WRKSRC}/src/rwconf.c
- ${REINPLACE_CMD} -E -e "s@^(SUBDIRS = .*) intl@\1@" \
- ${WRKSRC}/Makefile.in
post-install:
- ${INSTALL} -d -m 0755 ${STAGEDIR}${PREFIX}/etc/minicom
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
post-install-DOCS-on:
- ${INSTALL} -d -m 0755 ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${STAGEDIR}${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${STAGEDIR}${DOCSDIR}/
(umask 022 && cd ${WRKSRC} && ${TAR} --exclude '*/Makefile*' \
--exclude '*.orig' -chf - extras doc | ${TAR} -xf - -C \
diff --git a/comms/minicom/pkg-plist b/comms/minicom/pkg-plist
index 877f25519f1d..fe6ec9070ea5 100644
--- a/comms/minicom/pkg-plist
+++ b/comms/minicom/pkg-plist
@@ -26,7 +26,6 @@ man/man1/xminicom.1.gz
%%NLS%%share/locale/vi/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/minicom.mo
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/doc/Announce-1.78
%%PORTDOCS%%%%DOCSDIR%%/doc/Announce-1.82