aboutsummaryrefslogtreecommitdiff
path: root/comms/nanovna-saver
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-01-01 23:14:43 +0000
committerDiane Bruce <db@FreeBSD.org>2020-01-01 23:14:43 +0000
commitc24e86c24c064b18aff0a1360efa76ce1b67710f (patch)
treefdcc43f9b837ba4f68ad7859e2f9bb7c4e177c19 /comms/nanovna-saver
parent5f582b73ab228c78efcb60ec79e46d7de3bdeea7 (diff)
downloadports-c24e86c24c064b18aff0a1360efa76ce1b67710f.tar.gz
ports-c24e86c24c064b18aff0a1360efa76ce1b67710f.zip
NanoVNASaver
A multiplatform tool to save Touchstone files from the NanoVNA, sweep frequency spans in segments to gain more than 101 data points, and generally display and analyze the resulting data.
Notes
Notes: svn path=/head/; revision=521787
Diffstat (limited to 'comms/nanovna-saver')
-rw-r--r--comms/nanovna-saver/Makefile28
-rw-r--r--comms/nanovna-saver/distinfo3
-rw-r--r--comms/nanovna-saver/files/patch-NanoVNASaver_NanoVNASaver.py15
-rw-r--r--comms/nanovna-saver/files/patch-setup.py36
-rw-r--r--comms/nanovna-saver/pkg-descr7
5 files changed, 89 insertions, 0 deletions
diff --git a/comms/nanovna-saver/Makefile b/comms/nanovna-saver/Makefile
new file mode 100644
index 000000000000..5233b774246f
--- /dev/null
+++ b/comms/nanovna-saver/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= nanovna-saver
+PORTVERSION= 0.2.1
+CATEGORIES= comms hamradio
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= Multiplatform tool to save Touchstone files from the NanoVNA
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.13.2:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}serial>0:comms/py-serial@${PY_FLAVOR}
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USES= python:3.3+ pyqt:5 qt:5
+USE_PYTHON= distutils autoplist
+USE_PYQT= core_run gui_run widgets_run
+QT5_USE= core gui widgets
+
+NO_ARCH= yes
+USE_GITHUB= yes
+GH_ACCOUNT= mihtjel
+GH_TAGNAME= 47e95d1
+
+.include <bsd.port.mk>
diff --git a/comms/nanovna-saver/distinfo b/comms/nanovna-saver/distinfo
new file mode 100644
index 000000000000..25d0d42e4ad1
--- /dev/null
+++ b/comms/nanovna-saver/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577802970
+SHA256 (mihtjel-nanovna-saver-0.2.1-47e95d1_GH0.tar.gz) = bf2a9ebd1d78e940b49ecf3590291fb948ecaaffa173b51c799a420db39383b9
+SIZE (mihtjel-nanovna-saver-0.2.1-47e95d1_GH0.tar.gz) = 172939
diff --git a/comms/nanovna-saver/files/patch-NanoVNASaver_NanoVNASaver.py b/comms/nanovna-saver/files/patch-NanoVNASaver_NanoVNASaver.py
new file mode 100644
index 000000000000..14e95aaae3d6
--- /dev/null
+++ b/comms/nanovna-saver/files/patch-NanoVNASaver_NanoVNASaver.py
@@ -0,0 +1,15 @@
+--- NanoVNASaver/NanoVNASaver.py.orig 2019-12-04 11:05:36 UTC
++++ NanoVNASaver/NanoVNASaver.py
+@@ -540,11 +540,7 @@ class NanoVNASaver(QtWidgets.QWidget):
+ return_ports = []
+ device_list = list_ports.comports()
+ for d in device_list:
+- if (d.vid == VID and
+- d.pid == PID):
+- port = d.device
+- logger.info("Found NanoVNA (%04x %04x) on port %s", d.vid, d.pid, d.device)
+- return_ports.append(port)
++ return_ports.append(d.device)
+ return return_ports
+
+ def exportFileS1P(self):
diff --git a/comms/nanovna-saver/files/patch-setup.py b/comms/nanovna-saver/files/patch-setup.py
new file mode 100644
index 000000000000..04306045bbad
--- /dev/null
+++ b/comms/nanovna-saver/files/patch-setup.py
@@ -0,0 +1,36 @@
+--- setup.py.orig 2019-12-04 11:05:36 UTC
++++ setup.py
+@@ -15,10 +15,11 @@
+ # along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+ import sys
++import io
+ from NanoVNASaver.about import version
+
+-if sys.version_info < (3, 7):
+- print("You need at least Python 3.7 for this application!")
++if sys.version_info < (3, 3):
++ print("You need at least Python 3.3 for this application!")
+ if sys.version_info[0] < 3:
+ print("try running with python3 {}".format(" ".join(sys.argv)))
+ sys.exit(1)
+@@ -30,7 +31,7 @@ except ImportError:
+ print("Try installing them with pip install setuptools")
+ sys.exit(1)
+
+-with open("README.md", "r") as fh:
++with io.open("README.md", "r", encoding="utf-8") as fh:
+ long_description = fh.read()
+
+ setup(
+@@ -48,10 +49,4 @@ setup(
+ 'NanoVNASaver = NanoVNASaver.__main__:main'
+ ],
+ },
+- install_requires=[
+- 'pyserial',
+- 'PyQt5',
+- 'numpy',
+- 'scipy'
+- ],
+ )
diff --git a/comms/nanovna-saver/pkg-descr b/comms/nanovna-saver/pkg-descr
new file mode 100644
index 000000000000..bca547b9d86f
--- /dev/null
+++ b/comms/nanovna-saver/pkg-descr
@@ -0,0 +1,7 @@
+NanoVNASaver
+
+A multiplatform tool to save Touchstone files from the NanoVNA, sweep
+frequency spans in segments to gain more than 101 data points, and
+generally display and analyze the resulting data.
+
+WWW: https://github.com/mihtjel/nanovna-saver