aboutsummaryrefslogtreecommitdiff
path: root/comms/nmealib
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-16 15:19:52 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2015-07-16 15:19:52 +0000
commit438ff7358d29853ed022ed1911826fba6824cee3 (patch)
tree82130d1e85c293298e1fa84ccec8e48cce4e98f9 /comms/nmealib
parentd2ac5a2231bbc0eafaf5bf136bcaa4daf0e22c1a (diff)
downloadports-438ff7358d29853ed022ed1911826fba6824cee3.tar.gz
ports-438ff7358d29853ed022ed1911826fba6824cee3.zip
Open source library for working with the National Marine Electronics
Association (NMEA) protocol. Features: * Analysis NMEA sentences and granting GPS data in C structures * Generate NMEA sentences * Supported sentences: GPGGA, GPGSA, GPGSV, GPRMC, GPVTG * Multilevel architecture of algorithms * Additional functions of geographical mathematics and work with navigation data WWW: http://nmea.sourceforge.net/
Notes
Notes: svn path=/head/; revision=392297
Diffstat (limited to 'comms/nmealib')
-rw-r--r--comms/nmealib/Makefile28
-rw-r--r--comms/nmealib/distinfo2
-rw-r--r--comms/nmealib/files/patch-Makefile8
-rw-r--r--comms/nmealib/pkg-descr13
-rw-r--r--comms/nmealib/pkg-plist15
5 files changed, 66 insertions, 0 deletions
diff --git a/comms/nmealib/Makefile b/comms/nmealib/Makefile
new file mode 100644
index 000000000000..4f879975ea14
--- /dev/null
+++ b/comms/nmealib/Makefile
@@ -0,0 +1,28 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= nmealib
+PORTVERSION= 0.5.3
+CATEGORIES= comms
+MASTER_SITES= SF/nmea/NmeaLib/nmea-0.5.x
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Library for working with the NMEA protocol
+
+LICENSE= LGPL21
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USES= gmake zip
+
+INCLUDES= config.h context.h generate.h generator.h gmath.h info.h nmea.h \
+ parse.h parser.h sentence.h time.h tok.h units.h
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/libnmea.a ${STAGEDIR}${PREFIX}/lib
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/nmea
+.for i in ${INCLUDES}
+ ${INSTALL_DATA} ${WRKSRC}/include/nmea/${i} ${STAGEDIR}${PREFIX}/include/nmea
+.endfor
+
+.include <bsd.port.mk>
diff --git a/comms/nmealib/distinfo b/comms/nmealib/distinfo
new file mode 100644
index 000000000000..65cd1253c8bf
--- /dev/null
+++ b/comms/nmealib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (nmealib-0.5.3.zip) = 41e9fbb8fd5cb1836ff727355b3debe98662b39beb7493af9b78bc4bd4a2ad7d
+SIZE (nmealib-0.5.3.zip) = 54924
diff --git a/comms/nmealib/files/patch-Makefile b/comms/nmealib/files/patch-Makefile
new file mode 100644
index 000000000000..efee28ec6ee6
--- /dev/null
+++ b/comms/nmealib/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig 2015-07-16 13:27:40 UTC
++++ Makefile
+@@ -1,4 +1,4 @@
+-CC = gcc
++CC?= gcc
+
+ BIN = lib/libnmea.a
+ MODULES = generate generator parse parser tok context time info gmath sentence
diff --git a/comms/nmealib/pkg-descr b/comms/nmealib/pkg-descr
new file mode 100644
index 000000000000..d8dfac7465a5
--- /dev/null
+++ b/comms/nmealib/pkg-descr
@@ -0,0 +1,13 @@
+Open source library for working with the National Marine Electronics
+Association (NMEA) protocol.
+
+Features:
+
+ * Analysis NMEA sentences and granting GPS data in C structures
+ * Generate NMEA sentences
+ * Supported sentences: GPGGA, GPGSA, GPGSV, GPRMC, GPVTG
+ * Multilevel architecture of algorithms
+ * Additional functions of geographical mathematics and work with navigation
+ data
+
+WWW: http://nmea.sourceforge.net/
diff --git a/comms/nmealib/pkg-plist b/comms/nmealib/pkg-plist
new file mode 100644
index 000000000000..2b7fd21e2a4e
--- /dev/null
+++ b/comms/nmealib/pkg-plist
@@ -0,0 +1,15 @@
+@comment $FreeBSD$
+include/nmea/config.h
+include/nmea/context.h
+include/nmea/generate.h
+include/nmea/generator.h
+include/nmea/gmath.h
+include/nmea/info.h
+include/nmea/nmea.h
+include/nmea/parse.h
+include/nmea/parser.h
+include/nmea/sentence.h
+include/nmea/time.h
+include/nmea/tok.h
+include/nmea/units.h
+lib/libnmea.a