aboutsummaryrefslogtreecommitdiff
path: root/comms/opencbm-plugin-xa1541/Makefile
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-11-05 11:09:01 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-11-05 12:30:23 +0000
commit131067d9a214456d10e3267225812f0906ab1d4c (patch)
tree545a69983146f77514986621a1b0835ce3492d7c /comms/opencbm-plugin-xa1541/Makefile
parent71d020c9ce9aeb814a977f930d820766c63fab32 (diff)
downloadports-131067d9a214456d10e3267225812f0906ab1d4c.tar.gz
ports-131067d9a214456d10e3267225812f0906ab1d4c.zip
comms/opencbm-plugin-xa1541: Fix run depends
The XA1541 plugin must depend on the exact same version of opencbm base. * Make sure both ports use the same PORTREVISION by defining it in comms/opencbm/Makefile.inc and enforcing no explicit definition in the port Makefiles. * Use PKGVERSION instead of PORTVERSION to construct the dependency. Reported by: pkg-fallout
Diffstat (limited to 'comms/opencbm-plugin-xa1541/Makefile')
-rw-r--r--comms/opencbm-plugin-xa1541/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/comms/opencbm-plugin-xa1541/Makefile b/comms/opencbm-plugin-xa1541/Makefile
index 3d9e312c77af..fddd313b1467 100644
--- a/comms/opencbm-plugin-xa1541/Makefile
+++ b/comms/opencbm-plugin-xa1541/Makefile
@@ -9,8 +9,8 @@ WWW= http://opencbm.sourceforge.net/
LICENSE= GPLv2
BUILD_DEPENDS= cc65:devel/cc65
-RUN_DEPENDS= opencbm=${PORTVERSION}:comms/opencbm \
- opencbm-kmod=${PORTVERSION}:comms/opencbm-kmod
+RUN_DEPENDS= opencbm=${PKGVERSION}:comms/opencbm \
+ opencbm-kmod>0:comms/opencbm-kmod
USES= gmake pkgconfig
USE_LDCONFIG= yes