aboutsummaryrefslogtreecommitdiff
path: root/comms/opencbm
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-11-05 11:09:01 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-11-05 12:30:23 +0000
commit131067d9a214456d10e3267225812f0906ab1d4c (patch)
tree545a69983146f77514986621a1b0835ce3492d7c /comms/opencbm
parent71d020c9ce9aeb814a977f930d820766c63fab32 (diff)
downloadports-131067d9a214456d10e3267225812f0906ab1d4c.tar.gz
ports-131067d9a214456d10e3267225812f0906ab1d4c.zip
comms/opencbm-plugin-xa1541: Fix run depends
The XA1541 plugin must depend on the exact same version of opencbm base. * Make sure both ports use the same PORTREVISION by defining it in comms/opencbm/Makefile.inc and enforcing no explicit definition in the port Makefiles. * Use PKGVERSION instead of PORTVERSION to construct the dependency. Reported by: pkg-fallout
Diffstat (limited to 'comms/opencbm')
-rw-r--r--comms/opencbm/Makefile1
-rw-r--r--comms/opencbm/Makefile.inc9
2 files changed, 9 insertions, 1 deletions
diff --git a/comms/opencbm/Makefile b/comms/opencbm/Makefile
index 60a41c46b2fe..d01d86da4815 100644
--- a/comms/opencbm/Makefile
+++ b/comms/opencbm/Makefile
@@ -1,6 +1,5 @@
PORTNAME= opencbm
PORTVERSION= ${OCBM_VERSION}
-PORTREVISION= 1
CATEGORIES= comms archivers
MAINTAINER= zirias@FreeBSD.org
diff --git a/comms/opencbm/Makefile.inc b/comms/opencbm/Makefile.inc
index 14ead178951d..a4d863c37667 100644
--- a/comms/opencbm/Makefile.inc
+++ b/comms/opencbm/Makefile.inc
@@ -1,4 +1,5 @@
OCBM_VERSION= 0.4.99.104
+OCBM_REVISION= 1
DISTVERSIONPREFIX= v
DISTINFO_FILE= ${.CURDIR}/../opencbm/distinfo
@@ -17,3 +18,11 @@ PLIST_SUB= OCBM_VERSION=${OCBM_VERSION}
PORTSCOUT= limit:^v\d
PLUGINBASENAME= ${PREFIX}/lib/opencbm/plugin/libopencbm-
+
+.if ${PORTNAME:Nopencbm-kmod}
+. if defined(PORTREVISION)
+IGNORE= PORTREVISION must not be defined explicitly
+. else
+PORTREVISION= ${OCBM_REVISION}
+. endif
+.endif