aboutsummaryrefslogtreecommitdiff
path: root/comms/opencbm
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-06-06 14:20:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-06-06 14:20:30 +0000
commit82ae264e551b119bfbcb1884f6be7556e809c5d3 (patch)
treec85bb7ed5e7e93c35bb7bbc2527c235f3cb24310 /comms/opencbm
parent8f7411f4bd3ff6ace8c32500bb75cc702f90102c (diff)
downloadports-82ae264e551b119bfbcb1884f6be7556e809c5d3.tar.gz
ports-82ae264e551b119bfbcb1884f6be7556e809c5d3.zip
Commodore CBM serial IEC/IEEE-488 bus utilities
The OpenCBM package contains user space support programs and development libraries to control and use CBM serial IEC/IEEE-488 bus devices as used by most Commodore (CBM) 8-bit machines. OpenCBM allows for access to Commodore seriel IEC bus devices such as CBM 1540, 1541, 1570, 1571 and 1581 floppy disk drives. OpenCBM allows for access to Commodore (parallel) IEEE-488 bus devices such as CBM 2031, 2040, 3040, 4031, 4040, 8050, 8250, 8280 and SFD-1001 floppy disk drives. The devices are connected via a custom USB adapter (called xu1541 or xum1541). A fast .d64 disk copier/transfer program is included. WWW: http://opencbm.sourceforge.net/
Notes
Notes: svn path=/head/; revision=538093
Diffstat (limited to 'comms/opencbm')
-rw-r--r--comms/opencbm/Makefile74
-rw-r--r--comms/opencbm/Makefile.inc20
-rw-r--r--comms/opencbm/distinfo11
-rw-r--r--comms/opencbm/files/patch-fs.c11
-rw-r--r--comms/opencbm/pkg-descr17
-rw-r--r--comms/opencbm/pkg-plist101
6 files changed, 234 insertions, 0 deletions
diff --git a/comms/opencbm/Makefile b/comms/opencbm/Makefile
new file mode 100644
index 000000000000..d9f80ae9364c
--- /dev/null
+++ b/comms/opencbm/Makefile
@@ -0,0 +1,74 @@
+# Created by: Felix Palmen <felix@palmen-it.de>
+# $FreeBSD$
+
+PORTNAME= opencbm
+PORTVERSION= ${OCBM_VERSION}
+CATEGORIES= comms archivers
+
+PATCHFILES= 12ef17d4cf78903c9c52d7a348a816424d549b89.diff
+
+MAINTAINER= felix@palmen-it.de
+COMMENT= Commodore CBM serial IEC/IEEE-488 bus utilities
+
+LICENSE= GPLv2 BSD3CLAUSE
+LICENSE_COMB= multi
+
+BUILD_DEPENDS= cc65:devel/cc65
+
+USES= gmake
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DOCS INFO
+OPTIONS_DEFAULT= DOCS INFO
+
+MAKE_ARGS= CC=cc INFODIR=${PREFIX}/share/info
+MAKEFILE= LINUX/Makefile
+MAKE_JOBS_UNSAFE= yes
+ALL_TARGET= opencbm plugin-xu1541 plugin-xum1541
+INSTALL_TARGET= install install-plugin-xu1541 install-plugin-xum1541
+
+DOCS_BUILD_DEPENDS= dvips:print/tex-dvipsk \
+ latex:print/tex-formats \
+ linuxdoc:textproc/linuxdoc-tools
+DOCS_USES= ghostscript:build
+DOCS_ALL_TARGET= doc
+DOCS_MAKE_ARGS_OFF= TXT= DVI= PDF= HTML=
+
+INFO_BUILD_DEPENDS= linuxdoc:textproc/linuxdoc-tools
+INFO_USES= makeinfo
+INFO_ALL_TARGET= doc
+INFO_INFO= opencbm
+INFO_MAKE_ARGS_OFF= INFO=
+
+OCBM_CONFDIR= ${LOCALBASE}/etc/opencbm.conf.d
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|_ETC="$$1"|_ETC="$${1:-${LOCALBASE}/etc}"|' \
+ -e 's|in /.*/ instead|in ${OCBM_CONFDIR}/ instead|' \
+ -e "s|execute 'opencbm_|execute '|" \
+ ${WRKSRC}/opencbm/LINUX/plugin_helper_tools
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopencbm.so.${OCBM_LIBVERSION}
+.for p in xu1541 xum1541
+ ${STRIP_CMD} ${STAGEDIR}${PLUGINBASENAME}${p}.so.${OCBM_LIBVERSION}
+.endfor
+ @${RM} ${STAGEDIR}${PREFIX}/etc/opencbm.conf
+ @${MV} ${STAGEDIR}${PREFIX}/etc/opencbm.conf.d/00opencbm.conf \
+ ${STAGEDIR}${PREFIX}/etc/opencbm.conf.d/00opencbm.conf.sample
+ @${MV} ${STAGEDIR}${PREFIX}/bin/opencbm_plugin_helper_tools \
+ ${STAGEDIR}${PREFIX}/sbin/opencbm_plugin_helper_tools
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/opencbm/docs && \
+ ${COPYTREE_SHARE} "html misc opencbm.pdf opencbm.txt" \
+ ${STAGEDIR}${DOCSDIR})
+
+post-install-INFO-on:
+ ${INSTALL_MAN} ${WRKSRC}/opencbm/docs/opencbm.info \
+ ${STAGEDIR}${PREFIX}/${INFO_PATH}
+
+.include "Makefile.inc"
+
+.include <bsd.port.mk>
diff --git a/comms/opencbm/Makefile.inc b/comms/opencbm/Makefile.inc
new file mode 100644
index 000000000000..d49ad3c7e461
--- /dev/null
+++ b/comms/opencbm/Makefile.inc
@@ -0,0 +1,20 @@
+# Created by: Felix Palmen <felix@palmen-it.de>
+# $FreeBSD$
+
+OCBM_VERSION= 0.4.99.99a
+DISTVERSIONPREFIX= v
+DIST_SUBDIR= opencbm
+DISTINFO_FILE= ${.CURDIR}/../opencbm/distinfo
+
+PATCH_DIST_STRIP= -p1
+PATCH_SITES= https://github.com/OpenCBM/OpenCBM/commit/
+
+USE_GITHUB= yes
+GH_ACCOUNT= OpenCBM
+GH_PROJECT= OpenCBM
+
+PATCHDIR= ${.CURDIR}/../opencbm/files
+PATCH_WRKSRC= ${WRKDIR}/OpenCBM-${OCBM_VERSION}
+
+OCBM_LIBVERSION= 0.4.99.99
+PLUGINBASENAME= ${PREFIX}/lib/opencbm/plugin/libopencbm-
diff --git a/comms/opencbm/distinfo b/comms/opencbm/distinfo
new file mode 100644
index 000000000000..64672974ab6e
--- /dev/null
+++ b/comms/opencbm/distinfo
@@ -0,0 +1,11 @@
+TIMESTAMP = 1590503036
+SHA256 (opencbm/OpenCBM-OpenCBM-v0.4.99.99a_GH0.tar.gz) = 0ae35e9011231eef1c4b6800bba16ced82690e80a91d67853888d49c63b874a0
+SIZE (opencbm/OpenCBM-OpenCBM-v0.4.99.99a_GH0.tar.gz) = 8661428
+SHA256 (opencbm/ca4c06e7430caf3b2296d4e1e00051fff015fc53.diff) = 3babd55eaa0378c688a422b1176325874a46fa4014e9420e672418998c592c27
+SIZE (opencbm/ca4c06e7430caf3b2296d4e1e00051fff015fc53.diff) = 8726
+SHA256 (opencbm/12ef17d4cf78903c9c52d7a348a816424d549b89.diff) = 2bea76abc6e3f19d93776c39a921c6e17d892613ae6e4740eda5f555483bb095
+SIZE (opencbm/12ef17d4cf78903c9c52d7a348a816424d549b89.diff) = 561
+SHA256 (opencbm/073b833772e4325c7f680d6aeb81bc11844f03ca.diff) = e4c5858162d000e099140d78590effc8b5dccbf1f80c9dcdfffc4420ad9b6c03
+SIZE (opencbm/073b833772e4325c7f680d6aeb81bc11844f03ca.diff) = 27055
+SHA256 (opencbm/3e967551e200d0c03aa4898e482626a7510acd21.diff) = d1d73fa395e16956dce1e971750ecefbb2b80b6be1c1ec95392fc9be4d2d4676
+SIZE (opencbm/3e967551e200d0c03aa4898e482626a7510acd21.diff) = 825
diff --git a/comms/opencbm/files/patch-fs.c b/comms/opencbm/files/patch-fs.c
new file mode 100644
index 000000000000..9c196c19e6a0
--- /dev/null
+++ b/comms/opencbm/files/patch-fs.c
@@ -0,0 +1,11 @@
+--- opencbm/libimgcopy/fs.c.orig 2017-09-06 16:59:00 UTC
++++ opencbm/libimgcopy/fs.c
+@@ -121,7 +121,7 @@ static int open_disk(CBM_FILE fd, imgcopy_settings *se
+ }
+ else
+ {
+- printf("filesize=%d, blockcount=%d, calc1=%d, calc2=%d\n", filesize, block_count, block_count * (BLOCKSIZE), block_count * (BLOCKSIZE + 1));
++ printf("filesize=%ld, blockcount=%d, calc1=%d, calc2=%d\n", (long)filesize, block_count, block_count * (BLOCKSIZE), block_count * (BLOCKSIZE + 1));
+ /* D64 sonderformate
+
+ for( tr = D82_TRACKS; !is_image && tr <= D82_TRACKS; )
diff --git a/comms/opencbm/pkg-descr b/comms/opencbm/pkg-descr
new file mode 100644
index 000000000000..1d157fa65ac4
--- /dev/null
+++ b/comms/opencbm/pkg-descr
@@ -0,0 +1,17 @@
+Commodore CBM serial IEC/IEEE-488 bus utilities
+
+The OpenCBM package contains user space support programs and development
+libraries to control and use CBM serial IEC/IEEE-488 bus devices as used by
+most Commodore (CBM) 8-bit machines.
+
+OpenCBM allows for access to Commodore seriel IEC bus devices such as CBM
+1540, 1541, 1570, 1571 and 1581 floppy disk drives.
+
+OpenCBM allows for access to Commodore (parallel) IEEE-488 bus devices such as
+CBM 2031, 2040, 3040, 4031, 4040, 8050, 8250, 8280 and SFD-1001 floppy disk
+drives.
+
+The devices are connected via a custom USB adapter (called xu1541 or xum1541).
+A fast .d64 disk copier/transfer program is included.
+
+WWW: http://opencbm.sourceforge.net/
diff --git a/comms/opencbm/pkg-plist b/comms/opencbm/pkg-plist
new file mode 100644
index 000000000000..d024fa120db3
--- /dev/null
+++ b/comms/opencbm/pkg-plist
@@ -0,0 +1,101 @@
+bin/cbmcopy
+bin/cbmctrl
+bin/cbmformat
+bin/cbmforng
+bin/cbmlinetester
+bin/cbmread
+bin/cbmrpm41
+bin/cbmwrite
+bin/d64copy
+bin/d82copy
+bin/frm_analyzer
+bin/imgcopy
+bin/samplelibtransf
+bin/xum1541cfg
+@sample etc/opencbm.conf.d/00opencbm.conf.sample
+etc/opencbm.conf.d/10xu1541.conf
+etc/opencbm.conf.d/10xum1541.conf
+include/cbmcopy.h
+include/d64copy.h
+include/opencbm.h
+lib/libopencbm.a
+lib/libopencbm.so
+lib/libopencbm.so.0
+lib/libopencbm.so.0.4.99.99
+lib/opencbm/plugin/libopencbm-xu1541.a
+lib/opencbm/plugin/libopencbm-xu1541.so
+lib/opencbm/plugin/libopencbm-xu1541.so.0
+lib/opencbm/plugin/libopencbm-xu1541.so.0.4.99.99
+lib/opencbm/plugin/xu1541/read_event_log
+lib/opencbm/plugin/xu1541/usb_echo_test
+lib/opencbm/plugin/libopencbm-xum1541.a
+lib/opencbm/plugin/libopencbm-xum1541.so
+lib/opencbm/plugin/libopencbm-xum1541.so.0
+lib/opencbm/plugin/libopencbm-xum1541.so.0.4.99.99
+man/man1/cbmcopy.1.gz
+man/man1/cbmctrl.1.gz
+man/man1/cbmformat.1.gz
+man/man1/cbmforng.1.gz
+man/man1/cbmlinetester.1.gz
+man/man1/cbmread.1.gz
+man/man1/cbmrpm41.1.gz
+man/man1/cbmwrite.1.gz
+man/man1/d64copy.1.gz
+man/man1/d82copy.1.gz
+man/man1/frm_analyzer.1.gz
+man/man1/imgcopy.1.gz
+man/man1/samplelibtransf.1.gz
+man/man1/xum1541cfg.1.gz
+sbin/opencbm_plugin_helper_tools
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-1.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-10.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-11.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-12.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-13.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-14.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-15.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-16.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-17.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-18.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-19.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-20.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-21.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-22.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-23.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-24.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-25.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-26.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-27.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-28.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-29.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-30.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-31.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-32.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-33.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-34.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-35.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-36.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-4.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-5.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-6.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-7.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-8.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-9.html
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-software-installed-uninstall.png
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm-software-installed.png
+%%PORTDOCS%%%%DOCSDIR%%/html/opencbm.html
+%%PORTDOCS%%%%DOCSDIR%%/html/zadig-listalldevices.png
+%%PORTDOCS%%%%DOCSDIR%%/html/zadig-success.png
+%%PORTDOCS%%%%DOCSDIR%%/html/zadig-uac.png
+%%PORTDOCS%%%%DOCSDIR%%/html/zadig-xu1541.png
+%%PORTDOCS%%%%DOCSDIR%%/html/zadig-xum1541.png
+%%PORTDOCS%%%%DOCSDIR%%/misc/README
+%%PORTDOCS%%%%DOCSDIR%%/misc/ibmlpt.txt
+%%PORTDOCS%%%%DOCSDIR%%/misc/serial-bus.txt
+%%PORTDOCS%%%%DOCSDIR%%/misc/serial.txt
+%%PORTDOCS%%%%DOCSDIR%%/opencbm.pdf
+%%PORTDOCS%%%%DOCSDIR%%/opencbm.txt
+@postexec opencbm_plugin_helper_tools rebuild
+@preunexec rm -f %%LOCALBASE%%/etc/opencbm.conf