aboutsummaryrefslogtreecommitdiff
path: root/comms/openobex
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-08-30 17:12:30 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-08-30 17:12:30 +0000
commitdda08cefbba320a5d0ee8097804e8b471843a700 (patch)
tree147283a1df88ed04c1e89fc2b6c862f3a3fee0af /comms/openobex
parent8a38fa52195516d0c6b336fca297c09dc47fe006 (diff)
downloadports-dda08cefbba320a5d0ee8097804e8b471843a700.tar.gz
ports-dda08cefbba320a5d0ee8097804e8b471843a700.zip
Notes
Diffstat (limited to 'comms/openobex')
-rw-r--r--comms/openobex/Makefile8
-rw-r--r--comms/openobex/distinfo4
-rw-r--r--comms/openobex/files/patch-bt12
-rw-r--r--comms/openobex/files/patch-usb65
-rw-r--r--comms/openobex/pkg-descr2
-rw-r--r--comms/openobex/pkg-plist2
6 files changed, 8 insertions, 85 deletions
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index 9ae766070d24..87b2c8cd5320 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= openobex
-PORTVERSION= 1.4
+PORTVERSION= 1.6
CATEGORIES= comms net
-MASTER_SITES= ${MASTER_SITE_KERNEL_ORG}
-MASTER_SITE_SUBDIR= linux/bluetooth
+MASTER_SITES= http://www.hendrik-sattler.de/downloads/${PORTNAME}/${PORTVERSION}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Open source implementation of the OBEX protocol
@@ -28,7 +28,7 @@ USB_DESC= Enable OBEX over USB
.if ${PORT_OPTIONS:MUSB}
. if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
CFLAGS+= -I${PREFIX}/include
. else
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
diff --git a/comms/openobex/distinfo b/comms/openobex/distinfo
index 4d482cf9124c..66e04423c269 100644
--- a/comms/openobex/distinfo
+++ b/comms/openobex/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openobex-1.4.tar.gz) = 79265309e2320beb03910fccf27fd04aefb18ba47a900947d2de8e88fae05cd8
-SIZE (openobex-1.4.tar.gz) = 393756
+SHA256 (openobex-1.6-Source.tar.gz) = 3dde9deaba9881c45da3dfea69765fdfaec9e1e0e2114bf0add997a688c615f8
+SIZE (openobex-1.6-Source.tar.gz) = 712415
diff --git a/comms/openobex/files/patch-bt b/comms/openobex/files/patch-bt
deleted file mode 100644
index d8e2749b3a5f..000000000000
--- a/comms/openobex/files/patch-bt
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur lib/bluez_compat.h work.2/openobex-1.4/lib/bluez_compat.h
---- lib/bluez_compat.h 2008-11-07 14:36:09.000000000 +0200
-+++ lib/bluez_compat.h 2008-11-19 02:34:53.000000000 +0200
-@@ -53,6 +53,8 @@
- #define rc_family rfcomm_family
- #define rc_bdaddr rfcomm_bdaddr
- #define rc_channel rfcomm_channel
-+#define BDADDR_ANY NG_HCI_BDADDR_ANY
-+#define BTPROTO_RFCOMM BLUETOOTH_PROTO_RFCOMM
-
- #elif defined(HAVE_BLUETOOTH_NETBSD)
- #include <bluetooth.h>
diff --git a/comms/openobex/files/patch-usb b/comms/openobex/files/patch-usb
deleted file mode 100644
index 3b592f3e8427..000000000000
--- a/comms/openobex/files/patch-usb
+++ /dev/null
@@ -1,65 +0,0 @@
---- lib/usbobex.c 2008-11-07 14:36:09.000000000 +0200
-+++ lib/usbobex.c 2008-11-19 02:47:39.000000000 +0200
-@@ -392,25 +392,8 @@
-
- DEBUG(4, "\n");
-
-- self->trans.self.usb.dev_control = usb_open(self->trans.self.usb.device);
- self->trans.self.usb.dev_data = usb_open(self->trans.self.usb.device);
-
-- ret = usb_set_configuration(self->trans.self.usb.dev_control, self->trans.self.usb.configuration);
-- if (ret < 0)
-- DEBUG(4, "Can't set configuration %d", ret);
--
-- ret = usb_claim_interface(self->trans.self.usb.dev_control, self->trans.self.usb.control_interface);
-- if (ret < 0) {
-- DEBUG(4, "Can't claim control interface %d", ret);
-- goto err1;
-- }
--
-- ret = usb_set_altinterface(self->trans.self.usb.dev_control, self->trans.self.usb.control_setting);
-- if (ret < 0) {
-- DEBUG(4, "Can't set control setting %d", ret);
-- goto err2;
-- }
--
- ret = usb_claim_interface(self->trans.self.usb.dev_data, self->trans.self.usb.data_interface);
- if (ret < 0) {
- DEBUG(4, "Can't claim data interface %d", ret);
-@@ -430,10 +413,8 @@
- err3:
- usb_release_interface(self->trans.self.usb.dev_data, self->trans.self.usb.data_interface);
- err2:
-- usb_release_interface(self->trans.self.usb.dev_control, self->trans.self.usb.control_interface);
- err1:
- usb_close(self->trans.self.usb.dev_data);
-- usb_close(self->trans.self.usb.dev_control);
- return ret;
- }
-
-@@ -450,21 +431,19 @@
- return 0;
-
- DEBUG(4, "\n");
-+
-+ usb_clear_halt(self->trans.self.usb.dev_data, self->trans.self.usb.data_endpoint_read);
-+ usb_clear_halt(self->trans.self.usb.dev_data, self->trans.self.usb.data_endpoint_write);
-+
- ret = usb_set_altinterface(self->trans.self.usb.dev_data, self->trans.self.usb.data_idle_setting);
- if (ret < 0)
- DEBUG(4, "Can't set data idle setting %d", ret);
- ret = usb_release_interface(self->trans.self.usb.dev_data, self->trans.self.usb.data_interface);
- if (ret < 0)
- DEBUG(4, "Can't release data interface %d", ret);
-- ret = usb_release_interface(self->trans.self.usb.dev_control, self->trans.self.usb.control_interface);
-- if (ret < 0)
-- DEBUG(4, "Can't release control interface %d", ret);
- ret = usb_close(self->trans.self.usb.dev_data);
- if (ret < 0)
- DEBUG(4, "Can't close data interface %d", ret);
-- ret = usb_close(self->trans.self.usb.dev_control);
-- if (ret < 0)
-- DEBUG(4, "Can't close control interface %d", ret);
-
- return ret;
- }
diff --git a/comms/openobex/pkg-descr b/comms/openobex/pkg-descr
index a2d2fd217ef8..7ba85fbad7c8 100644
--- a/comms/openobex/pkg-descr
+++ b/comms/openobex/pkg-descr
@@ -3,4 +3,4 @@ implementation of the Object Exchange (OBEX) protocol. OBEX is a
session protocol and can best be described as a binary HTTP protocol.
It's used mainly for Infrared and Bluetooth communication.
-WWW: http://www.bluez.org/openobex/
+WWW: http://gitorious.org/openobex/pages/Home
diff --git a/comms/openobex/pkg-plist b/comms/openobex/pkg-plist
index 7d0a601c4332..fb996a295712 100644
--- a/comms/openobex/pkg-plist
+++ b/comms/openobex/pkg-plist
@@ -1,6 +1,6 @@
include/openobex/obex.h
include/openobex/obex_const.h
-lib/libopenobex.so.5
+lib/libopenobex.so.2
lib/libopenobex.a
lib/libopenobex.la
lib/libopenobex.so