aboutsummaryrefslogtreecommitdiff
path: root/comms/openzwave-devel
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-17 10:47:15 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-04-17 10:47:15 +0000
commitc5defae963ae6671087580a5ccd7250076bdbe24 (patch)
tree7e145b30a34b9a35535d48542ea1211cf3c0e3a4 /comms/openzwave-devel
parentc56adaadab03ec9aa085499ee719bb34adce2875 (diff)
downloadports-c5defae963ae6671087580a5ccd7250076bdbe24.tar.gz
ports-c5defae963ae6671087580a5ccd7250076bdbe24.zip
comms/openzwave-devel: fix build on GCC architectures
Use C++11 compiler: cc1plus: error: unrecognized command line option "-std=c++11" Adding MAKE_ARGS+= CXX="${CXX}" is necessary because CXX is set up in Makefile. MFH: 2020Q2 (fix build blanket)
Notes
Notes: svn path=/head/; revision=531918
Diffstat (limited to 'comms/openzwave-devel')
-rw-r--r--comms/openzwave-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/comms/openzwave-devel/Makefile b/comms/openzwave-devel/Makefile
index 8f5d8f3a2979..70898331f612 100644
--- a/comms/openzwave-devel/Makefile
+++ b/comms/openzwave-devel/Makefile
@@ -11,7 +11,7 @@ COMMENT= Open-zwave - An open-source interface to Z-Wave networks
LICENSE= LGPL20
-USES= gmake tar:bz2 iconv pkgconfig
+USES= compiler:c++11-lang gmake tar:bz2 iconv pkgconfig
# Manually update this when makefile is updated
# echo $(git describe --long --tags --dirty 2>/dev/null | sed s/^v//) | awk '{split($$0,a,"-"); print a[2]}'
@@ -22,7 +22,7 @@ USE_GITHUB= yes
GH_ACCOUNT= OpenZWave
GH_PROJECT= open-zwave
GH_TAGNAME= 14f2ba74
-MAKE_ARGS= VERSION_REV=${VERSION_REV} LIBDIR=${WRKSRC} docdir=${DOCSDIR}
+MAKE_ARGS= VERSION_REV=${VERSION_REV} LIBDIR=${WRKSRC} docdir=${DOCSDIR} CXX=${CXX}
OPTIONS_DEFINE= DOXYGEN DOCS
OPTIONS_DEFAULT=