aboutsummaryrefslogtreecommitdiff
path: root/comms/owfs
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-16 09:15:17 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-16 09:15:17 +0000
commit22f2f2c7951b31d3f9a010e42dddf3e9e03bc813 (patch)
tree08aa705619e0af1707843ba9c6e1e39b793b28f7 /comms/owfs
parent27037736c6a4226b756ecfdf3b84cd29ddc2e453 (diff)
downloadports-22f2f2c7951b31d3f9a010e42dddf3e9e03bc813.tar.gz
ports-22f2f2c7951b31d3f9a010e42dddf3e9e03bc813.zip
Add new port comms/owfs
PR: 189222 Submitted by: Johan (stromnet.se) OWFS -- 1-Wire file system. OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim. OWFS is a simple and flexible program to monitor and control the physical environment. You can write scripts to read temperature, flash lights, write to an LCD, log and graph, ...
Notes
Notes: svn path=/head/; revision=365069
Diffstat (limited to 'comms/owfs')
-rw-r--r--comms/owfs/Makefile144
-rw-r--r--comms/owfs/Makefile.options62
-rw-r--r--comms/owfs/distinfo2
-rw-r--r--comms/owfs/pkg-descr8
-rw-r--r--comms/owfs/pkg-plist169
5 files changed, 385 insertions, 0 deletions
diff --git a/comms/owfs/Makefile b/comms/owfs/Makefile
new file mode 100644
index 000000000000..d883f3745ced
--- /dev/null
+++ b/comms/owfs/Makefile
@@ -0,0 +1,144 @@
+# Created by: Johan Strom <johna@stromnet.se>
+# $FreeBSD$
+
+PORTNAME= owfs
+PORTVERSION= 2.9p5
+CATEGORIES= comms
+MASTER_SITES= SF/owfs/owfs/${PORTVERSION}
+
+MAINTAINER= johan@stromnet.se
+COMMENT= OWFS -- 1-Wire file system
+
+LICENSE= GPLv2
+
+USES= libtool
+LIBTOOLIZE_ARGS=-c -f -i
+ACLOCAL_ARGS= -I${LOCALBASE}/share/aclocal
+
+USE_AUTOTOOLS= libtoolize aclocal autoheader autoconf automake
+AUTOMAKE_ARGS= --add-missing
+GNU_CONFIGURE= On
+INSTALL_TARGET= install-strip
+
+.include "Makefile.options"
+
+OPTIONS_SUB=yes
+
+CONFIGURE_ARGS= --enable-owlib
+
+# Linux specific kernel driver
+CONFIGURE_ARGS+= --disable-w1
+CONFIGURE_ARGS+= --disable-parport
+
+OWDEBUG_CONFIGURE_ENABLE= debug
+OWSHELL_CONFIGURE_ENABLE= owshell
+OWNET_CONFIGURE_ENABLE= ownet
+
+I2C_CONFIGURE_ENABLE= i2c
+OWHTTPD_CONFIGURE_ENABLE= owhttpd
+OWFTPD_CONFIGURE_ENABLE= owftpd
+OWSERVER_CONFIGURE_ENABLE= owserver
+
+OWTAP_CONFIGURE_ENABLE= owtap
+OWTAP_USE= tk=yes tk_wrapper=yes
+
+OWMALLOC_CONFIGURE_ENABLE= owmalloc
+OWTRAFFIC_CONFIGURE_ENABLE= owtraffic
+
+OWMON_CONFIGURE_ENABLE= owmon
+OWMON_USE= tk=yes tk_wrapper=yes
+
+OWCAPI_CONFIGURE_ENABLE= owcapi
+
+OWPERL_CONFIGURE_ENABLE= owperl
+OWPERL_USES= perl5
+OWPERL_USE= perl5=build,run,fixpacklist
+
+# Broken/untested
+OWPHP_CONFIGURE_ENABLE= owphp
+
+OWPYTHON_CONFIGURE_ENABLE= owpython
+OWPYTHON_USES= python
+
+# Additional CONFIGURE_ARGS is done below
+OWTCL_CONFIGURE_ENABLE= owtcl
+OWTCL_USES= tcl
+
+# XXX Broken due to -lgcc_p
+PROFILING_CONFIGURE_ENABLE= profiling
+
+# XXX: Not tested, it compiles, but not sure if fusefs actually works
+OWFS_CONFIGURE_ENABLE= owfs
+OWFS_USES= fuse
+
+ZERO_CONFIGURE_ENABLE= zero
+USB_CONFIGURE_ENABLE= usb
+USB_LDFLAGS= -lusb
+
+.include <bsd.port.options.mk>
+
+# If OW Network and C API is requested, build libownet as well
+.if ${PORT_OPTIONS:MOWNET} && ${PORT_OPTIONS:MOWCAPI}
+CONFIGURE_ARGS+= --enable-ownetlib
+PLIST_SUB+= OWNETLIB=""
+.else
+CONFIGURE_ARGS+= --disable-ownetlib
+PLIST_SUB+= OWNETLIB="@comment "
+.endif
+
+# If OW Network and Perl is requested, we get ownet perl files
+.if ${PORT_OPTIONS:MOWPERL} && ${PORT_OPTIONS:MOWNET}
+PLIST_SUB+= OWNETPERL=""
+.else
+PLIST_SUB+= OWNETPERL="@comment "
+.endif
+
+# If OW Network and Python is requested, we get ownet python files
+.if ${PORT_OPTIONS:MOWPYTHON} && ${PORT_OPTIONS:MOWNET}
+PLIST_SUB+= OWNETPYTHON=""
+.else
+PLIST_SUB+= OWNETPYTHON="@comment "
+.endif
+
+# If Perl, Python or PHP is requested, enable SWIG
+.if ${PORT_OPTIONS:MOWPERL} || ${PORT_OPTIONS:MOWPYTHON} || ${PORT_OPTIONS:MOWPHP}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/swig2.0:${PORTSDIR}/devel/swig20
+CONFIGURE_ARGS+= --enable-swig SWIG=${LOCALBASE}/bin/swig2.0
+.else
+CONFIGURE_ARGS+= --disable-swig
+.endif
+
+.if ${PORT_OPTIONS:MOWTCL}
+CONFIGURE_ARGS+= --enable-owtcl --with-tcl=${TCL_LIBDIR}
+.endif
+
+# These __version__ fixes should be unnecessary on next release
+post-patch:
+ @${REINPLACE_CMD} \
+ -e "s/^\(__version__ = '[[:digit:]]\.[[:digit:]]\).*/\1'/" \
+ ${WRKSRC}/module/swig/python/unittest/*.py \
+ ${WRKSRC}/module/ownet/python/ownet/__init__.py
+ @${REINPLACE_CMD} -e "s/\(__version__ =\).*/\1 '1.9'/" \
+ ${WRKSRC}/module/ownet/python/ownet/connection.py
+ @${REINPLACE_CMD} -e "s/\(__version__ = .*\) [+].*/\1/" \
+ ${WRKSRC}/module/swig/python/ow/__init__.py
+
+# This takes a few seconds so give the user some notice
+pre-configure:
+ ${MKDIR} ${WRKSRC}/m4
+ @echo "Preparing build using autotools..."
+
+# Workarounds for different problems
+post-install:
+.if ${PORT_OPTIONS:MOWPYTHON}
+ (cd ${STAGEDIR}${PREFIX} \
+ && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py \
+ -d ${PYTHONPREFIX_SITELIBDIR} -f ${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;})
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/python2.7/site-packages/ow/_OW.so
+.endif
+.if ${PORT_OPTIONS:MOWPERL}
+ @${RM} -f ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/perl5/site_perl/5.16/mach/auto/OW/OW.so
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/owfs/Makefile.options b/comms/owfs/Makefile.options
new file mode 100644
index 000000000000..0ef37c9ad286
--- /dev/null
+++ b/comms/owfs/Makefile.options
@@ -0,0 +1,62 @@
+# $FreeBSD$
+
+OPTIONS_DEFINE = OWDEBUG \
+ OWSHELL \
+ OWNET \
+ I2C \
+ OWHTTPD \
+ OWFTPD \
+ OWSERVER \
+ OWTAP \
+ OWMALLOC \
+ OWTRAFFIC \
+ OWMON \
+ OWCAPI \
+ OWPERL \
+ OWPHP \
+ OWPYTHON \
+ OWTCL \
+ PROFILING \
+ OWFS \
+ ZERO \
+ USB
+
+# Options disabled
+# PARPORT - linux/parport.h not available
+# W1 - no support on FreeBSD
+
+
+OWDEBUG_DESC= Enable debug output
+OWSHELL_DESC= Enable CLI utils
+OWNET_DESC= Enable network communication
+I2C_DESC= Enable i2c (DS2482-x00) support (UNTESTED)
+OWHTTPD_DESC= Enable owhttpd HTTP server
+OWFTPD_DESC= Enable owftpd FTP server
+OWSERVER_DESC= Enable owserver
+OWMALLOC_DESC= Enable malloc checking
+OWTRAFFIC_DESC= Enable debug bus traffic reports
+OWTAP_DESC= Enable owtap module (X11)
+OWMON_DESC= Enable owmon module (X11)
+OWCAPI_DESC= Enable C API
+OWPERL_DESC= Enable Perl binding
+OWPHP_DESC= Enable PHP binding (BROKEN)
+OWPYTHON_DESC= Enable Python binding
+OWTCL_DESC= Enable TCL binding
+PROFILING_DESC= Enable profiling (BROKEN)
+OWFS_DESC= Enable FUSE support (UNTESTED)
+ZERO_DESC= Enable Zeroconf/bonjour (UNTESTED)
+USB_DESC= Enable 1-Wire usb DS2490 support
+
+# Options disabled
+#PARPORT_DESC= Enable 1-Wire parallel port DS1410E support
+#W1_DESC=Enable w1 support
+
+OPTIONS_DEFAULT=OWDEBUG\
+ OWSHELL\
+ OWNET\
+ OWHTTPD\
+ OWFTPD\
+ OWSERVER\
+ OWCAPI\
+ USB
+
diff --git a/comms/owfs/distinfo b/comms/owfs/distinfo
new file mode 100644
index 000000000000..9e560fc662cd
--- /dev/null
+++ b/comms/owfs/distinfo
@@ -0,0 +1,2 @@
+SHA256 (owfs-2.9p5.tar.gz) = f7e11bae6cd29d58726e6d29b297834e5656d6069a407d798067ae25cb0812ea
+SIZE (owfs-2.9p5.tar.gz) = 1444365
diff --git a/comms/owfs/pkg-descr b/comms/owfs/pkg-descr
new file mode 100644
index 000000000000..cf8849b7170c
--- /dev/null
+++ b/comms/owfs/pkg-descr
@@ -0,0 +1,8 @@
+OWFS -- 1-Wire file system.
+OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim.
+
+OWFS is a simple and flexible program to monitor and control the physical
+environment. You can write scripts to read temperature, flash lights, write
+to an LCD, log and graph, ...
+
+WWW: http://www.owfs.org/
diff --git a/comms/owfs/pkg-plist b/comms/owfs/pkg-plist
new file mode 100644
index 000000000000..ee49983c1e71
--- /dev/null
+++ b/comms/owfs/pkg-plist
@@ -0,0 +1,169 @@
+%%OWCAPI%%include/owcapi.h
+%%OWCAPI%%lib/libowcapi-2.9.so.5
+%%OWCAPI%%lib/libowcapi-2.9.so.5.0.0
+%%OWCAPI%%lib/libowcapi.so
+%%OWFS%%bin/owfs
+%%OWFTPD%%bin/owftpd
+%%OWHTTPD%%bin/owhttpd
+%%OWMON%%bin/owmon
+%%OWNETLIB%%include/ownetapi.h
+%%OWNETLIB%%lib/libownet-2.9.so.5
+%%OWNETLIB%%lib/libownet-2.9.so.5.0.0
+%%OWNETLIB%%lib/libownet.so
+%%OWNETPERL%%%%PERL5_MAN3%%/OWNet.3.gz
+%%OWNETPERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/OWNet/.packlist
+%%OWNETPERL%%%%SITE_PERL%%/OWNet.pm
+%%OWNETPERL%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OWNet
+%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet-0.3-py2.7.egg-info
+%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/__init__.py
+%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/__init__.pyc
+%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/connection.py
+%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/connection.pyc
+%%OWNETPYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%/ownet
+%%OWPERL%%%%SITE_PERL%%/%%PERL_ARCH%%/OW.pm
+%%OWPERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/OW/.packlist
+%%OWPERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/OW/OW.so
+%%OWPERL%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OW
+%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow-2.9p5-py2.7.egg-info
+%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/_OW.so
+%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/__init__.py
+%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/__init__.pyc
+%%OWPYTHON%%@dirrmtry %%PYTHON_SITELIBDIR%%/ow
+%%OWSERVER%%bin/owserver
+%%OWSHELL%%bin/owdir
+%%OWSHELL%%bin/owexist
+%%OWSHELL%%bin/owget
+%%OWSHELL%%bin/owpresent
+%%OWSHELL%%bin/owread
+%%OWSHELL%%bin/owwrite
+%%OWTAP%%bin/owtap
+%%OWTCL%%@dirrm lib/owtcl-1.0
+%%OWTCL%%lib/owtcl-1.0/ow-1.0.so
+%%OWTCL%%lib/owtcl-1.0/ow.so
+%%OWTCL%%lib/owtcl-1.0/ow.tcl
+%%OWTCL%%lib/owtcl-1.0/pkgIndex.tcl
+bin/owexternal
+include/owfs_config.h
+lib/libow-2.9.so.5
+lib/libow-2.9.so.5.0.0
+lib/libow.so
+man/man1/libowcapi.1.gz
+man/man1/libownet.1.gz
+man/man1/owcapi.1.gz
+man/man1/owdir.1.gz
+man/man1/owfs.1.gz
+man/man1/owftpd.1.gz
+man/man1/owget.1.gz
+man/man1/owhttpd.1.gz
+man/man1/owmon.1.gz
+man/man1/ownet.1.gz
+man/man1/ownetapi.1.gz
+man/man1/ownetlib.1.gz
+man/man1/owpresent.1.gz
+man/man1/owread.1.gz
+man/man1/owserver.1.gz
+man/man1/owshell.1.gz
+man/man1/owtap.1.gz
+man/man1/owwrite.1.gz
+man/man3/DS1427.3.gz
+man/man3/DS1821.3.gz
+man/man3/DS1822.3.gz
+man/man3/DS1825.3.gz
+man/man3/DS18B20.3.gz
+man/man3/DS18S20.3.gz
+man/man3/DS1904.3.gz
+man/man3/DS1920.3.gz
+man/man3/DS1921.3.gz
+man/man3/DS1963L.3.gz
+man/man3/DS1963S.3.gz
+man/man3/DS1971.3.gz
+man/man3/DS1977.3.gz
+man/man3/DS1982.3.gz
+man/man3/DS1982U.3.gz
+man/man3/DS1985.3.gz
+man/man3/DS1985U.3.gz
+man/man3/DS1986.3.gz
+man/man3/DS1986U.3.gz
+man/man3/DS1990A.3.gz
+man/man3/DS1991.3.gz
+man/man3/DS1992.3.gz
+man/man3/DS1993.3.gz
+man/man3/DS1994.3.gz
+man/man3/DS1995.3.gz
+man/man3/DS1996.3.gz
+man/man3/DS2401.3.gz
+man/man3/DS2404.3.gz
+man/man3/DS2404S.3.gz
+man/man3/DS2405.3.gz
+man/man3/DS2406.3.gz
+man/man3/DS2407.3.gz
+man/man3/DS2408.3.gz
+man/man3/DS2409.3.gz
+man/man3/DS2411.3.gz
+man/man3/DS2413.3.gz
+man/man3/DS2415.3.gz
+man/man3/DS2417.3.gz
+man/man3/DS2423.3.gz
+man/man3/DS2430A.3.gz
+man/man3/DS2431.3.gz
+man/man3/DS2433.3.gz
+man/man3/DS2436.3.gz
+man/man3/DS2437.3.gz
+man/man3/DS2438.3.gz
+man/man3/DS2450.3.gz
+man/man3/DS2502-E48.3.gz
+man/man3/DS2502-UNW.3.gz
+man/man3/DS2502.3.gz
+man/man3/DS2505-UNW.3.gz
+man/man3/DS2505.3.gz
+man/man3/DS2506-UNW.3.gz
+man/man3/DS2506.3.gz
+man/man3/DS2720.3.gz
+man/man3/DS2740.3.gz
+man/man3/DS2751.3.gz
+man/man3/DS2755.3.gz
+man/man3/DS2756.3.gz
+man/man3/DS2760.3.gz
+man/man3/DS2761.3.gz
+man/man3/DS2762.3.gz
+man/man3/DS2770.3.gz
+man/man3/DS2780.3.gz
+man/man3/DS2781.3.gz
+man/man3/DS2788.3.gz
+man/man3/DS2804.3.gz
+man/man3/DS2890.3.gz
+man/man3/DS28E04.3.gz
+man/man3/DS28EA00.3.gz
+man/man3/DS28EC20.3.gz
+man/man3/EDS.3.gz
+man/man3/EDS0064.3.gz
+man/man3/EDS0065.3.gz
+man/man3/EDS0066.3.gz
+man/man3/EDS0067.3.gz
+man/man3/EDS0068.3.gz
+man/man3/EDS0070.3.gz
+man/man3/EDS0071.3.gz
+man/man3/EDS0072.3.gz
+man/man3/EDS0080.3.gz
+man/man3/EDS0082.3.gz
+man/man3/EDS0083.3.gz
+man/man3/EDS0085.3.gz
+man/man3/EDS0090.3.gz
+man/man3/EEEF.3.gz
+man/man3/LCD.3.gz
+man/man3/MAX31820.3.gz
+man/man3/MAX31826.3.gz
+man/man3/MAX31850.3.gz
+man/man3/MAX31851.3.gz
+man/man3/OWNet.3.gz
+man/man3/Thermachron.3.gz
+man/man3/UVI.3.gz
+man/man3/mAM001.3.gz
+man/man3/mCM001.3.gz
+man/man3/mDI001.3.gz
+man/man3/mRS001.3.gz
+man/man3/owperl.3.gz
+man/man5/owfs.5.gz
+man/man5/owfs.conf.5.gz
+man/mann/ow.n.gz
+man/mann/owtcl.n.gz