aboutsummaryrefslogtreecommitdiff
path: root/comms/p5-Device-Modem
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2003-07-22 22:41:09 +0000
committerAnders Nordby <anders@FreeBSD.org>2003-07-22 22:41:09 +0000
commit5c4f899a8e6c7d20c51e1b162b9dd12114c253a6 (patch)
treedc5d659e171e684321c283c5aab04c2fcc315cf7 /comms/p5-Device-Modem
parent4d3f5f625f373436eb5d4fcbbd0d75fc137786c7 (diff)
downloadports-5c4f899a8e6c7d20c51e1b162b9dd12114c253a6.tar.gz
ports-5c4f899a8e6c7d20c51e1b162b9dd12114c253a6.zip
Add Device::Modem, a Perl module to talk to AT compliant devices via
serial ports.
Notes
Notes: svn path=/head/; revision=85402
Diffstat (limited to 'comms/p5-Device-Modem')
-rw-r--r--comms/p5-Device-Modem/Makefile34
-rw-r--r--comms/p5-Device-Modem/distinfo1
-rw-r--r--comms/p5-Device-Modem/pkg-descr1
-rw-r--r--comms/p5-Device-Modem/pkg-plist12
4 files changed, 48 insertions, 0 deletions
diff --git a/comms/p5-Device-Modem/Makefile b/comms/p5-Device-Modem/Makefile
new file mode 100644
index 000000000000..a2ac2f6b5196
--- /dev/null
+++ b/comms/p5-Device-Modem/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Device-Modem
+# Date created: 22 July 2003
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Device-Modem
+PORTVERSION= 1.28
+CATEGORIES= comms perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Device
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl class to interface generic modems (AT-compliant)
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Device/SerialPort.pm:${PORTSDIR}/comms/p5-Device-SerialPort
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Device::Modem::Log::File.3 Device::Modem::Log::Syslog.3 Device::Modem.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}/examples
+ ${INSTALL_DATA} ${WRKSRC}/examples/active.pl ${DOCSDIR}/examples/
+ ${INSTALL_DATA} ${WRKSRC}/examples/dial.pl ${DOCSDIR}/examples/
+ ${INSTALL_DATA} ${WRKSRC}/examples/shell.pl ${DOCSDIR}/examples/
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/p5-Device-Modem/distinfo b/comms/p5-Device-Modem/distinfo
new file mode 100644
index 000000000000..6764090d312e
--- /dev/null
+++ b/comms/p5-Device-Modem/distinfo
@@ -0,0 +1 @@
+MD5 (Device-Modem-1.28.tar.gz) = 75ebab69232c67b1eb2b553690cca3f4
diff --git a/comms/p5-Device-Modem/pkg-descr b/comms/p5-Device-Modem/pkg-descr
new file mode 100644
index 000000000000..548b1bf5aad6
--- /dev/null
+++ b/comms/p5-Device-Modem/pkg-descr
@@ -0,0 +1 @@
+This is a perl extension to talk to AT compliant devices via serial ports.
diff --git a/comms/p5-Device-Modem/pkg-plist b/comms/p5-Device-Modem/pkg-plist
new file mode 100644
index 000000000000..cecdee83672f
--- /dev/null
+++ b/comms/p5-Device-Modem/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/Device/Modem/Log/File.pm
+%%SITE_PERL%%/Device/Modem/Log/Syslog.pm
+%%SITE_PERL%%/Device/Modem.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Device/Modem/.packlist
+%%PORTDOCS%%%%DOCSDIR%%/examples/active.pl
+%%PORTDOCS%%%%DOCSDIR%%/examples/dial.pl
+%%PORTDOCS%%%%DOCSDIR%%/examples/shell.pl
+%%PORTDOCS%%@dirrm share/doc/Device-Modem/examples
+%%PORTDOCS%%@dirrm share/doc/Device-Modem
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Device/Modem
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Device 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Device 2>/dev/null || true