aboutsummaryrefslogtreecommitdiff
path: root/comms/p5-Device-Modem
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-11-05 12:30:46 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-11-05 12:30:46 +0000
commitd3a86a7bd90d8d639073fc0235fc46acf0766245 (patch)
tree8f08ce595110f6f0608ecc66b93e776e84a745f2 /comms/p5-Device-Modem
parentd96f8f3e296e5b6f1a78e477ca118c51d4de30fe (diff)
downloadports-d3a86a7bd90d8d639073fc0235fc46acf0766245.tar.gz
ports-d3a86a7bd90d8d639073fc0235fc46acf0766245.zip
Support STAGEDIR.
Notes
Notes: svn path=/head/; revision=332840
Diffstat (limited to 'comms/p5-Device-Modem')
-rw-r--r--comms/p5-Device-Modem/Makefile14
-rw-r--r--comms/p5-Device-Modem/pkg-plist16
2 files changed, 14 insertions, 16 deletions
diff --git a/comms/p5-Device-Modem/Makefile b/comms/p5-Device-Modem/Makefile
index 7059603377a6..928b43f64b5d 100644
--- a/comms/p5-Device-Modem/Makefile
+++ b/comms/p5-Device-Modem/Makefile
@@ -11,24 +11,16 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl class to interface generic modems (AT-compliant)
BUILD_DEPENDS= p5-Device-SerialPort>=0:${PORTSDIR}/comms/p5-Device-SerialPort
-RUN_DEPENDS= p5-Device-SerialPort>=0:${PORTSDIR}/comms/p5-Device-SerialPort
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
-MAN3= Device::Modem.3 \
- Device::Modem::FAQ.3 \
- Device::Modem::Log::File.3 \
- Device::Modem::Log::Syslog.3 \
- Device::Modem::Protocol::Xmodem.3 \
- Device::Modem::UsRobotics.3
-
-NO_STAGE= yes
post-install:
.ifndef(NOPORTEXAMPLES)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/comms/p5-Device-Modem/pkg-plist b/comms/p5-Device-Modem/pkg-plist
index c6f35a1efd78..eb5e4b086ee9 100644
--- a/comms/p5-Device-Modem/pkg-plist
+++ b/comms/p5-Device-Modem/pkg-plist
@@ -1,9 +1,15 @@
+%%PERL5_MAN3%%/Device::Modem.3.gz
+%%PERL5_MAN3%%/Device::Modem::FAQ.3.gz
+%%PERL5_MAN3%%/Device::Modem::Log::File.3.gz
+%%PERL5_MAN3%%/Device::Modem::Log::Syslog.3.gz
+%%PERL5_MAN3%%/Device::Modem::Protocol::Xmodem.3.gz
+%%PERL5_MAN3%%/Device::Modem::UsRobotics.3.gz
+%%SITE_PERL%%/Device/Modem.pm
%%SITE_PERL%%/Device/Modem/FAQ.pod
%%SITE_PERL%%/Device/Modem/Log/File.pm
%%SITE_PERL%%/Device/Modem/Log/Syslog.pm
%%SITE_PERL%%/Device/Modem/Protocol/Xmodem.pm
%%SITE_PERL%%/Device/Modem/UsRobotics.pm
-%%SITE_PERL%%/Device/Modem.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Device/Modem/.packlist
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/active.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/caller-id.pl
@@ -11,9 +17,9 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shell.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xmodem.pl
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Device/Modem
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Device/Modem
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Device
-@dirrm %%SITE_PERL%%/Device/Modem/Protocol
-@dirrm %%SITE_PERL%%/Device/Modem/Log
-@dirrm %%SITE_PERL%%/Device/Modem
+@dirrmtry %%SITE_PERL%%/Device/Modem/Protocol
+@dirrmtry %%SITE_PERL%%/Device/Modem/Log
+@dirrmtry %%SITE_PERL%%/Device/Modem
@dirrmtry %%SITE_PERL%%/Device