aboutsummaryrefslogtreecommitdiff
path: root/comms/p5-SMS-Send-TW-ShareSMS/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-06 15:09:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-06 15:09:25 +0000
commit87f213e8bdcdf8c7c0a024bd6c81dadcb274cb98 (patch)
treedf5ddbb8eb024ca2c8d3811e907ee3d55699a24f /comms/p5-SMS-Send-TW-ShareSMS/Makefile
parent379b06ef8b2334438cd63f6397bc38f264d46c90 (diff)
downloadports-87f213e8bdcdf8c7c0a024bd6c81dadcb274cb98.tar.gz
ports-87f213e8bdcdf8c7c0a024bd6c81dadcb274cb98.zip
Notes
Diffstat (limited to 'comms/p5-SMS-Send-TW-ShareSMS/Makefile')
-rw-r--r--comms/p5-SMS-Send-TW-ShareSMS/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/comms/p5-SMS-Send-TW-ShareSMS/Makefile b/comms/p5-SMS-Send-TW-ShareSMS/Makefile
new file mode 100644
index 000000000000..3c44c5cb3b18
--- /dev/null
+++ b/comms/p5-SMS-Send-TW-ShareSMS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-SMS-Send-TW-ShareSMS
+# Date created: 2007-10-06
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SMS-Send-TW-ShareSMS
+PORTVERSION= 0.01
+CATEGORIES= comms perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= SMS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= SMS::Send driver for www.ShareSMS.com
+
+RUN_DEPENDS= ${SITE_PERL}/SMS/Send.pm:${PORTSDIR}/comms/p5-SMS-Send \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${SITE_PERL}/SMS/Send.pm:${PORTSDIR}/comms/p5-SMS-Send \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= SMS::Send::TW::ShareSMS.3
+
+.include <bsd.port.mk>