aboutsummaryrefslogtreecommitdiff
path: root/comms/picocom
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-23 18:22:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-23 18:22:19 +0000
commit14a36e4848b28c92ad14c9e28ba6876c7ea2ad46 (patch)
treece13ae043b86c229c0baf21416ef89a3f06a9e20 /comms/picocom
parenta066b89dc999bc7fff3b0c55cee6069396e0170e (diff)
downloadports-14a36e4848b28c92ad14c9e28ba6876c7ea2ad46.tar.gz
ports-14a36e4848b28c92ad14c9e28ba6876c7ea2ad46.zip
As its name suggests, picocom is a minimal dumb-terminal emulation pro-
gram. It is, in principle, very much like minicom(1) , only it's "pico" instead of "mini"! It was designed to serve as a simple, manual, modem configuration, testing, and debugging tool. It has also served (quite well) as a low-tech "terminal-window" to allow operator intervention in PPP connection scripts (something like the ms-windows "open terminal window before / after dialing" feature). It could also prove useful in many other similar tasks. WWW: http://efault.net/npat/hacks/picocom/
Notes
Notes: svn path=/head/; revision=223294
Diffstat (limited to 'comms/picocom')
-rw-r--r--comms/picocom/Makefile22
-rw-r--r--comms/picocom/distinfo3
-rw-r--r--comms/picocom/files/patch-Makefile32
-rw-r--r--comms/picocom/pkg-descr11
4 files changed, 68 insertions, 0 deletions
diff --git a/comms/picocom/Makefile b/comms/picocom/Makefile
new file mode 100644
index 000000000000..7da42504e9f2
--- /dev/null
+++ b/comms/picocom/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: picocom
+# Date created: 2008-11-23
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= picocom
+PORTVERSION= 1.4
+CATEGORIES= comms
+MASTER_SITES= http://efault.net/npat/hacks/picocom/dist/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Dumb Terminal Emulator
+
+ALL_TARGET= picocom
+USE_GMAKE= yes
+
+PLIST_FILES= bin/picocom
+MAN8= picocom.8
+
+.include <bsd.port.mk>
diff --git a/comms/picocom/distinfo b/comms/picocom/distinfo
new file mode 100644
index 000000000000..865e7f1cbc36
--- /dev/null
+++ b/comms/picocom/distinfo
@@ -0,0 +1,3 @@
+MD5 (picocom-1.4.tar.gz) = 08fcc5f6bb9e7676a2569386d5ea9f70
+SHA256 (picocom-1.4.tar.gz) = 437c5fac2376e416b4427501d1b074da5aa6b8fea756a0d61aec22686f025721
+SIZE (picocom-1.4.tar.gz) = 41295
diff --git a/comms/picocom/files/patch-Makefile b/comms/picocom/files/patch-Makefile
new file mode 100644
index 000000000000..3293a1f548ff
--- /dev/null
+++ b/comms/picocom/files/patch-Makefile
@@ -0,0 +1,32 @@
+--- Makefile.orig 2008-11-04 10:13:20.000000000 -0700
++++ Makefile
+@@ -3,12 +3,15 @@ VERSION=1.4
+
+ # CC = gcc
+ CPPFLAGS=-DVERSION_STR=\"$(VERSION)\" -DUUCP_LOCK_DIR=\"/var/lock\"
+-CFLAGS = -Wall -g
++CFLAGS = -Wall -g -I$(PREFIX)/include
+
+ # LD = gcc
+-LDFLAGS = -g
++LDFLAGS = -g -Wl,-R$(PREFIX)/lib -L$(PREFIX)/lib -lcurses
+ LDLIBS =
+
++BIN = $(PREFIX)/bin
++MAN8 = $(PREFIX)/man/man8
++
+ picocom : picocom.o term.o
+ # $(LD) $(LDFLAGS) -o $@ $+ $(LDLIBS)
+
+@@ -17,6 +20,12 @@ term.o : term.c term.h
+
+ doc : picocom.8 picocom.8.html picocom.8.ps
+
++install:
++ -install -d $(BIN)
++ install -o root picocom $(BIN)
++ -install -d $(MAN8)
++ install -o root picocom.8 $(MAN8)
++
+ changes :
+ svn log -v . > CHANGES
diff --git a/comms/picocom/pkg-descr b/comms/picocom/pkg-descr
new file mode 100644
index 000000000000..72233182301c
--- /dev/null
+++ b/comms/picocom/pkg-descr
@@ -0,0 +1,11 @@
+As its name suggests, picocom is a minimal dumb-terminal emulation pro-
+gram. It is, in principle, very much like minicom(1) , only it's "pico"
+instead of "mini"! It was designed to serve as a simple, manual, modem
+configuration, testing, and debugging tool. It has also served (quite
+well) as a low-tech "terminal-window" to allow operator intervention in
+PPP connection scripts (something like the ms-windows "open terminal
+window before / after dialing" feature). It could also prove useful in
+many other similar tasks.
+
+
+WWW: http://efault.net/npat/hacks/picocom/