aboutsummaryrefslogtreecommitdiff
path: root/comms/predict
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-10-13 00:49:26 +0000
committerDiane Bruce <db@FreeBSD.org>2020-10-13 00:49:26 +0000
commitdf449157acabdeaf6fbe13b50e832929aa3ca958 (patch)
treeb17b295cbfe84e45c4e265ebdafc0c1d902f49d3 /comms/predict
parent22ac06ade402a30ddceff5779e40094174ba4ca6 (diff)
downloadports-df449157acabdeaf6fbe13b50e832929aa3ca958.tar.gz
ports-df449157acabdeaf6fbe13b50e832929aa3ca958.zip
Notes
Diffstat (limited to 'comms/predict')
-rw-r--r--comms/predict/Makefile15
-rw-r--r--comms/predict/distinfo5
-rw-r--r--comms/predict/files/Makefile30
-rw-r--r--comms/predict/files/patch-predict.c38
-rw-r--r--comms/predict/files/predict.h2
-rw-r--r--comms/predict/files/vocalizer.h2
-rw-r--r--comms/predict/pkg-plist1
7 files changed, 25 insertions, 68 deletions
diff --git a/comms/predict/Makefile b/comms/predict/Makefile
index 9a4c43309592..f20cfe1446b8 100644
--- a/comms/predict/Makefile
+++ b/comms/predict/Makefile
@@ -1,10 +1,9 @@
-# Created by: db
# $FreeBSD$
-PORTNAME= predict
-PORTVERSION= 2.2.3
-CATEGORIES= comms astro hamradio
-MASTER_SITES= ftp://ftp.amsat.org/amsat/software/Linux/ \
+PORTNAME= predict
+PORTVERSION= 2.2.7
+CATEGORIES= comms astro hamradio
+MASTER_SITES= https://www.qsl.net/kd2bd/ \
LOCAL/db
MAINTAINER= hamradio@FreeBSD.org
@@ -12,14 +11,16 @@ COMMENT= Satellite tracking program for amateur radio satellites
LICENSE= GPLv2
+LIB_DEPENDS= libasound.so:audio/alsa-lib
+
USES= ncurses
INSTALL_TARGET= install install.man
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
post-patch:
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/predict.h > ${WRKSRC}/predict.h
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/vocalizer.h > ${WRKSRC}/vocalizer/vocalizer.h
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' -e 's|%%STAGEDIR%%|${STAGEDIR}|g' \
- ${FILESDIR}/Makefile > ${WRKSRC}/Makefile
+ -e 's|%%CC%%|${CC}|g' -e 's|%%CFLAGS%%|${CFLAGS}|g' \
+ ${FILESDIR}/Makefile > ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/comms/predict/distinfo b/comms/predict/distinfo
index abafd0317aac..15937eb28da9 100644
--- a/comms/predict/distinfo
+++ b/comms/predict/distinfo
@@ -1,2 +1,3 @@
-SHA256 (predict-2.2.3.tar.gz) = fbaa7c78227a2216ee22b25c914c4dd538abfc22d96f0bb5d21e3e61976e5166
-SIZE (predict-2.2.3.tar.gz) = 1639784
+TIMESTAMP = 1602533134
+SHA256 (predict-2.2.7.tar.gz) = bc4e828209996daefa591aad2e27320786f86b4da949df6a8c3f167ab035fd71
+SIZE (predict-2.2.7.tar.gz) = 1887048
diff --git a/comms/predict/files/Makefile b/comms/predict/files/Makefile
index 1dcc08592cba..2323d00dd36b 100644
--- a/comms/predict/files/Makefile
+++ b/comms/predict/files/Makefile
@@ -2,16 +2,8 @@
PREFIX= %%PREFIX%%
STAGEDIR= %%STAGEDIR%%
-
-.ifndef CC
-CC = -cc
-.endif
-.ifndef CPPFLAGS
-CPPFLAGS =
-.endif
-.ifndef CFLAGS
-CFLAGS = -O2
-.endif
+CC= %%CC%%
+CFLAGS= %%CFLAGS%%
default: all
all: predict vocalizer/vocalizer
@@ -21,7 +13,7 @@ predict: predict.c predict.h
${CC} ${CFLAGS} -o predict predict.c ${LIBS}
vocalizer/vocalizer: vocalizer/vocalizer.c vocalizer/vocalizer.h
- ${CC} ${CFLAGS} -o vocalizer/vocalizer vocalizer/vocalizer.c ${LIBS}
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o vocalizer/vocalizer vocalizer/vocalizer.c -L${LOCALBASE}/lib ${LIBS} -lasound
clean:
rm -f *.o predict *core *~ \#* *.txt vocalizer/vocalizer
@@ -30,14 +22,16 @@ install:
mkdir -p ${STAGEDIR}${PREFIX}/share/predict/
mkdir ${STAGEDIR}${PREFIX}/share/predict/default
mkdir ${STAGEDIR}${PREFIX}/share/predict/vocalizer
- cp default/predict.db ${STAGEDIR}${PREFIX}/share/predict/default
- cp default/predict.qth ${STAGEDIR}${PREFIX}/share/predict/default
- cp default/predict.tle ${STAGEDIR}${PREFIX}/share/predict/default
- cp vocalizer/*.wav ${STAGEDIR}${PREFIX}/share/predict/vocalizer
- cp predict ${STAGEDIR}${PREFIX}/bin
- cp vocalizer/vocalizer ${STAGEDIR}${PREFIX}/bin
+ install -m 0644 default/predict.db ${STAGEDIR}${PREFIX}/share/predict/default
+ install -m 0644 default/predict.qth ${STAGEDIR}${PREFIX}/share/predict/default
+ install -m 0644 default/predict.tle ${STAGEDIR}${PREFIX}/share/predict/default
+ install -m 0644 vocalizer/*.wav ${STAGEDIR}${PREFIX}/share/predict/vocalizer
+ install predict ${STAGEDIR}${PREFIX}/bin
+ strip ${STAGEDIR}${PREFIX}/bin/predict
+ install vocalizer/vocalizer ${STAGEDIR}${PREFIX}/bin
+ strip ${STAGEDIR}${PREFIX}/bin/vocalizer
install.man:
- install docs/man/predict.1 ${STAGEDIR}${PREFIX}/man/man1
+ install -m 0644 docs/man/predict.1 ${STAGEDIR}${PREFIX}/man/man1
.PHONY: clean build
diff --git a/comms/predict/files/patch-predict.c b/comms/predict/files/patch-predict.c
deleted file mode 100644
index 8c76ca342342..000000000000
--- a/comms/predict/files/patch-predict.c
+++ /dev/null
@@ -1,38 +0,0 @@
---- predict.c.orig Tue May 16 20:48:30 2006
-+++ predict.c Tue May 16 20:49:36 2006
-@@ -5128,7 +5128,7 @@
-
- if ((old_visibility=='V' || old_visibility=='D') && visibility=='N')
- {
-- sprintf(command,"%svocalizer/vocalizer eclipse &",predictpath);
-+ sprintf(command,"vocalizer eclipse &",predictpath);
- system(command);
- eclipse_alarm=1;
- oldtime-=0.000015*sqrt(sat_alt);
-@@ -5136,7 +5136,7 @@
-
- if (old_visibility=='N' && (visibility=='V' || visibility=='D'))
- {
-- sprintf(command,"%svocalizer/vocalizer sunlight &",predictpath);
-+ sprintf(command,"vocalizer sunlight &",predictpath);
- system(command);
- eclipse_alarm=1;
- oldtime-=0.000015*sqrt(sat_alt);
-@@ -5151,7 +5151,7 @@
- if (sat_range_rate>0.0)
- approaching='-';
-
-- sprintf(command,"%svocalizer/vocalizer %.0f %.0f %c %c &",predictpath,sat_azi,sat_ele,approaching,visibility);
-+ sprintf(command,"vocalizer %.0f %.0f %c %c &",predictpath,sat_azi,sat_ele,approaching,visibility);
- system(command);
- oldtime=CurrentDaynum();
- old_visibility=visibility;
-@@ -5273,7 +5273,7 @@
- {
- /* Announce LOS */
-
-- sprintf(command,"%svocalizer/vocalizer los &",predictpath);
-+ sprintf(command,"vocalizer los &",predictpath);
- system(command);
- }
- }
diff --git a/comms/predict/files/predict.h b/comms/predict/files/predict.h
index e0d913cbd353..1f17708dc8ce 100644
--- a/comms/predict/files/predict.h
+++ b/comms/predict/files/predict.h
@@ -1 +1 @@
-char *predictpath={"%%PREFIX%%/share/predict/"}, soundcard=1, *version={"2.2.3"};
+char *predictpath={"/usr/local/share/predict/"}, soundcard=1, *version={"2.2.3"};
diff --git a/comms/predict/files/vocalizer.h b/comms/predict/files/vocalizer.h
index 1cf9ae955aab..e8ae971fdb19 100644
--- a/comms/predict/files/vocalizer.h
+++ b/comms/predict/files/vocalizer.h
@@ -1 +1 @@
-char *path={"%%PREFIX%%/share/predict/vocalizer/"};
+char *path={"/usr/local/share/predict/vocalizer/"};
diff --git a/comms/predict/pkg-plist b/comms/predict/pkg-plist
index 057410c39361..cfcb09d2389c 100644
--- a/comms/predict/pkg-plist
+++ b/comms/predict/pkg-plist
@@ -4,7 +4,6 @@ man/man1/predict.1.gz
%%DATADIR%%/default/predict.db
%%DATADIR%%/default/predict.qth
%%DATADIR%%/default/predict.tle
-%%DATADIR%%/vocalizer/alarm.wav
%%DATADIR%%/vocalizer/approaching.wav
%%DATADIR%%/vocalizer/azimuth.wav
%%DATADIR%%/vocalizer/eclipse.wav