aboutsummaryrefslogtreecommitdiff
path: root/comms/py-hidapi
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-10-11 22:34:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-10-11 22:34:31 +0000
commit584f3238f8b84dfae508fa39bd08c5f041e6f469 (patch)
treeae8d02db1f917b2d838cef25cf73abc58e6b9033 /comms/py-hidapi
parent93210d6be31a966367e3b674eb052cf7340d4f06 (diff)
downloadports-584f3238f8b84dfae508fa39bd08c5f041e6f469.tar.gz
ports-584f3238f8b84dfae508fa39bd08c5f041e6f469.zip
Add py-hidapi 0.7.99, cython interface to comms/hidapi.
Notes
Notes: svn path=/head/; revision=451805
Diffstat (limited to 'comms/py-hidapi')
-rw-r--r--comms/py-hidapi/Makefile28
-rw-r--r--comms/py-hidapi/distinfo3
-rw-r--r--comms/py-hidapi/pkg-descr3
3 files changed, 34 insertions, 0 deletions
diff --git a/comms/py-hidapi/Makefile b/comms/py-hidapi/Makefile
new file mode 100644
index 000000000000..23944b75b6c2
--- /dev/null
+++ b/comms/py-hidapi/Makefile
@@ -0,0 +1,28 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hidapi
+PORTVERSION= 0.7.99
+DISTVERSIONSUFFIX= .post21
+CATEGORIES= comms python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Cython interface to comms/hidapi
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= cython:lang/cython
+LIB_DEPENDS= libhidapi.so:comms/hidapi
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|usb-1.0|usb|g' ${WRKSRC}/setup.py
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/hid.so
+
+.include <bsd.port.mk>
diff --git a/comms/py-hidapi/distinfo b/comms/py-hidapi/distinfo
new file mode 100644
index 000000000000..149f1a699e6e
--- /dev/null
+++ b/comms/py-hidapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507756423
+SHA256 (hidapi-0.7.99.post21.tar.gz) = e0be1aa6566979266a8fc845ab0e18613f4918cf2c977fe67050f5dc7e2a9a97
+SIZE (hidapi-0.7.99.post21.tar.gz) = 51377
diff --git a/comms/py-hidapi/pkg-descr b/comms/py-hidapi/pkg-descr
new file mode 100644
index 000000000000..dfe8a35bd2c5
--- /dev/null
+++ b/comms/py-hidapi/pkg-descr
@@ -0,0 +1,3 @@
+Cython interface to comms/hidapi.
+
+WWW: https://pypi.python.org/pypi/hidapi