aboutsummaryrefslogtreecommitdiff
path: root/comms/py-qt5-sensors
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-10-05 15:50:03 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-10-05 15:50:03 +0000
commit2933bb22c330742a9a771b8a84abb127fc3e8cbc (patch)
tree4f76a634aa6b24065331c83abce53f1dfe75ebf9 /comms/py-qt5-sensors
parent4d98efd1ac4f23c42ac3616f40382cc7b48b2581 (diff)
downloadports-2933bb22c330742a9a771b8a84abb127fc3e8cbc.tar.gz
ports-2933bb22c330742a9a771b8a84abb127fc3e8cbc.zip
Update PyQt to 5.15.0, py-sip to 4.19.24 and qscintilla2 to 2.11.5
- Update PyQt to 5.15.0, py-sip to 4.19.24 and qscintilla2 to 2.11.5 - Use pypi for PYQT [1] - Add devel/py-qt5-sip (Don't use it for now. It will be used in future updates of PyQt with py-sip >= 5) - Add missing py-qt5 ports: comms/py-qt5-sensors, devel/py-qt5-location, devel/py-qt5-remoteobjects, net/py-qt5-networkauth - Strip libs - Refactor *_PATH and *_PORT parts [1] RiverBankComputing doesn't offer links to download latest version of some ports PR: 247369 Reviewed by: tcberner Differential Revision: https://reviews.freebsd.org/D25749 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=551499
Diffstat (limited to 'comms/py-qt5-sensors')
-rw-r--r--comms/py-qt5-sensors/Makefile34
-rw-r--r--comms/py-qt5-sensors/pkg-descr4
-rw-r--r--comms/py-qt5-sensors/pkg-plist24
3 files changed, 62 insertions, 0 deletions
diff --git a/comms/py-qt5-sensors/Makefile b/comms/py-qt5-sensors/Makefile
new file mode 100644
index 000000000000..098faae045a2
--- /dev/null
+++ b/comms/py-qt5-sensors/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= sensors
+CATEGORIES= comms devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtSensors module
+
+BUILD_DEPENDS= ${PY_ENUM34}
+RUN_DEPENDS= ${PY_ENUM34}
+
+CONFIGURE_ARGS= --enable QtSensors
+PYQT_DIST= yes
+
+USES= gl python pyqt:5 qt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run
+USE_PYTHON= concurrent flavors py3kplist
+USE_QT= core gui sensors qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtSensors API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtSensors.so
+
+.include <bsd.port.mk>
diff --git a/comms/py-qt5-sensors/pkg-descr b/comms/py-qt5-sensors/pkg-descr
new file mode 100644
index 000000000000..32b00ca3bfd0
--- /dev/null
+++ b/comms/py-qt5-sensors/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtSensors module.
+
+WWW: https://riverbankcomputing.com/software/pyqt
diff --git a/comms/py-qt5-sensors/pkg-plist b/comms/py-qt5-sensors/pkg-plist
new file mode 100644
index 000000000000..094231ef2feb
--- /dev/null
+++ b/comms/py-qt5-sensors/pkg-plist
@@ -0,0 +1,24 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtSensors.pyi
+%%PYTHON_SITELIBDIR%%/PyQt5/QtSensors.so
+%%API%%%%PYQT_APIDIR%%/api/python/QtSensors.api
+%%PYQT_SIPDIR%%/QtSensors/QtSensorsmod.sip
+%%PYQT_SIPDIR%%/QtSensors/qaccelerometer.sip
+%%PYQT_SIPDIR%%/QtSensors/qaltimeter.sip
+%%PYQT_SIPDIR%%/QtSensors/qambientlightsensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qambienttemperaturesensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qcompass.sip
+%%PYQT_SIPDIR%%/QtSensors/qdistancesensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qgyroscope.sip
+%%PYQT_SIPDIR%%/QtSensors/qholstersensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qhumiditysensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qirproximitysensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qlidsensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qlightsensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qmagnetometer.sip
+%%PYQT_SIPDIR%%/QtSensors/qorientationsensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qpressuresensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qproximitysensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qrotationsensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qsensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qtapsensor.sip
+%%PYQT_SIPDIR%%/QtSensors/qtiltsensor.sip