aboutsummaryrefslogtreecommitdiff
path: root/comms/py-serial
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-10-13 20:35:29 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-10-13 20:35:29 +0000
commit312b3b9c38104463224c8ddb57ace8f3aedd2fdf (patch)
treea147b5e1f619ef882d436132221e8ec3a9a8fcfb /comms/py-serial
parentca45c4c08c036be9005cf77a7a3ca58ac07af8b6 (diff)
downloadports-312b3b9c38104463224c8ddb57ace8f3aedd2fdf.tar.gz
ports-312b3b9c38104463224c8ddb57ace8f3aedd2fdf.zip
Notes
Diffstat (limited to 'comms/py-serial')
-rw-r--r--comms/py-serial/Makefile13
-rw-r--r--comms/py-serial/files/patch-serial_tools_list__ports__posix.py11
2 files changed, 18 insertions, 6 deletions
diff --git a/comms/py-serial/Makefile b/comms/py-serial/Makefile
index df96188749d2..0fdc01c73962 100644
--- a/comms/py-serial/Makefile
+++ b/comms/py-serial/Makefile
@@ -3,6 +3,7 @@
PORTNAME= serial
PORTVERSION= 2.7
+PORTREVISION= 1
CATEGORIES= comms python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,18 +12,18 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= sbz@FreeBSD.org
COMMENT= Serial port encapsulation library for Python
-USES= python
-USE_PYTHON= distutils pythonprefix
+USES= dos2unix python
+USE_PYTHON= concurrent distutils py3kplist pythonprefix
PYDISTUTILS_PKGNAME= py${PORTNAME}
-
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+DOS2UNIX_FILES= serial/tools/list_ports_posix.py
OPTIONS_DEFINE= DOCS EXAMPLES
-post-install:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/comms/py-serial/files/patch-serial_tools_list__ports__posix.py b/comms/py-serial/files/patch-serial_tools_list__ports__posix.py
new file mode 100644
index 000000000000..92fb9f247300
--- /dev/null
+++ b/comms/py-serial/files/patch-serial_tools_list__ports__posix.py
@@ -0,0 +1,11 @@
+--- serial/tools/list_ports_posix.py.orig 2013-10-12 03:43:18 UTC
++++ serial/tools/list_ports_posix.py
+@@ -43,7 +43,7 @@ elif plat[:3] == 'bsd' or \
+ plat[:7] == 'freebsd':
+
+ def comports():
+- devices = glob.glob('/dev/cuad*')
++ devices = glob.glob('/dev/cua*[!.init][!.lock]')
+ return [(d, d, d) for d in devices]
+
+ elif plat[:6] == 'darwin': # OS X (confirmed)