aboutsummaryrefslogtreecommitdiff
path: root/comms/qt6-connectivity
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-09-29 04:05:14 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-09-29 04:10:07 +0000
commitcb2e2b668adab05ec009ab06af987372059c35ae (patch)
tree093166929aa010697ab802ef73b50150ad051287 /comms/qt6-connectivity
parent36a838e202256d5a528abfc8ff6a66ca7ce4d148 (diff)
downloadports-cb2e2b668adab05ec009ab06af987372059c35ae.tar.gz
ports-cb2e2b668adab05ec009ab06af987372059c35ae.zip
comms/qt6-connectivity: new port
Diffstat (limited to 'comms/qt6-connectivity')
-rw-r--r--comms/qt6-connectivity/Makefile12
-rw-r--r--comms/qt6-connectivity/distinfo3
-rw-r--r--comms/qt6-connectivity/pkg-plist135
3 files changed, 150 insertions, 0 deletions
diff --git a/comms/qt6-connectivity/Makefile b/comms/qt6-connectivity/Makefile
new file mode 100644
index 000000000000..9fdb3fba6e73
--- /dev/null
+++ b/comms/qt6-connectivity/Makefile
@@ -0,0 +1,12 @@
+PORTNAME= connectivity
+PORTVERSION= ${QT6_VERSION}
+CATEGORIES= comms
+PKGNAMEPREFIX= qt6-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt connectivity (Bluetooth/NFC) module
+
+USES= compiler:c++11-lang perl5 cmake qt-dist:6,connectivity
+USE_QT= base
+
+.include <bsd.port.mk>
diff --git a/comms/qt6-connectivity/distinfo b/comms/qt6-connectivity/distinfo
new file mode 100644
index 000000000000..1d81f793939c
--- /dev/null
+++ b/comms/qt6-connectivity/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1695806920
+SHA256 (KDE/Qt/6.5.2/qtconnectivity-everywhere-src-6.5.2.tar.xz) = db2e4922352d253cafbb8f21eeca58da269c19e0e6d614420af19a7cd35fdc99
+SIZE (KDE/Qt/6.5.2/qtconnectivity-everywhere-src-6.5.2.tar.xz) = 985972
diff --git a/comms/qt6-connectivity/pkg-plist b/comms/qt6-connectivity/pkg-plist
new file mode 100644
index 000000000000..21eff4b22f6c
--- /dev/null
+++ b/comms/qt6-connectivity/pkg-plist
@@ -0,0 +1,135 @@
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/dummy_helper_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/lecmaccalculator_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdevicediscoveryagent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothdeviceinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothhostinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothlocaldevice_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserver_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothservicediscoveryagent_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothserviceinfo_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothsocket_dummy_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qbluetoothsocketbase_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergycontroller_dummy_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergycontrollerbase_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qlowenergyserviceprivate_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qprivatelinearbuffer_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qtbluetooth-config_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qtbluetoothexports_p.h
+%%QT_INCDIR%%/QtBluetooth/%%FULLVER%%/QtBluetooth/private/qtbluetoothglobal_p.h
+%%QT_INCDIR%%/QtBluetooth/QBluetoothAddress
+%%QT_INCDIR%%/QtBluetooth/QBluetoothDeviceDiscoveryAgent
+%%QT_INCDIR%%/QtBluetooth/QBluetoothDeviceInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothHostInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothLocalDevice
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServer
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServiceDiscoveryAgent
+%%QT_INCDIR%%/QtBluetooth/QBluetoothServiceInfo
+%%QT_INCDIR%%/QtBluetooth/QBluetoothSocket
+%%QT_INCDIR%%/QtBluetooth/QBluetoothUuid
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyAdvertisingData
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyAdvertisingParameters
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyCharacteristic
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyCharacteristicData
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyConnectionParameters
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyController
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyDescriptor
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyDescriptorData
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyHandle
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyService
+%%QT_INCDIR%%/QtBluetooth/QLowEnergyServiceData
+%%QT_INCDIR%%/QtBluetooth/QtBluetooth
+%%QT_INCDIR%%/QtBluetooth/QtBluetoothDepends
+%%QT_INCDIR%%/QtBluetooth/QtBluetoothVersion
+%%QT_INCDIR%%/QtBluetooth/qbluetooth.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothaddress.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothdevicediscoveryagent.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothdeviceinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothhostinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothlocaldevice.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothserver.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothservicediscoveryagent.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothserviceinfo.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothsocket.h
+%%QT_INCDIR%%/QtBluetooth/qbluetoothuuid.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergyadvertisingdata.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergyadvertisingparameters.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergycharacteristic.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergycharacteristicdata.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergyconnectionparameters.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergycontroller.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergydescriptor.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergydescriptordata.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergyservice.h
+%%QT_INCDIR%%/QtBluetooth/qlowenergyservicedata.h
+%%QT_INCDIR%%/QtBluetooth/qtbluetooth-config.h
+%%QT_INCDIR%%/QtBluetooth/qtbluetoothexports.h
+%%QT_INCDIR%%/QtBluetooth/qtbluetoothglobal.h
+%%QT_INCDIR%%/QtBluetooth/qtbluetoothversion.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qndefnfcsmartposterrecord_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qndefrecord_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_generic_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldmanager_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qnearfieldtarget_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qtnfc-config_p.h
+%%QT_INCDIR%%/QtNfc/%%FULLVER%%/QtNfc/private/qtnfcglobal_p.h
+%%QT_INCDIR%%/QtNfc/QNdefFilter
+%%QT_INCDIR%%/QtNfc/QNdefMessage
+%%QT_INCDIR%%/QtNfc/QNdefNfcIconRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcSmartPosterRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcTextRecord
+%%QT_INCDIR%%/QtNfc/QNdefNfcUriRecord
+%%QT_INCDIR%%/QtNfc/QNdefRecord
+%%QT_INCDIR%%/QtNfc/QNearFieldManager
+%%QT_INCDIR%%/QtNfc/QNearFieldTarget
+%%QT_INCDIR%%/QtNfc/QtNfc
+%%QT_INCDIR%%/QtNfc/QtNfcDepends
+%%QT_INCDIR%%/QtNfc/QtNfcVersion
+%%QT_INCDIR%%/QtNfc/qndeffilter.h
+%%QT_INCDIR%%/QtNfc/qndefmessage.h
+%%QT_INCDIR%%/QtNfc/qndefnfcsmartposterrecord.h
+%%QT_INCDIR%%/QtNfc/qndefnfctextrecord.h
+%%QT_INCDIR%%/QtNfc/qndefnfcurirecord.h
+%%QT_INCDIR%%/QtNfc/qndefrecord.h
+%%QT_INCDIR%%/QtNfc/qnearfieldmanager.h
+%%QT_INCDIR%%/QtNfc/qnearfieldtarget.h
+%%QT_INCDIR%%/QtNfc/qtnfc-config.h
+%%QT_INCDIR%%/QtNfc/qtnfcexports.h
+%%QT_INCDIR%%/QtNfc/qtnfcglobal.h
+%%QT_INCDIR%%/QtNfc/qtnfcversion.h
+lib/cmake/Qt6/FindBlueZ.cmake
+lib/cmake/Qt6/FindPCSCLITE.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothAdditionalTargetInfo.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothConfig.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothConfigVersion.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothConfigVersionImpl.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothDependencies.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothTargets.cmake
+lib/cmake/Qt6Bluetooth/Qt6BluetoothVersionlessTargets.cmake
+lib/cmake/Qt6BuildInternals/StandaloneTests/QtConnectivityTestsConfig.cmake
+lib/cmake/Qt6Nfc/Qt6NfcAdditionalTargetInfo.cmake
+lib/cmake/Qt6Nfc/Qt6NfcConfig.cmake
+lib/cmake/Qt6Nfc/Qt6NfcConfigVersion.cmake
+lib/cmake/Qt6Nfc/Qt6NfcConfigVersionImpl.cmake
+lib/cmake/Qt6Nfc/Qt6NfcDependencies.cmake
+lib/cmake/Qt6Nfc/Qt6NfcTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6Nfc/Qt6NfcTargets.cmake
+lib/cmake/Qt6Nfc/Qt6NfcVersionlessTargets.cmake
+%%QT_LIBDIR%%/libQt6Bluetooth.prl
+%%QT_LIBDIR%%/libQt6Bluetooth.so
+%%QT_LIBDIR%%/libQt6Bluetooth.so.6
+%%QT_LIBDIR%%/libQt6Bluetooth.so.%%FULLVER%%
+%%QT_LIBDIR%%/libQt6Nfc.prl
+%%QT_LIBDIR%%/libQt6Nfc.so
+%%QT_LIBDIR%%/libQt6Nfc.so.6
+%%QT_LIBDIR%%/libQt6Nfc.so.%%FULLVER%%
+%%QT_LIBDIR%%/metatypes/qt6bluetooth_%%CMAKE_BUILD_TYPE%%_metatypes.json
+%%QT_LIBDIR%%/metatypes/qt6nfc_%%CMAKE_BUILD_TYPE%%_metatypes.json
+%%QT_MKSPECDIR%%/modules/qt_lib_bluetooth.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_bluetooth_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_nfc.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_nfc_private.pri
+libdata/pkgconfig/Qt6Bluetooth.pc
+libdata/pkgconfig/Qt6Nfc.pc
+%%QT_DATADIR%%/modules/Bluetooth.json
+%%QT_DATADIR%%/modules/Nfc.json