aboutsummaryrefslogtreecommitdiff
path: root/comms/redsea
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-02-20 21:49:09 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-02-20 21:49:09 +0000
commita943e48a11b2ccec2877f43e106d30f5fea0588e (patch)
tree5918df4a387b3f52d4166bed0561dfb9c0636633 /comms/redsea
parent6c318dc5623df09111624687ad79a3649f5226f6 (diff)
downloadports-a943e48a11b2ccec2877f43e106d30f5fea0588e.tar.gz
ports-a943e48a11b2ccec2877f43e106d30f5fea0588e.zip
Notes
Diffstat (limited to 'comms/redsea')
-rw-r--r--comms/redsea/Makefile36
-rw-r--r--comms/redsea/distinfo3
-rw-r--r--comms/redsea/pkg-descr11
-rw-r--r--comms/redsea/pkg-message10
4 files changed, 60 insertions, 0 deletions
diff --git a/comms/redsea/Makefile b/comms/redsea/Makefile
new file mode 100644
index 000000000000..b4bdfcd82979
--- /dev/null
+++ b/comms/redsea/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= redsea
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.17.1
+CATEGORIES= comms
+
+MAINTAINER= morrand276@gmail.com
+COMMENT= Lightweight command-line FM-RDS decoder
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libsndfile.so:audio/libsndfile
+
+USES= autoreconf:build compiler:c++14-lang iconv localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= windytan
+
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/redsea ${DOCSDIR}/README.md
+
+OPTIONS_DEFINE= DEMOD TMC
+OPTIONS_DEFAULT= DEMOD TMC
+
+DEMOD_DESC= Demodulation support via comms/liquid-dsp
+TMC_DESC= TMC (traffic messages) support (may slow building)
+
+DEMOD_CONFIGURE_WITH= liquid
+DEMOD_LIB_DEPENDS= libliquid.so:comms/liquid-dsp
+TMC_CONFIGURE_ENABLE= tmc
+
+pre-configure:
+ @cd ${WRKSRC} && ${AUTORECONF} -i
+
+.include <bsd.port.mk>
diff --git a/comms/redsea/distinfo b/comms/redsea/distinfo
new file mode 100644
index 000000000000..c599b6b4781b
--- /dev/null
+++ b/comms/redsea/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1546699406
+SHA256 (windytan-redsea-v0.17.1_GH0.tar.gz) = 15fc9f2c733ce0b68b27301df071b20846ad30ac5670599a9344d63bd7d0afbd
+SIZE (windytan-redsea-v0.17.1_GH0.tar.gz) = 119115
diff --git a/comms/redsea/pkg-descr b/comms/redsea/pkg-descr
new file mode 100644
index 000000000000..7f9ebb7a9a0c
--- /dev/null
+++ b/comms/redsea/pkg-descr
@@ -0,0 +1,11 @@
+redsea is a lightweight command-line decoder for broadcast FM-RDS data,
+such as that provided from a software-defined radio (SDR). It can also
+decode raw ASCII bitstreams, the hex format provided by RDS Spy, and audio
+files containing multiplex signals. Decoded RDS groups are printed to the
+terminal as line-delimited JSON objects; optionally, undecoded hex blocks
+can be output instead.
+
+This program is intended to be used in combination with a separate source
+of demodulated FM multiplex signals, such as rtl-sdr.
+
+WWW: https://github.com/windytan/redsea/
diff --git a/comms/redsea/pkg-message b/comms/redsea/pkg-message
new file mode 100644
index 000000000000..a5529dab99f5
--- /dev/null
+++ b/comms/redsea/pkg-message
@@ -0,0 +1,10 @@
+Don't forget to give redsea something to decode! For output from a USB
+software-defined radio stick, you may want to consider installing
+comms/rtl-sdr or another SDR tool of your choice that can feed raw I/Q
+data on stdout.
+
+You can also provide redsea with hex data from RDS Spy, raw ASCII
+bitstream, or an audio file containing a multiplexed FM signal.
+
+Fuller details are contained in the redsea wiki:
+https://github.com/windytan/redsea/wiki/Input-formats