aboutsummaryrefslogtreecommitdiff
path: root/comms/rtl-sdr
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-05 22:58:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-05 22:58:02 +0000
commit7277ec6a16005fbbf00e59a8beacc7634f4376fc (patch)
tree89becbb47fd3ca1d6f3fd97d6677e0b01732e970 /comms/rtl-sdr
parent96966101c6558191cb15925803ded6baf1737eb7 (diff)
downloadports-7277ec6a16005fbbf00e59a8beacc7634f4376fc.tar.gz
ports-7277ec6a16005fbbf00e59a8beacc7634f4376fc.zip
Assume "pkg-config libusb*" works after 9.x EOL
FreeBSD appears to use different pkg-config name for 0.1.x API but it doesn't matter much as 0.1, 1.0 and 2.0 share CFLAGS/LIBS.
Notes
Notes: svn path=/head/; revision=430669
Diffstat (limited to 'comms/rtl-sdr')
-rw-r--r--comms/rtl-sdr/Makefile2
-rw-r--r--comms/rtl-sdr/files/patch-configure.ac11
-rw-r--r--comms/rtl-sdr/files/patch-librtlsdr.pc.in4
3 files changed, 4 insertions, 13 deletions
diff --git a/comms/rtl-sdr/Makefile b/comms/rtl-sdr/Makefile
index 741c227324c4..1564fbdeae11 100644
--- a/comms/rtl-sdr/Makefile
+++ b/comms/rtl-sdr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rtl-sdr
PORTVERSION= 20140210
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= comms hamradio
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
diff --git a/comms/rtl-sdr/files/patch-configure.ac b/comms/rtl-sdr/files/patch-configure.ac
index 41b2b774812f..344f1a6cf34a 100644
--- a/comms/rtl-sdr/files/patch-configure.ac
+++ b/comms/rtl-sdr/files/patch-configure.ac
@@ -1,16 +1,5 @@
--- configure.ac.orig 2012-08-23 08:40:54.000000000 +0200
+++ configure.ac 2012-08-23 11:47:20.000000000 +0200
-@@ -14,9 +14,7 @@
- LT_INIT
- AC_PROG_LIBTOOL
-
--PKG_CHECK_MODULES(LIBUSB, libusb-1.0 >= 1.0)
--LIBS="$LIBS $LIBUSB_LIBS"
--CFLAGS="$CFLAGS $LIBUSB_CFLAGS"
-+LIBS="$LIBS -lusb"
-
- AC_PATH_PROG(DOXYGEN,doxygen,false)
- AM_CONDITIONAL(HAVE_DOXYGEN, test $DOXYGEN != false)
@@ -34,7 +32,7 @@
dnl checks for required libraries
diff --git a/comms/rtl-sdr/files/patch-librtlsdr.pc.in b/comms/rtl-sdr/files/patch-librtlsdr.pc.in
index 7a8ae2a687f4..23a615e11a89 100644
--- a/comms/rtl-sdr/files/patch-librtlsdr.pc.in
+++ b/comms/rtl-sdr/files/patch-librtlsdr.pc.in
@@ -1,3 +1,5 @@
+libusb-1.0 is already part of RTLSDR_PC_LIBS
+
--- librtlsdr.pc.in.orig 2014-07-11 08:56:42.640078065 +0000
+++ librtlsdr.pc.in 2014-07-11 08:56:57.487076496 +0000
@@ -7,5 +7,5 @@
@@ -5,5 +7,5 @@
Version: @VERSION@
Cflags: -I${includedir}/ @RTLSDR_PC_CFLAGS@
-Libs: -L${libdir} -lrtlsdr -lusb-1.0
-+Libs: -L${libdir} -lrtlsdr -lusb
++Libs: -L${libdir} -lrtlsdr
Libs.private: @RTLSDR_PC_LIBS@