aboutsummaryrefslogtreecommitdiff
path: root/comms/rxtx
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-10-20 11:17:36 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-10-20 11:17:36 +0000
commit8520c470d71e21de2b51bb80a6f4abc4d355513f (patch)
tree194a1db6eb07b944c6c68bda529edb5139323e15 /comms/rxtx
parentd636ca9b798639601b4740ae14b3400c381cd2e1 (diff)
downloadports-8520c470d71e21de2b51bb80a6f4abc4d355513f.tar.gz
ports-8520c470d71e21de2b51bb80a6f4abc4d355513f.zip
RXTX: serial and parallel I/O libraries supporting Sun's CommAPI. Open-source
implementation of the Java Communications API. Native interface to serial ports in Java. PR: 65396 Submitted by: Jean-Baptiste Quenot <jb.quenot@caraldi.com> Reviewed by: glewis Approved by: glewis (mentor)
Notes
Notes: svn path=/head/; revision=119844
Diffstat (limited to 'comms/rxtx')
-rw-r--r--comms/rxtx/Makefile28
-rw-r--r--comms/rxtx/distinfo2
-rw-r--r--comms/rxtx/files/patch-Makefile.in13
-rw-r--r--comms/rxtx/files/patch-ParallelImp.c14
-rw-r--r--comms/rxtx/files/patch-SerialImp.h13
-rw-r--r--comms/rxtx/pkg-descr5
-rw-r--r--comms/rxtx/pkg-plist7
7 files changed, 82 insertions, 0 deletions
diff --git a/comms/rxtx/Makefile b/comms/rxtx/Makefile
new file mode 100644
index 000000000000..ad43dbf529a4
--- /dev/null
+++ b/comms/rxtx/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rxtx
+# Whom: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
+# Date Created: 2004-04-10 00:15:35
+#
+# $FreeBSD$
+#
+
+PORTNAME= rxtx
+PORTVERSION= 2.1.7p17
+CATEGORIES= comms java
+MASTER_SITES= ftp://jarvi.dsl.frii.com/pub/rxtx/
+PKGNAMESUFFIX= -${JAVA_PORT:S/java\///}
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.([^\.]*)$/-\1/:S/p/pre/}
+
+MAINTAINER= jb.quenot@caraldi.com
+COMMENT= Native interface to serial ports in Java
+
+USE_GMAKE= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+JAVA_OS= native
+USE_LIBTOOL_VER=13
+
+INSTALLS_SHLIB= yes
+MAKE_ENV= JAVA_HOME=${JAVA_HOME}
+PREFIX= ${JAVA_HOME}/jre
+
+.include <bsd.port.mk>
diff --git a/comms/rxtx/distinfo b/comms/rxtx/distinfo
new file mode 100644
index 000000000000..c571203b2c91
--- /dev/null
+++ b/comms/rxtx/distinfo
@@ -0,0 +1,2 @@
+MD5 (rxtx-2.1-7pre17.tar.gz) = 1ae2a0fc82bfb3f7a911f2313c8cad44
+SIZE (rxtx-2.1-7pre17.tar.gz) = 985729
diff --git a/comms/rxtx/files/patch-Makefile.in b/comms/rxtx/files/patch-Makefile.in
new file mode 100644
index 000000000000..c8a3996f115c
--- /dev/null
+++ b/comms/rxtx/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- Makefile.in.orig Fri Apr 9 23:57:20 2004
++++ Makefile.in Fri Apr 9 23:58:06 2004
+@@ -451,7 +451,7 @@
+ echo $$i; \
+ fi; \
+ done` $(RXTX_PATH)
+- $(INSTALL_PROGRAM) $(JARTARGET) $(JHOME)/
++ $(BSD_INSTALL_DATA) $(JARTARGET) $(JHOME)/
+
+ clean-generic:
+ rm -rf $(DEST) $(TOP)/$(CLASSTOP)
diff --git a/comms/rxtx/files/patch-ParallelImp.c b/comms/rxtx/files/patch-ParallelImp.c
new file mode 100644
index 000000000000..24b304efdb6f
--- /dev/null
+++ b/comms/rxtx/files/patch-ParallelImp.c
@@ -0,0 +1,14 @@
+$FreeBSD$
+
+--- src/ParallelImp.c.orig Fri Apr 9 23:31:09 2004
++++ src/ParallelImp.c Fri Apr 9 23:35:01 2004
+@@ -222,9 +222,6 @@
+ #if defined(__linux__)
+ return( status & LP_BUSY ? JNI_TRUE : JNI_FALSE );
+ #endif
+-#if defined(__FreeBSD__)
+- return( status & EBUSY ? JNI_TRUE : JNI_FALSE );
+-#endif
+ return(JNI_FALSE);
+ }
+ /*----------------------------------------------------------
diff --git a/comms/rxtx/files/patch-SerialImp.h b/comms/rxtx/files/patch-SerialImp.h
new file mode 100644
index 000000000000..808d3c10c56b
--- /dev/null
+++ b/comms/rxtx/files/patch-SerialImp.h
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- src/SerialImp.h.orig Sat Apr 24 23:31:27 2004
++++ src/SerialImp.h Sat Apr 24 23:31:38 2004
+@@ -126,7 +126,7 @@
+ #endif /* __sgi__ || sgi */
+ #if defined(__FreeBSD__)
+ # define DEVICEDIR "/dev/"
+-# define LOCKDIR "/var/spool/uucp"
++# define LOCKDIR "/var/spool/lock"
+ # define LOCKFILEPREFIX "LK."
+ # define UUCP
+ #endif
diff --git a/comms/rxtx/pkg-descr b/comms/rxtx/pkg-descr
new file mode 100644
index 000000000000..9e64ad0c5aa1
--- /dev/null
+++ b/comms/rxtx/pkg-descr
@@ -0,0 +1,5 @@
+RXTX: serial and parallel I/O libraries supporting Sun's CommAPI. Open-source
+implementation of the Java Communications API. Native interface to serial ports
+in Java.
+
+WWW: http://www.rxtx.org/
diff --git a/comms/rxtx/pkg-plist b/comms/rxtx/pkg-plist
new file mode 100644
index 000000000000..be7fcafa7323
--- /dev/null
+++ b/comms/rxtx/pkg-plist
@@ -0,0 +1,7 @@
+lib/ext/RXTXcomm.jar
+lib/i386/librxtxParallel-2.1-7pre17.so
+lib/i386/librxtxParallel.la
+lib/i386/librxtxParallel.so
+lib/i386/librxtxSerial-2.1-7pre17.so
+lib/i386/librxtxSerial.la
+lib/i386/librxtxSerial.so