aboutsummaryrefslogtreecommitdiff
path: root/comms/spandsp
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2006-06-16 23:34:22 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2006-06-16 23:34:22 +0000
commitf121cfd31f4fb5774f42f1d89705938b0d6aa583 (patch)
tree344c5800a086fefeb748bb69d057ac302b7878b7 /comms/spandsp
parent18fafae1ca50df4bc333ce4ec4dbd4a262cf37a1 (diff)
downloadports-f121cfd31f4fb5774f42f1d89705938b0d6aa583.tar.gz
ports-f121cfd31f4fb5774f42f1d89705938b0d6aa583.zip
Update to 0.0.2.p26.
Notes
Notes: svn path=/head/; revision=165610
Diffstat (limited to 'comms/spandsp')
-rw-r--r--comms/spandsp/Makefile3
-rw-r--r--comms/spandsp/distinfo6
-rw-r--r--comms/spandsp/files/patch-src-Makefile.in17
-rw-r--r--comms/spandsp/files/patch-src-power_meter.c13
-rw-r--r--comms/spandsp/files/patch-src-spandsp-dc_restore.h16
-rw-r--r--comms/spandsp/files/patch-src-t31.c28
-rw-r--r--comms/spandsp/pkg-plist6
7 files changed, 28 insertions, 61 deletions
diff --git a/comms/spandsp/Makefile b/comms/spandsp/Makefile
index 2170f8e8c153..923a264b13ac 100644
--- a/comms/spandsp/Makefile
+++ b/comms/spandsp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= spandsp
-DISTVERSION= 0.0.2pre20
-PORTREVISION= 1
+DISTVERSION= 0.0.2pre26
CATEGORIES= comms
MASTER_SITES= http://www.soft-switch.org/downloads/spandsp/${PORTNAME}-${DISTVERSION}/ \
${MASTER_SITE_LOCAL}
diff --git a/comms/spandsp/distinfo b/comms/spandsp/distinfo
index e6c26c8b079e..6d367c0f090d 100644
--- a/comms/spandsp/distinfo
+++ b/comms/spandsp/distinfo
@@ -1,3 +1,3 @@
-MD5 (spandsp-0.0.2pre20.tar.gz) = 8d6e94a30fb4698b5f25eb93e26444e1
-SHA256 (spandsp-0.0.2pre20.tar.gz) = 8523c1a4da13e11c5096213e434bc69d96ea65cddde27b5b7fc83bf52787b7ef
-SIZE (spandsp-0.0.2pre20.tar.gz) = 1312403
+MD5 (spandsp-0.0.2pre26.tar.gz) = 2b28a75b1d7c49616534bd7264317241
+SHA256 (spandsp-0.0.2pre26.tar.gz) = 57ac136a61974eb6c8cfd81bab14a514a04a3be8c513cc1682524ec4082d0fc8
+SIZE (spandsp-0.0.2pre26.tar.gz) = 1417752
diff --git a/comms/spandsp/files/patch-src-Makefile.in b/comms/spandsp/files/patch-src-Makefile.in
index 3b8f9a6f252d..b8f1b7b09c03 100644
--- a/comms/spandsp/files/patch-src-Makefile.in
+++ b/comms/spandsp/files/patch-src-Makefile.in
@@ -1,11 +1,14 @@
---- src/Makefile.in~ Thu Apr 28 09:03:02 2005
-+++ src/Makefile.in Thu Jun 23 15:27:14 2005
-@@ -211,7 +211,7 @@
- sysconfdir = @sysconfdir@
+
+$FreeBSD$
+
+--- src/Makefile.in.orig
++++ src/Makefile.in
+@@ -197,7 +197,7 @@
target_alias = @target_alias@
+ AM_CFLAGS = -std=c99
MAINTAINERCLEANFILES = Makefile.in
--INCLUDES = -I$(top_buildir)
-+#INCLUDES = -I$(top_buildir)
+-INCLUDES = -I$(top_builddir)
++#INCLUDES = -I$(top_builddir)
lib_LTLIBRARIES = libspandsp.la
libspandsp_la_SOURCES = adsi.c \
- awgn.c \
+ async.c \
diff --git a/comms/spandsp/files/patch-src-power_meter.c b/comms/spandsp/files/patch-src-power_meter.c
deleted file mode 100644
index 5209632685e7..000000000000
--- a/comms/spandsp/files/patch-src-power_meter.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/power_meter.c.orig Thu Jun 30 22:40:33 2005
-+++ src/power_meter.c Thu Jun 30 22:41:05 2005
-@@ -72,6 +72,10 @@
- }
- /*- End of function --------------------------------------------------------*/
-
-+#ifndef INFINITY
-+#define INFINITY (float)HUGE_VAL
-+#endif
-+
- float power_meter_dbm0(power_meter_t *meter)
- {
- float val;
diff --git a/comms/spandsp/files/patch-src-spandsp-dc_restore.h b/comms/spandsp/files/patch-src-spandsp-dc_restore.h
index d2f63ad0d8e4..2b4ea48bf832 100644
--- a/comms/spandsp/files/patch-src-spandsp-dc_restore.h
+++ b/comms/spandsp/files/patch-src-spandsp-dc_restore.h
@@ -1,14 +1,16 @@
---- src/spandsp/dc_restore.h.orig Tue Jan 18 15:05:48 2005
-+++ src/spandsp/dc_restore.h Thu Jun 30 22:35:33 2005
-@@ -85,6 +85,11 @@
+
+$FreeBSD$
+
+--- src/spandsp/dc_restore.h.orig
++++ src/spandsp/dc_restore.h
+@@ -109,5 +109,10 @@
}
- /*- End of function --------------------------------------------------------*/
+ #endif
+#ifndef INT16_MAX
+#define INT16_MAX 0x7fff
+#define INT16_MIN (-0x7fff-1)
+#endif
+
- static inline int16_t saturate(int32_t amp)
- {
- if (amp > INT16_MAX)
+ #endif
+ /*- End of file ------------------------------------------------------------*/
diff --git a/comms/spandsp/files/patch-src-t31.c b/comms/spandsp/files/patch-src-t31.c
deleted file mode 100644
index 7ffd6abfd2d6..000000000000
--- a/comms/spandsp/files/patch-src-t31.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/t31.c.orig Thu Jun 30 23:07:14 2005
-+++ src/t31.c Thu Jun 30 23:10:28 2005
-@@ -51,19 +51,12 @@
- t31_profile_t profiles[3] =
- {
- {
-- .echo = TRUE,
-- .verbose = TRUE,
-- .result_code_format = ASCII_RESULT_CODES,
-- .pulse_dial = FALSE,
-- .double_escape = FALSE,
-- .s_regs[0] = 0,
-- .s_regs[3] = '\r',
-- .s_regs[4] = '\n',
-- .s_regs[5] = '\b',
-- .s_regs[6] = 1,
-- .s_regs[7] = 60,
-- .s_regs[8] = 5,
-- .s_regs[10] = 0
-+ TRUE,
-+ TRUE,
-+ ASCII_RESULT_CODES,
-+ FALSE,
-+ FALSE,
-+ { 0, 0, 0, '\r', '\n', '\b', 1, 60, 5, 0 }
- }
- };
-
diff --git a/comms/spandsp/pkg-plist b/comms/spandsp/pkg-plist
index 003fe92936d0..e46d42c9ce21 100644
--- a/comms/spandsp/pkg-plist
+++ b/comms/spandsp/pkg-plist
@@ -2,6 +2,7 @@ include/spandsp.h
include/spandsp/adsi.h
include/spandsp/alaw_ulaw.h
include/spandsp/arctan2.h
+include/spandsp/async.h
include/spandsp/awgn.h
include/spandsp/bert.h
include/spandsp/biquad.h
@@ -9,16 +10,19 @@ include/spandsp/complex.h
include/spandsp/complex_filters.h
include/spandsp/dc_restore.h
include/spandsp/dds.h
-include/spandsp/ec_disable_detector.h
+include/spandsp/ec_disable_tone.h
include/spandsp/echo.h
include/spandsp/fir.h
include/spandsp/fsk.h
include/spandsp/g168models.h
+include/spandsp/g722.h
+include/spandsp/g726.h
include/spandsp/hdlc.h
include/spandsp/ima_adpcm.h
include/spandsp/logging.h
include/spandsp/mmx.h
include/spandsp/modem_echo.h
+include/spandsp/noise.h
include/spandsp/oki_adpcm.h
include/spandsp/oss.h
include/spandsp/playout.h