aboutsummaryrefslogtreecommitdiff
path: root/comms/splat
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2018-01-18 19:56:15 +0000
committerDiane Bruce <db@FreeBSD.org>2018-01-18 19:56:15 +0000
commita5d518dcf7400e8853ddc2dce468885bf9b2e2de (patch)
tree8590313aa244a23821c30179ed9a5033318eb4e8 /comms/splat
parent8004627faf75d51d3c3949ebe0c8dee59af6c88f (diff)
downloadports-a5d518dcf7400e8853ddc2dce468885bf9b2e2de.tar.gz
ports-a5d518dcf7400e8853ddc2dce468885bf9b2e2de.zip
- Update to latest version
- Change to new upstream distribution - This also fixes build with clang6 on head Release 1.4.2: By John A. Magliacane <kd2bd@amsat.org> (08-Dec-14) * Modified the "build" script to better accommodate the Mac OSX platform, and fixed a contradiction in the documentation relating to the description of the situational and time variability parameters used in the ITM and ITWOM propagation models. (Thanks John M. Vanderau, AA0DN) * Modified the man pages for improved rendering. (Thanks Randy Berry, N3LRX) * Added a field limit in the citydecoder utility to prevent crashing if the coordinate file being read should contain unexpectantly large fields. (Thanks David Binderman) ---------------------------------------------------------------------------- Release 1.4.1: By John A. Magliacane <kd2bd@amsat.org> (08-Jan-14): * The copyright restriction on the ITWOM 3.0 propagation model has been removed. ITWOM 3.0 code may now be used and modified under the GPLv2 license. * Commented out unused variables and calculations in itwom3.0.cpp to eliminate gcc warnings about unused but set variables. * Fixed a bug that caused path loss graphs to be plotted incorrectly. * Embellished the "citydecoder" utility to handle U.S. Census County Subdivision files, thereby providing an additional source of city names and locations not necessarily contained in previously handled Incorporated Places/Census Designated data files. * Corrected the image size written to the header of Xastir-compatible .ppm maps. * Fixed a bug that sometimes prevented the "Mode of propagation" from appearing in Path Analysis reports when running in -oldtim mode. * Added a -log command line switch that allows SPLAT!'s command line and all associated switches and arguments to be written to a logfile for future reference or re-execution at a later time. * Modified SPLAT!'s "build" script for better handling of OSX. (Thanks Glen Bizeau, VE9GLN) * Changed some coding to eliminate compilation warnings produced by recent versions of GCC. * Brought the documentation up to date.
Notes
Notes: svn path=/head/; revision=459370
Diffstat (limited to 'comms/splat')
-rw-r--r--comms/splat/Makefile6
-rw-r--r--comms/splat/distinfo5
-rw-r--r--comms/splat/files/patch-splat.cpp20
-rw-r--r--comms/splat/files/patch-utils_fontdata.c12
-rw-r--r--comms/splat/files/patch-utils_postdownload4
5 files changed, 28 insertions, 19 deletions
diff --git a/comms/splat/Makefile b/comms/splat/Makefile
index d262753acd8c..626dcc757c01 100644
--- a/comms/splat/Makefile
+++ b/comms/splat/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= splat
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.2
CATEGORIES= comms hamradio
-MASTER_SITES= SUNSITE/apps/ham
-
+MASTER_SITES= http://www.qsl.net/kd2bd/
+#http://www.qsl.net/kd2bd/splat-1.4.2.tar.bz2
MAINTAINER= hamradio@FreeBSD.org
COMMENT= Used in calculating path losses, useful to ham radio and others
diff --git a/comms/splat/distinfo b/comms/splat/distinfo
index 4c0fa193a5ea..0c872a36eae6 100644
--- a/comms/splat/distinfo
+++ b/comms/splat/distinfo
@@ -1,2 +1,3 @@
-SHA256 (splat-1.4.0.tar.bz2) = f081951c68577234668ac2a1e6eff86e60e57e17c470d765900e9d1461058678
-SIZE (splat-1.4.0.tar.bz2) = 357433
+TIMESTAMP = 1516294940
+SHA256 (splat-1.4.2.tar.bz2) = 39b0b314e2e927bdf00d1eda4b9865efd128ba850305f987aec049c4fd58a29c
+SIZE (splat-1.4.2.tar.bz2) = 356823
diff --git a/comms/splat/files/patch-splat.cpp b/comms/splat/files/patch-splat.cpp
new file mode 100644
index 000000000000..0912c8c52806
--- /dev/null
+++ b/comms/splat/files/patch-splat.cpp
@@ -0,0 +1,20 @@
+--- splat.cpp.orig 2018-01-18 17:04:01 UTC
++++ splat.cpp
+@@ -567,7 +567,7 @@ double ElevationAngle(struct site source, struct site
+ (downtilt), as referenced to a normal to the center of
+ the earth. */
+
+- register double a, b, dx;
++ double a, b, dx;
+
+ a=GetElevation(destination)+destination.alt+earthradius;
+ b=GetElevation(source)+source.alt+earthradius;
+@@ -2727,7 +2727,7 @@ void PlotPath(struct site source, struct site destinat
+
+ char block;
+ int x, y;
+- register double cos_xmtr_angle, cos_test_angle, test_alt;
++ double cos_xmtr_angle, cos_test_angle, test_alt;
+ double distance, rx_alt, tx_alt;
+
+ ReadPath(source,destination);
diff --git a/comms/splat/files/patch-utils_fontdata.c b/comms/splat/files/patch-utils_fontdata.c
deleted file mode 100644
index 4bc8afc28556..000000000000
--- a/comms/splat/files/patch-utils_fontdata.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- utils/fontdata.c.orig 2012-11-05 15:44:52.000000000 -0500
-+++ utils/fontdata.c 2012-11-05 15:42:54.000000000 -0500
-@@ -39,7 +39,8 @@
- {
- int x;
- unsigned char line, input;
-- FILE *infile, *outfile;
-+ gzFile infile;
-+ FILE *outfile;
-
- if (argc==2)
- infile=gzopen(argv[1],"rb");
diff --git a/comms/splat/files/patch-utils_postdownload b/comms/splat/files/patch-utils_postdownload
index be6818c9959f..259543c93a67 100644
--- a/comms/splat/files/patch-utils_postdownload
+++ b/comms/splat/files/patch-utils_postdownload
@@ -1,5 +1,5 @@
---- utils/postdownload.orig 2012-11-03 03:56:52.000000000 -0500
-+++ utils/postdownload 2012-11-03 03:57:09.000000000 -0500
+--- utils/postdownload.orig 2009-03-01 17:37:04 UTC
++++ utils/postdownload
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/bin/sh