aboutsummaryrefslogtreecommitdiff
path: root/comms/sredird
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-29 19:35:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-29 19:35:41 +0000
commite4ddb7fa93d52253a6b5e9103ad04d999d58c70c (patch)
tree33579c32d25f25ceff7be9f5da3faa5277e1d133 /comms/sredird
parent6cca510e9b5bcaff518e332fcb50efce7f03abc4 (diff)
downloadports-e4ddb7fa93d52253a6b5e9103ad04d999d58c70c.tar.gz
ports-e4ddb7fa93d52253a6b5e9103ad04d999d58c70c.zip
- Update to 2.2.2
- Take maintainership PR: ports/91033 Submitted by: Frank Laszlo <laszlof@vonostingroup.com>
Notes
Notes: svn path=/head/; revision=152369
Diffstat (limited to 'comms/sredird')
-rw-r--r--comms/sredird/Makefile4
-rw-r--r--comms/sredird/distinfo6
-rw-r--r--comms/sredird/files/patch-aa70
-rw-r--r--comms/sredird/files/patch-ab9
4 files changed, 42 insertions, 47 deletions
diff --git a/comms/sredird/Makefile b/comms/sredird/Makefile
index bd64e1b3193d..e43a53d57c0f 100644
--- a/comms/sredird/Makefile
+++ b/comms/sredird/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= sredird
-PORTVERSION= 2.2.1
+PORTVERSION= 2.2.2
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= system/serial
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= laszlof@vonostingroup.com
COMMENT= RFC 2217 compliant serial port redirector
PLIST_FILES= libexec/sredird
diff --git a/comms/sredird/distinfo b/comms/sredird/distinfo
index 7338127877a9..358c7f41b84f 100644
--- a/comms/sredird/distinfo
+++ b/comms/sredird/distinfo
@@ -1,3 +1,3 @@
-MD5 (sredird-2.2.1.tar.gz) = a6b8f03ddb9657f533bd218110c3e635
-SHA256 (sredird-2.2.1.tar.gz) = 6b9b5afdcd2a5f4740371268055d95d0a24523f7665c747f16cff811cbb5844d
-SIZE (sredird-2.2.1.tar.gz) = 25766
+MD5 (sredird-2.2.2.tar.gz) = e541e4b1cb9fa8fc8ff0e76bb1127cda
+SHA256 (sredird-2.2.2.tar.gz) = 640c47dcd84b3b90640165a38eb336a675fdab06c14c09cae2f4a604cae560d3
+SIZE (sredird-2.2.2.tar.gz) = 25495
diff --git a/comms/sredird/files/patch-aa b/comms/sredird/files/patch-aa
index 01b3a4eaad88..98b5a8c42330 100644
--- a/comms/sredird/files/patch-aa
+++ b/comms/sredird/files/patch-aa
@@ -1,54 +1,52 @@
---- sredird.c.orig Mon Sep 20 15:26:54 1999
-+++ sredird.c Tue Dec 21 11:02:48 1999
-@@ -43,7 +43,12 @@
+--- sredird.c.orig Wed Dec 28 15:35:00 2005
++++ sredird.c Wed Dec 28 15:39:43 2005
+@@ -110,7 +110,12 @@
#include <fcntl.h>
#include <syslog.h>
#include <termios.h>
--#include <termio.h>
-+#ifndef __FreeBSD__ /* FreeBSD */
-+#include <termio.h> /* Doesn't exist on FreeBSD */
++#ifndef __FreeBSD__
+ #include <termio.h>
+#else
-+#include <netdb.h> /* Necessary for getprotobyname(3) function */
-+#include <netinet/in_systm.h> /* Reqired for netinet/ip.h */
-+#endif /* FreeBSD */
++#include <netdb.h>
++#include <netinet/in_systm.h>
++#endif
#include <sys/socket.h>
#include <netinet/in.h>
#include <netinet/ip.h>
-@@ -129,6 +134,14 @@
+@@ -196,6 +201,13 @@
/* Default modem state polling in milliseconds (100 msec should be enough) */
#define ModemStatePolling 100
-+/* FreeBSD specific definitions */
-+#ifdef __FreeBSD__ /* FreeBSD */
++#ifdef __FreeBSD__
+struct tms mytms;
-+#define times(NULL) times(&mytms) /* Coz times(NULL) coredumps on FreeBSD */
-+#define SOL_TCP getprotobyname("TCP")->p_proto /* SOL_TCP and SOL_IP undefined */
-+#define SOL_IP getprotobyname("IP")->p_proto /* on FreeBSD */
-+#endif /* FreeBSD */
++#define times(NULL) times(&mytms)
++#define SOL_TCP getprotobyname("TCP")->p_proto
++#define SOL_IP getprotobyname("IP")->p_proto
++#endif
+
/* Standard boolean definition */
typedef enum { False, True } Boolean;
-@@ -571,8 +584,10 @@
- return(115200UL);
- case B230400:
- return(230400UL);
-+#ifndef __FreeBSD__ /* Sadly, but FreeBSD doesn't support rates > 230K */
- case B460800:
- return(460800UL);
+@@ -714,8 +726,10 @@
+ return(115200UL);
+ case B230400:
+ return(230400UL);
++#ifndef __FreeBSD__
+ case B460800:
+ return(460800UL);
+#endif
- default:
- return(0UL);
- }
-@@ -954,9 +969,11 @@
- case 230400UL:
- Speed = B230400;
- break;
+ default:
+ return(0UL);
+ }
+@@ -1094,9 +1108,11 @@
+ case 230400UL:
+ Speed = B230400;
+ break;
+#ifndef __FreeBSD__
- case 460800UL:
- Speed = B460800;
- break;
+ case 460800UL:
+ Speed = B460800;
+ break;
+#endif
- default:
- LogMsg(LOG_WARNING,"Unknwon baud rate requested. Setting to 38400");
- Speed = B38400;
+ default:
+ LogMsg(LOG_WARNING,"Unknwon baud rate requested, setting to 9600.");
+ Speed = B9600;
diff --git a/comms/sredird/files/patch-ab b/comms/sredird/files/patch-ab
index 6547065ee220..f64fc37e5713 100644
--- a/comms/sredird/files/patch-ab
+++ b/comms/sredird/files/patch-ab
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- README.orig Thu Nov 14 11:29:17 2002
-+++ README Mon Feb 17 15:25:24 2003
+--- README.orig Wed Dec 28 15:40:48 2005
++++ README Wed Dec 28 15:42:52 2005
@@ -101,21 +101,19 @@
5 - Installation
@@ -13,7 +10,7 @@ $FreeBSD$
configuration file (usually /etc/inetd.conf) should look like this:
-sredir stream tcp nowait root /usr/sbin/tcpd /usr/sbin/sredird -i 5 /dev/modem /var/lock/LCK..modem
-+sredir stream tcp nowait root /usr/local/libexec/sredird sredird -i 5 /dev/cuaa0 /var/spool/lock/LCK..cuaa0
++sredir stream tcp nowait root /usr/local/libexec/sredird sredird -i 5 /dev/cuaa0 /var/spool/lock/LCK..cuaa0
Of course, "sredir" should be defined in the services file (usually
-/etc/services, usual values start at port 7000) and "/dev/modem" should