aboutsummaryrefslogtreecommitdiff
path: root/comms/sunxi-tools
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-25 15:53:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-25 15:53:12 +0000
commit08c13bcac565bdff0f385544a236e5ba7c4d99f5 (patch)
tree09f8a2a8f43fda5da57ad8e1327cb426acc1547e /comms/sunxi-tools
parent0825b181a77f0a1fbe7b05c2e21597971023572c (diff)
downloadports-08c13bcac565bdff0f385544a236e5ba7c4d99f5.tar.gz
ports-08c13bcac565bdff0f385544a236e5ba7c4d99f5.zip
Tools to help hacking Allwinner A10 (aka sun4i) based devices and possibly
it's successors, that's why the 'x' in the package name. WWW: https://github.com/linux-sunxi/sunxi-tools PR: 213250 Submitted by: manu
Notes
Notes: svn path=/head/; revision=446592
Diffstat (limited to 'comms/sunxi-tools')
-rw-r--r--comms/sunxi-tools/Makefile19
-rw-r--r--comms/sunxi-tools/distinfo3
-rw-r--r--comms/sunxi-tools/files/patch-Makefile29
-rw-r--r--comms/sunxi-tools/pkg-descr4
-rw-r--r--comms/sunxi-tools/pkg-plist7
5 files changed, 62 insertions, 0 deletions
diff --git a/comms/sunxi-tools/Makefile b/comms/sunxi-tools/Makefile
new file mode 100644
index 000000000000..747e139d9c0a
--- /dev/null
+++ b/comms/sunxi-tools/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= sunxi-tools
+PORTVERSION= 1.4.2
+DISTVERSIONPREFIX= v
+CATEGORIES= comms
+
+MAINTAINER= manu@freebsd.org
+COMMENT= Tools to help hacking Allwinner devices
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USE_GITHUB= yes
+GH_ACCOUNT= linux-sunxi
+
+USES= gmake pkgconfig
+
+.include <bsd.port.mk>
diff --git a/comms/sunxi-tools/distinfo b/comms/sunxi-tools/distinfo
new file mode 100644
index 000000000000..0aea9fc12f18
--- /dev/null
+++ b/comms/sunxi-tools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1499609673
+SHA256 (linux-sunxi-sunxi-tools-v1.4.2_GH0.tar.gz) = 81f48014a520cb83cac4e17f5ae627a637c4d6a422b60c693c5a705c92e43822
+SIZE (linux-sunxi-sunxi-tools-v1.4.2_GH0.tar.gz) = 84090
diff --git a/comms/sunxi-tools/files/patch-Makefile b/comms/sunxi-tools/files/patch-Makefile
new file mode 100644
index 000000000000..9e0ed40d773c
--- /dev/null
+++ b/comms/sunxi-tools/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- Makefile.orig 2016-11-29 13:07:51 UTC
++++ Makefile
+@@ -17,7 +17,7 @@
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ CC ?= gcc
+-DEFAULT_CFLAGS := -std=c99
++DEFAULT_CFLAGS += -std=c99
+ DEFAULT_CFLAGS += -Wall -Wextra -Wno-unused-result
+
+ DEFAULT_CFLAGS += -D_POSIX_C_SOURCE=200112L
+@@ -63,7 +63,7 @@ BINDIR ?= $(PREFIX)/bin
+ tools: $(TOOLS) $(FEXC_LINKS)
+ target-tools: $(TARGET_TOOLS)
+
+-all: tools target-tools
++all: tools
+
+ misc: $(MISC_TOOLS)
+
+@@ -75,7 +75,7 @@ install-all: install-tools install-target-tools
+ install-tools: $(TOOLS)
+ install -d $(DESTDIR)$(BINDIR)
+ @set -ex ; for t in $^ ; do \
+- install -m0755 $$t $(DESTDIR)$(BINDIR)/$$t ; \
++ $(BSD_INSTALL_PROGRAM) $$t $(DESTDIR)$(BINDIR)/$$t ; \
+ done
+ @set -ex ; for l in $(FEXC_LINKS) ; do \
+ ln -nfs sunxi-fexc $(DESTDIR)$(BINDIR)/$$l ; \
diff --git a/comms/sunxi-tools/pkg-descr b/comms/sunxi-tools/pkg-descr
new file mode 100644
index 000000000000..06390a2f5981
--- /dev/null
+++ b/comms/sunxi-tools/pkg-descr
@@ -0,0 +1,4 @@
+Tools to help hacking Allwinner A10 (aka sun4i) based devices and possibly
+it's successors, that's why the 'x' in the package name.
+
+WWW: https://github.com/linux-sunxi/sunxi-tools
diff --git a/comms/sunxi-tools/pkg-plist b/comms/sunxi-tools/pkg-plist
new file mode 100644
index 000000000000..a8e19f6cb63e
--- /dev/null
+++ b/comms/sunxi-tools/pkg-plist
@@ -0,0 +1,7 @@
+bin/bin2fex
+bin/fex2bin
+bin/sunxi-bootinfo
+bin/sunxi-fel
+bin/sunxi-fexc
+bin/sunxi-nand-part
+bin/sunxi-pio